Yesterday I had everything I needed:

RoadTest02.jpg

Components from Farnell, samples of the microcontroller from EnergyMicro, and PCB's from Wuerth / WE-Direkt  !

And to further thank the main contributors to this build:

RoadTest03.jpg

From left to right: coil by Wuerth, LTC3108 from Linear and of course the GiantGecko from EnergyMicro!

 

Building and debugging - No power, no connection........

 

I had some trouble getting the design going. I soldered everything in place, omitting a few C's to play with startup time / energy reserve later on. I then connected the thermo electric element, and hoped I would see power getting up.... Unfortunately: no luck! I connected my power supply instead, and would only see the regulator do something  (peaking to 0.3V, then slowly decreasing again) when I would adjust the input voltage. Somehow the regulator wasn't working..

Debugging

OK. Let's try the other major component, the microcontroller. Until now, I've used the microcontroller that is placed on the STK3700, now I wanted to use the STK3700 to program an external microcontroller. I started eAcommander, and chose 'Debug Out' as option. I then noticed that I shouldn't use the signals in the lower right corner of the STK3700 (SWD, SWIO, #RESET),  but on the shrouded header, because a nice bright LED was shining next to that connector. If I had read 'application note AN002' before, I would have known that.... Now I had it connected, but had the problem that during programming I would get a popup  "Unable to read from SRAM". I looked at some posts on the EM forum (Lizard Lounge), and found that it could be that the device was locked.... For a pristine device that looked unprobable to me, but I tried unlocking anyway (button in the eAcommander), indeed without effect. I re-inspected the solder work, and discovered a small tin sliver going from SWD to SWDIO; no wonder the debug interface didn't work! I reworked those pins, and... Succes! I could program my external EFM32! I was very happy with this; with this new succes I started with new hopes on the DC/DC converter.

RoadTest01.jpg

Debugging interface; I soldered a single-in-line socket next to the header, to use jumper cables.

 

DC/nothing converter......

Unfortunately I had less luck here. The converter still behaved the same. Even the LDO and VAUX pins wouldn't get any voltage higher than 0.3V.... I was getting very frustrated, as no line would start switching whatever I tried... Then I thougt about the orientation of the transformer; I had already taken second looks at the layout of the demo board when I was designing, because I found the pinout a bit unclear, so I thought I'd take a second look there as well.

* Schematic? The same....

* Layout? The same....

* Placement of transformer? Different!

The transformer was rotated 90 degrees with respect to the pin 1 location on the component! I'll have to look into this when I have more time, but this was really frustrating. I desoldered the coil (luckily I have a hot air station), and rotated it. Next I applied power, and.... Nothing.

 

I did find out I had 2.2V out on the LDO pin, but no output on the VOUT pin. The amount of current drawn from the supply is ridiculous (40mA), so I guess I've messed something up. This is the state I left the project in last night. Tonight I'll do part two....

RoadTest05.jpg

Current state of affairs