Previous posts for this project:

 

 

Introduction

 

On Monday, I received a package from element14. It contained the two TI Launchpads provided for the challenge: MSP430FR5969 and CC3200.

Now, i've never worked with Launchpads before, so all of this is new to me.


In this post, I'll try to get started with Launchpads and the associated software.

 

Struggling

 

There seem to be (at least) two different software packages to work with TI Launchpads: Energia and Code Composer Studio.

 

Energia seems to be the Launchpad version of the Arduino IDE, while CCS (Code Composer Studio) is a more elaborate IDE based on Eclipse.

Unfortunately, CCS is not available for Mac ... So I went ahead and continued with Energia instead.

Screen Shot 2014-10-26 at 17.10.37.png

I downloaded the MacOS X version of Energia from Download | Energia and started the installation.

Once Energia was installed, I tried to run it. This returned a message that a legacy version of Java was required.

Screen Shot 2014-10-26 at 17.00.53.pngScreen Shot 2014-10-26 at 17.01.21.png

 

I installed Java 6 by following the instructions and tried running Energia again, only to be confronted with a new warning message.

Screen Shot 2014-10-26 at 17.02.39.pngScreen Shot 2014-10-26 at 17.04.00.png

 

This time, my Mac was refusing to launch the application because it is from an "unidentified developer". This was probably due to some security settings on my Mac. Luckily, I found that by "right" clicking, and selecting "Open", the popup message was different and allowed me to run the application.

 

At last, Energia was up and running. That wasn't too hard, and the problems that were encountered, were overcome easily.

Screen Shot 2014-10-26 at 17.05.27.png

 

Competitors were provided two Launchpads for this challenge. I thought I'd start with the MSP430FR5969 and later on proceed with the CC3200 as I got more familiar with the Launchpad and software.

As with Arduino, I wanted to start off with something very basic: blinking LEDs.


From the examples, I loaded the Blink sketch, and tried to upload it to the board.

Screen Shot 2014-10-27 at 20.56.28.pngScreen Shot 2014-10-27 at 20.58.43.png

 

This returned an error that my Launchpad's firmware needed to be updated. Unfortunately that kept failing at a certain point, saying it was an unknown device. What now ?

 

tilib: MSP430_OpenDevice: Unknown device (error = 5)

tilib: device initialization failed

 

I posted my question in the TI support thread (Have a Question for TI?  Ask it Here!) but have yet to get an answer from anyone. In parallel, I searched the world wide web for answers.

It would seem that the new MSP430FR5969 with EnergyTrace feature is not properly supported yet, and a new version of Energia (with new drivers) is required. Proposed solutions were to either use CCS (which is not available on Mac) or to manually patch/update the driver. Unfortunately, always referring to Windows or Linux, not Mac.

 

It seems like I won't be able to move forward with Launchpads on my Mac for the time being ...

 

Fallback

 

By lack of working options on my Mac, I ended up falling back to my old Windows XP desktop PC ... It's old and slow, but I have no other choice.

 

I installed Energia on it, but encountered the same issue as before. So I installed CCS6 and guess what ? It recognised the Launchpad properly!

With CCS up and running, and the board recognised, I was finally able to upload a sketch to my MSP430FR5969 Launchpad!

CCS-Energia SKetch.PNG

 

CCS requires some getting used to, but I was able to rather easily find my way and upload the sketch. Even the "EnergyTrace" feature mentioned earlier made an appearance (lower-right corner in the screenshot). It seems to be able to provide live feedback on the Launchpads power consumption. I'll have to look up this feature to find out what it's all about!