Apparently "Start a Discussion" and "Write a Blog Post" have the same templates and look the same, but are not. Some things I'm good at, knowing the difference between those two, not so much.

 

Last Wednesday, switched from the PSoC 4 Pioneer Kit to the Development Kit that has the PSoC 1, 3, and 5. I purchased the 4 for it. Then started with the 5 for Temp Kit, which the literature and docs state the 3 and 5 are same-same for usability. But trying to program the 5 yielded an error in Creator that it isn't the 3. So, placing the 3 on the Dev Kit, it programs. Trying to use the Temp Kit and the CapSense Touch Expansion Kit, both failed as they had the same issues.

 

The issue:

The Dev Kit states only the Port A can be used for both the Temp Kit and CapSense Kit.

 

Net name on Dev Kit at Port A is P5_5 which connects to Temp Kit P0_5.

 

So, the code pin net name should tie to its' physical Dev Kit net name, P5_5, but the Temp Kit Net Name was used instead. So the PSoC 3 tried to its' P0_5 which is the Dev Kit's Port B. Exact same thing on the CapSense Kit.

 

Both codes route to Port B. Plugging either kit into Port B doesn't work. There is partial results, but bottom line: DON'T TRUST THE CODE. The pin mapping is all wrong.

 

The amount of work going through and remapping I/Os is the same as having to start from scratch. So that is where I'm at. Dropping the 4 onto the Dev Kit and creating from scratch.

 

Using the code example for the Voltage Display was awesome. That worked great. But trying to run the CapSense, is sluggish and doesn't seem to know what to do with the MiniProg3. Creator is just hanging and hanging. I do wonder if using my 4 month old HP Envy laptop is part of the comm's issue. Or if my Agilent or National Instruments SW is secretly on in the background trying to control the USB. This was an issue once and was corrected. But I feel strongly that your general off-the-shelf PC these days (desktop or laptop) and Windows 8.1 OS are not hardware/test equipment friendly.

 

I do have a 7 year old desktop with an Intel P4 3.4 GHz machine collecting dust under the desk. Maybe I can find Win 7 somewhere. Last thing I want to do, spend a day and a half setting up and configuring an antiquey Windows machine.

 

Last week, also purchased LEDs with I2C controllers. Purchased different LEDs that use NRZ Comm, too. As I will be creating my own CapSense Buttons, also purchased copper tape with adhesive on the back.

 

ALL THIS STUFF is like physically running in a foot race. The training is fine, the race will be fine. But you cannot train and run as you've a hole in one sock and the other is lost. Then your trainers are missing 'cause the dog made off with one and chew-toyed the other. And your shorts have been chafing you and so now your skin is red and irritated. Plus, the cat barfed on your shirt.

 

Gotta keep the Finish Line Ribbon in the mind's eye.

 

Gold Metal B!tches!