Skip navigation

BeagleBoard

1 Post authored by: interested1

MainImage.png

Background:

I have been enjoying my Beagle Bone Black for a few days now, but have been ready to take the beagle for a walk off the officially supported hardware path.  My mission: could I get the unsupported Camera Cape working despite no official support (so don't bother the developers about support questions) and not all that much to work with?  Succintly, YES! 

 

 

Black Ops. Plan:  all that follows relates to an unsupported cape and my own attempts to get it working on the Beagle Bone Black.  Please note that this is one person's confirmation of success.  I will give you some details of the journey to get this working, but mostly provide enough detail to excite the community into their own investigation.  With some good sluething you too can get your camera board working on the Beagle Bone Black.

 

 

Details:

My plan was simple, check the web and see if I couldn't find an SD dump of a developer's hack and then dd that onto my own card.  Once I got a hold of a devloper's SD dump, flashed my microSD card, and got the Beagle to boot off of the card I then mounted the camera cape.  I would be more detailed, but at the time I wasn't really taking notes or thinking I could get this to work.  Anyway, the first boot with the the caped Beagle you have to be patient as it seems to take a bit longer to boot that normal.  One key to look for is the two lights on the camera cape to be illuminated solid... if you have this, then you are getting close to Beagle sight.  Another issue to be aware of is that sometimes the Beagle seems to hang.  I am unsure if it actually hanging at boot, but the symptoms are that two of the Beagle's LEDs are illuminated and none of the chaotic flashing that signals proper operation.  What you want is for all four of the Beagles LEDs to be going wild and the two LEDs on the camera cape to be solid.  If you get to this point you have done most of the difficult stuff...

 

Once the Beagle booted with the cape on I got to the developer's GUI login --recall I didn't make the installation-- with usernames and passwords I had no clue about.  For good reason root was not an option at the GUI login; however, my Linux experience compelled me to attempt to switch tty and attempt to login as root --hoping that there remained no password set on the root account.  Success! 

 

Once logged in as root, and having written down the username I wanted to become since I don't like to use Linux as root, I did a simple password change for that user and jumped back to the GUI login.

 

 

At this point I began to feel like I had the Beagle and Cape in my clutches; yet, all was not finished...

 

Screenshot-1.png

 

The above dmesg looked good to me and it might give a clue to how to get this [redacted?].

working.png

Since everything was seemingly working at this point I fired up cheese to test out the camera cape's talents viz. snapping pictures.  The screenshot above includes the dmesg covering the cape manager reportage and both the cheese and Gimp apps all running. 

 

On the initial running of cheese you will need to tweak the preferences.  For whatever reason the defaults in cheese have the camera set at an absurdly high resolution and with a very dark contrast.  This is the easiest fix in the entire mission!  Simply navigate your way to the preference menu in cheese and make the appropriate adjustments.

 

After a bit of tinkering with the preferences within chesse I could take pictures like the one below:

Cheese.jpg

 

Conclusion:

So I hope I have sparked your interest in trying to get unsupported hardware working on the Beagle Bone Black.  This is not a howto nor a guide, so please don't be upset that this is a provocation only.  If I can get this working, so can you!

 

Happy Hacking!