NanoRama

Enter Your Project for a chance to win a Nano Grand Prize bundle for the most innovative use of Arduino plus a $400 shopping cart!

Submit an EntrySubmit an Entry  Back to homepage
Project14 Home
Monthly Themes
Monthly Theme Poll

 

Things were moving along nicely.  My 3D prints were fitting together well.  My software was mostly working (I have a few features left to go).  And then crash!   The wheels came off the bus.

 

Backing up a bit, my PCBs arrived Monday afternoon.  I started test fitting modules, doubling checking the heights of the various components.  Everything was looking good.  I was getting ready to populate the PCB, first double checking the signal between my protoboard and my PCB.  Oops, I started noticing some discrepancies.  Looking deeper, it suddenly occurred to me that I had swapped the to connectors on the Nano footprint.  Yeah, I probably should have double checked things prior to ordering the boards.  Yeah, I should have used a standard library element for the Nano device, but I had decided to go quick and dirty.  And boy, did it end up to be dirty, I mean really messy.

 

As I sat there, trying to plan a recovery path, I came up with an idea.  If I flipped the Nano over in 'dead bug' style, the signals would line up.  So, I fired up the soldering iron.  I removed the two 15-pin headers from the Nano, and re-solder on some nice new ones to the opposite side of the Nano.

Nano flipped (bottom)Nano flipped (top)

 

I then proceeded to populate one of my new PCBs.  After I finished the assemble, and rechecked the fit of the board in the enclosure, I decided to fire it up and drop some code onto the modified Nano.  Crash!  First thing that I noticed is that the USB port on the Nano did not connect (no device connection sound).  So, I unplugged the Nano from the PCB.  Hurray, a connection.  I then decided to upload the software onto the Nano.  Or I should say try to load the software onto the Nano, as IDE had a large red banner with a "Problem uploading to the board" message.  Not sure if I damaged my Nano during the surgery, but I need to step back a bit and figure this out.

 

Error message

 

So, where am I?  I did manage to get everything to fit and look pretty good.

 

Populated BoardPopulated Board (side view)

Everything fit into the case.

 

Populated Board on bottom lid.Populated Board between lids.

Now I need to step away and lick my wounds (mostly ego) and see if I can come up with a plan to finish this project within the deadlines.  I have my doubts, as I have a ton of projects that also need my attention, but only time will tell.

 

Thanks for all the great comments and support along the way.  It has been fun trying out the Arduino.  I find it very similar to Visual Basic, everything comes together quickly, but as you get further into the project, the progress diminishes.  I ran into several dead crashes. Code that mostly worked, but was a little tweaky.  Several problems with resource conflicts.  I am sure that playing with it more, I might sort out my issues, but having built so many projects from scratch, I am just not sure that Ardunio offers me anything more than I could build myself.  Time will tell.

 

Update - 5/6/2020 - It's alive!

 

This might be a record for me.  I made 4 wiring errors on an 8-pin device.  I generated my schematic by transcribing the protobroad wiring.  Somehow on the DMX (RS-485) transceiver, I flipped the power and ground, as well as the transmit and receive lines (2 signals on each side the device), causing the FTDI chip on the Ardunio to not properly connected (overloading the power??).  I was able to cut and jumper the errors and I have a functioning device (except that I some how swapped the up/down and left/right signals - which a simple code change will correct).

 

It's alive!

I still have a bunch of little things to fix and/or complete, but at least I will soon be back to same level of functionality as my old protoboard setup.

 

Thanks again for all the kind words and encouragement.  This really is what makes this community so great!