********************ISSUE RESOLVED. Credit to shabaz for identifying that a networking device was the issue.  ***********************

 

I would like the assistance of members that have PoE experience in reviewing my findings to help troubleshoot Ethernet failure under PoE.

 

I powered up the Pi4B & PoE Hat using a PoE power supply and managed to ssh over the wired Ethernet connection. Satisfied it worked, I command lined "sudo shutdown -h now" so I could teach go teach a class. When I cycled the PoE power supply on my return, the configuration failed to work. I determined Ethernet network was not being detected under PoE.

 

To isolate the issue, I ran a number of scenarios. I found it almost impossible to describe in writing the testing scenarios. Being a visual learner, pictures of each scenario seemed easier.  The attached drawing shows the hardware, connections and power status for each scenario. My interpretation of the results suggest the PoE power supply and PoE Hat are not at fault. The issue is with the Pi4B. Not working also means no indicator lights on the Pi RJ45 Ethernet Jack.

  • Compare scenario B & G: PoE power supply not at fault.
  • Compare scenario A & E & I: PoE Hat not at fault.
  • When you rule everything else out, what do you have left Pi4B

The PoE Hat controls the Pi Ethernet interface via the PoE headers. Would the PoE Hat have changed something (i.e. firmware/software) in the Pi4B when it detected PoE? It did work. I confirmed by checking logs. But only once.

 

An O/S re-install did nothing to resolve the issue.

 

If you look at the scenario's you will note the final scenario "J" using a Pi3B+ has not been ran. The scenario would use the PoE Hat to power the Pi3B+. The Pi3B+ is a personal device, not provided as part of the RoadTest. I am concerned running this scenario may render the Pi3B+ in the same state as the Pi4B.

 

Is the fault with the PoE Hat? Is it with the PoE power supply? Maybe it is the Pi4B? I am looking for individuals to review my findings and provide their insight.