Version 1

    This is a rarely encountered error that can occur when generating your Gerber outputs (extended RS274X format).

    It is nothing to panic about, the cause is known and workarounds are available.


    The Gerber format uses Apertures (D-Codes) for drawing your circuit. You can think of Apertures as different pen sizes, typically each unique shape and track width will have an Aperture assigned and the plot image is made up of 'flashed' and 'drawn' apertures to create the plot. CircuitStudio supports a maximum aperture number (D-Code) of 999 so if you have too many unique shapes in your design it will trigger this error. Complex shapes link polygons do not need their own aperture but fills (Home | Fill) do when using the extended format (RS274X).


    We cover three potential solutions that will allow you to generate your Gerber output and get your board manufactured.


    1. Output Layers Individually

    Typically a single layer will not require more than the maximum number of apertures so you can use Outputs | Gerber and generate one layer at a time. Depending on your design it may be possible to select several layers, you will need to experiment. Use RS274X format and all the information regarding the Aperture assignments are contained within the Gerber file itself so it is safe to generate the files individually.


    2. Don't Use Embedded Apertures (RS274X)

    CircuitStudio supports the older Gerber format where the Aperture definitions are placed into a separate file and each plot layer then makes use of those common definitions. It is recommended to generate all layers at once with this format to prevent any mismatch between the definitions and the drawn layers. When using this option ensure that Gerber Setup : Apertures : Flash all fills it not checked to prevent an excessive number of apertures being required.

    After selecting the layers to plot (this should be all the layers required), Clear the list and then click Create List From PCB to calculate the required apertures. Scroll down the list to make sure you have not reached D999, if you have then too many apertures are required and you should consider using a different workaround technique.


    3. Switch from using Fills to Polygons

    You can determine if the number of fills used on a design is likely to be a problem. Click View | Filter then in the PCB Filter window select Groups:<All>, Objects:Fill and Layers:<All>. At the bottom of the window you will get a count of objects that pass the filter. If this is a high number (approaching 900 or more) then it is very likely that the number of fills is causing your Gerber output error. If you want to use extended Gerber format then you can either use the first workaround (generating one layer at a time) or rework your design to use polygons rather than rectangular fills.