Version 4

    Applies to Versions: [1.5.1]

     

    CircuitStudio, through its use of a modern ribbon interface, is designed to be easy to use and accessible to those whose full time job is not PCB design. Those wishing to access the full power of the product will be interested in these extra commands that are not accessible via a button or other dedicated UI element.

     

    The following are accessed by typing a search string into the search bar on the upper right of the editor window.

     

    The search string should be the command name or a few characters from it so that it will be returned in the search results dropdown.

     

    PCB Editor

    Convert > Create Region From Selected Primitives

    Deselect > Touching Rectangle

    Deselect > Touching Line

    Design > Make PCB Library

    Paste Array...

    Pin/Part Swapping > Automatic Net/Pin Optimizer...

    Pin/Part Swapping > Configure...

    Pin/Part Swapping > Interactive Differential-Pair Swapping

    Pin/Part Swapping > Interactive Part Swapping

    Pin/Part Swapping > Interactive Pin/Net Swapping

    Place > 3D Body

    Report > Measure Selected Objects

    Select > Touching Rectangle

    Select > Touching Line

     

    PCB Library Editor

    Convert > Create Region From Selected Primitives

    Deselect > Touching Rectangle

    Deselect > Touching Line

    PCB Lib Placement > Paste Array...

    Tools > Component Wizard

    Tools > Library Splitter Wizard...

    Reports > Library Component

    Reports > Library List

    Select > Touching Rectangle

    Select > Touching Line

     

    Schematic Editor

    Deselect > Touching Rectangle

    Deselect > Touching Line

    Design > Create Sheet From Sheet Symbol

    Design > Create Sheet Symbol From Sheet

    Port Cross Reference > Add To Project

    Port Cross Reference > Add To Sheet

    Port Cross Reference > Remove From Project

    Port Cross Reference > Remove From Sheet

    Select > Touching Rectangle

    Select > Touching Line

     

    Schematic Library Editor

    Deselect > Touching Rectangle

    Deselect > Touching Line

    Edit > Paste Array...

    Select > Touching Rectangle

    Select > Touching Line

    Tools > Configure Pin Swapping...

     

     

    Do you know of any more useful commands? If so let us know in the comments section below.