Version 1

    Sometimes it can be really handy to export for documentation purposes or importing into other CAD applications. Although CircuitStudio can generate PDF documents it doesn't directly export to any graphical image formats. As a Microsoft Windows program it does support the clipboard making exporting images possible without the need for dedicated options within the application.

     

    PCIe 4 port serial interface example provided with CircuitStudio.

     

    Using copy and paste it is possible to copy the image into Microsoft Word or other Windows applications.The one big drawback is the lack of title block - this does not copy so it may be necessary to perform a screen capture (as above). The following free applications can be used to convert the image into DXF or SVG format.

     

    SVG with Inkscape

     

    This free application Inkscape has the capability to export both DXF and SVG. In CircuitStudio use Select > All then Copy and in Inkscape paste the drawing into your document. One minor issue you may notice with text is that the background is white rather than transparent and a very fine bounding box to the text.

     

    After that is it just a matter of using File > Save As > Plain SVG. The SVG export works well as you can see in the image below.

     

    The DXF export is not usable because of the loss of text. When copy and pasted from CS the text comes across as bitmaps and so does not convert to DXF format.

     

    DXF with Inkscape via PDF

     

    To work around the issue of bitmap text, from CS print the schematic sheet to a PDF file and open with Inkscape. Once open ungroup the objects (you might need to this a couple of times) and then select all objects (in particular the text) and run Path > Object To Path. This converts the text fonts into outlines. Once complete File > Save As > Desktop Cutting Plotter (AutoCAD DXF R14) (*.dxf). The resulting output is an outline drawing as can be seen below (viewed using the free online Autodesk viewer).