I won the Cel Robox as a part of the IoT Holiday Lights Design Challenge and was quite happy to be the owner of a Best In Class 3D Printer. This would be my first 3D printer and had been wanting one for ages. A week after the announcement, I received the Robox... Happy Day. Unaware of what was to come I unboxed it and allocated a place for it on my desk. This is the story of what came next. Here we go...


What is the Cel Robox

The Cel Robox is a micro manufacturing Platform. My mother refused to call it a printer as it was misleading and since it produces small objects, the description fits. For the uninitiated, a 3D printer uses molten plastic to assemble models in a layer wise fashion. This involves careful calibration of the surface on which the manufacturing happens as the laws of physics apply and if you can abode by them, you can make magic happen.


Understanding that involves a simple example. Say I want to make a small bridge in plastic. I cannot manufacture a straight line in mid air and hence the software will make 'supports' to allow making the impossible, possible.


The Cel Robox is different from most of the 3D printers out there because...

1. The calibration is supposed to be automatic. Theoretically, You need not 'adjust' the machine. Just plug and play

2. The build platform is enclosed instead of being open. This allows for better temperature control over the environment.

3. It has Dual Extruder which means that there are two thickness at which the printer can spit out plastic. Speed vs accuracy- You select.

4. Smart Reels means that the settings for the materials being used are made available to the printer as soon as you plug in the reel.


Though this sounds magical, it is still a machine and it will give you a reality check once in a while.


My Unboxing


When I received, the Robox, it was packaged extra nicely by the great folks at element14. It was a Box within a Box and in the final box was my printer. There was a tape which said "Opened for customs" which meant that Indian Customs has already snuk a peek at my prize. I took out the accessories box and set it aside and went straight for the printer. Beautiful Blue! I had set it on my table and took off the tape on the front. I could not open it since it needed the software instructions for it to unlock the door. I had installed Automaker the day the results were announced hence I plugged everything in the light told me it was ON. Pressing 'Unlock' on the Automaker made it clunk around inside and finally unlock the door. The plastic clips on the x Axis fell off with the movement and I wondered how I could have taken them off without activating anything. The clips are also test prints which are made in the factory using a RED PLA which I later found out. One of them was not a good print and would have made me sweat at the first instance that it had failed a print in factory but then ignorance is a bliss.



As I selected the phone stand from Mini Factory and started the print, I began to wonder what will happen next. I watched in awe as the first strand of PLA came out from the nozzle and then was dragged onto the bed. Something is wrong! I canceled the print and went online to research.

I later found out that there is a 'wiper blade' which is supposed to clean the nozzle but it was missing! Did Customs take it out!? Will it never work!? Horror!


Dr. Defeo assure me that it would be replaced if it had been removed by customs but then I realized that the front had never been opened. I lifted the Robox and as I shifted it side to side, I could hear something... moving.


My suspicions were confirmed by Andy(workshopshed) and I proceeded to take out screws for the electronics panel. Two screws and a gentle push of clips later I was in and saw the "wiper blade" waiting for me. I took the obligatory pictures and respectfully put back the panel making sure nothing else was disturbed. There was a Ferrite Core hanging which I left as is for now since I did not know what purpose the loose core served.(Assembly slacking?)

2015 - 2.jpg

After restoring the rogue part to it's rightful place I proceeded to reprint the phone stand on draft quality.

Success! A half hour of drooling and awes later I had a hot piece of plastic which resembled the one on my screen. I wish I had taken a video of it...



The problems


Fast forward to a few days back. The Cel Robox got no assignments due to a family tragedy a few weeks back and I went into a bad place which ate up a lot of things. On a mental return, i recommissioned the robox to print small robot head for a pending project. I noticed that a part of the first layer was thinner than the others but it was OK since I was printing. A few small prints later, the results began to fail. I needed to print a longish connecting rod and it kept failing. I tried all sorts of calibrations but nothing worked. Finally, I shrunk it down and layed it to as close to the right side as I could. It worked but I knew there was an issue.




I manually inspected the bed to identify abnormalities but could not find any. I looked high and low for remaining pieces of plactic which could be sabotaging my prints but to no avail. I tried manually putting a sheet of aluminium to elevate the left side. Worked once I think but then again failed the next time. I tried using paper sheets to elevate the right side and level the gantry which seemed to have worked at the time. Then I leveled the gantry again without the paper and it almost seems level.



Multiple Nozzle height calibrations and gantry level permutations later, the problem remain.


I have scoured the forums with no useful input and have lodged a complaint with CEL. The CS guy has asked me to check the Bed... twice and I have replied that it is level twice. Same with calibration and all that jazz.


So what happens?

Below is a gallery of images describing the problems in chronological order.




Recalibrated... makes it worse!


Then a bit better


Trying to print a rectangular sheet 190mm x 150mm. Fails at the top left with thick layer at the bottom left. and thin layer at the right. Printed at 50% Speed!

If you think you know what is wrong please so let me know.



This comes later once the issue is resolved...