Previous blog e14 adventures in 3D: #1 New Toy in the e14 Office 

 

Last time, I confessed my schoolboy error of running 240v through my printers PSU while it was set to receive 110v.

This poor little guy got the shock of its life!

 

Now time for some trouble shooting, First item on the replacement list was the PSU which went pop.

 

PSU has been switched out, next job is to power on the printer after carefully checking the voltage!

 

Power on,

 

No movement.... not recognized on a Windows PC, a Mac, or Raspbian linux distro.

LED light on the board is illuminated, so it is getting power but not talking via USB.

 

PrintrboardRevB_Front.jpg

800px-Printrboard_RevF_Board300.png

 

 

Checking out the schematics found on the Reprap wiki:  http://reprap.org/wiki/Printrboard  cstanton identified that there could be two components could have taken a beating... one easy job, one not so easy.

 

ESD Protection Diode:

NXP DIODE ESD, USB, SOT457NXP DIODE ESD, USB, SOT457

PRTR5V0U4D,125

 

Microcontroller:

Atmel MCU, 8BIT, AVR, 128K FLASH, USB, 64TQFPAtmel MCU, 8BIT, AVR, 128K FLASH, USB, 64TQFP

Atmel: Datasheet for AT90USB1286, AT90USB1287, AT90USB646, AT90USB647

 

Firstly we had hoped the protection diode had stepped up and taken one for the team, stopping the brains from a nasty shock.

 

Luckily both items are in stock with Farnell and we were able to get hold of them next day delivery.

 

 

Soldering of the (not very good at) protection diode:

 

First Job is to check the schematic for placement and orientation:

IMG_20170609_164724.jpg

 

 

Desoldering the Protection diode did not go as well as wanted, some of you eagle eyed reader will notice the lifted pad. Some of you SUPER eagle eyed readers will have also noticed that LUCKILY it was on the one pin that is not used!

 

IMG_20170609_164741.jpg

 

Replacement of the diode .... it is a bit messy but mechanically and physically connected.

 

IMG_20170609_165311.jpg

 

Before attempting to solder the Microcontoller with its 483 pins (I counted) we thought it would be a good idea to believe in the little Protection Diode, We plugged it all back in to no avail. LED still illuminated, no communication via usb. Not even coming up as an unknown device.

 

Next on the proverbial heatgun and flux chopping block is the Atmel MCU, again soldered by cstanton

IMG_20170705_094855.jpg

 

Bit of flux here and there and some of the connectors are a little toasty but.... SHES A LIVE!

 

IMG_20170705_094201.jpg

Using a Raspberry Pi 3 we followed the device logs:

tail -f user/log/messages

We let the Pi boot, Follow the logs, power on the board,  nothing... nothing... nothing....THERE IT IS, the ATMEL bootloader listed as a USB device.

 

Massive thanks to cstanton for the diagnosis and soldering.

 

Next step is to change a few of the jumps and attempt to flash the firmware!

 

More updates to follow soon!