Acting on information from Peter Oakes (thanks) I downloaded the Keysight IO Libraries Suite 17.3 - 976Mbytes, reasonable speed of download here.

 

Then I installed it - you get offered to install the IO stuff, Command something and BenchVue  - I just selected the IO stuff.

 

It said that NI VISA was installed and recommended a "side by side" installation of the Keysight stuff as the secondary VISA.

 

I had a go at removing the NI VISA but it wasn't having it !

 

So I let the Keysight installer rip and it seemed to manage OK - masses of little flash screens telling you about little sections of the install but no overall progress indication - it didn't take that long, a few minutes.

 

I ran BenchVue again and it spotted my DMM right away - it didn't find the DAQ box (because it wasn't plugged into the network). I fixed that and went off hunting to see how to add the DAQ - got to a thing in the help telling me to launch "Connection Expert" - luckily while I was wondering what the hell that was and how to launch it BenchVue found the DAQ box on its own.

 

So far so good.

 

BV can talk to the DMM but needed to download some stuff to talk to the DAQ - it then offered me the option to run the free version or license the Pro version if I had the license.

 

Since I did I tried the in application licensing.

 

 

I did the Activate License

It went OK at first and I got a big white box telling me that it was on the case and might take some time.

 

Then (after a few minutes) I got this

 

 

AAAAARGH !!

 

I look forward to the support team's help.

 

Funnily enough I had similar issues installing a paid for license on my scope - it all looks quite slick and lovely and then it just doesn't work.

 

I have the BV as a review - I didn't pay for it so I can see the funny side to all this - it doesn't look so amusing when you've parted with cash and have a client depending on it.

 

MK