4 Replies Latest reply on May 1, 2014 5:21 PM by e_b_123

    How to add module usbserial

    e_b_123

      I want to attach the mobile-modem Huawei E-169 and an USB-RS485 adapter.

      Both devices are listed in lsusb.

      but no one will be mounted correctly

      The Huawei Modem should be mounted at /dev/ttyUSB*.

      dmesg delivers output only mounted as storage.

       

      usb 2-1.2: new high speed USB device number 8 using fsl-ehci

      scsi7 : usb-storage 2-1.2:1.2

      scsi8 : usb-storage 2-1.2:1.3

      scsi 7:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2

      scsi 8:0:0:0: Direct-Access     HUAWEI   MMC Storage      2.31 PQ: 0 ANSI: 2

      sd 8:0:0:0: [sda] Attached SCSI removable disk

      linaro@linaro-ubuntu-desktop:~$

       

      I tried to modeswitch the device with modeprobe usbserial with following error.

      FATAL: Module usb_serial not found.

       

      How can i load module usb_serial?

       

      linaro@linaro-ubuntu-desktop:~$ modprobe -l | grep serial

      kernel/drivers/usb/gadget/g_serial.ko

      already tried to /boot/linux.config

      CONFIG_USB_SERIAL=y and

      CONFIG_USB_SERIAL=m

       

      Working on Ubuntu 12.11

      Linux linaro-ubuntu-desktop 3.0.35-03023-ga0660f4 #1 SMP PREEMPT Tue Mar 25 21:17:12 CET 2014 armv7l armv7l armv7l GNU/Linux