7 Replies Latest reply on Mar 19, 2015 4:58 PM by mikejn1

    Confused about GPIO


      Hi all,


      I recently got a Raspberry pi and am loving it so far. The only problem I have encountered is GPIO. If I understand correctly, I need to download something to use them in python. I have tried everything  that i could find without success:


      $ sudo python

      >>> import RPi.GPIO as GPIO


      (which came up with something about the file not existing)




      $ wget http://pypi.python.org/packages/source/R/RPi.GPIO/RPi.GPIO-0.1.0.tar.gz


      (which said that the website wasn't available or something)


      I have tried updating/upgrading the software with


      $ sudo apt-get update

      (which I think came up with some errors)


      $ sudo apt-get upgrade

      (seemed to work)

      What should I do? Am I doing something wrong?  I "inherited" the Raspberry pi, so i don't know when it was bought and it came with a preinstalled sd card so i'm not 100% sure what it is running but I think raspbian.


      Many Thanks,