2 Replies Latest reply on Aug 19, 2015 11:40 AM by bobalexander

    Issue with 2.4" HAT

    jwflight

      I purchased a 2.4" HAT (2.4" HAT Primary Display for the Raspberry Pi) and can't seem to get it working.  I have the Pi 2 and followed the instructions on the directions, then the website, to install the required package to get the screen working.  Unfortunately, when I get everything installed the screen doesn't work and the software appears to cause the boot to hang (NOOBS OS) and there's no way to boot the system.  I/m forced to reinstall NOOBS with a clean install. 

       

      Any suggestions?

        • Re: Issue with 2.4" HAT
          peteroakes

          the software may still be configured for the older PI .

           

          When the move to PI 2 happened, some of the PI pins regarding the SPI bus etc changed and this may be your issue, look for an updated driver,, check their web site to verify it it has been confirmed working on PI 2

          • Re: Issue with 2.4" HAT
            bobalexander

            Any luck? I'm interested in that screen for my projects.

            If not, you might try the steps here: I Can See Clearly Now! With the 4D Systems 2.4" Touch Screen for the Raspberry Pi

             

            If this is not working, you may try "safe mode" and disable some things...

            To enable it, you have to insert a jumper between pins 5 and 6 on P1 (GPIO) header when booting.Safemode pins

            If you do this, bootloader will ignore the config.txt file (except from avoid_safe_mode option which can be used to disable this feature) and will try to boot kernel_emergency.img (if available) instead of kernel.img.

            Default kernel_emergency.img has special emergency initramfs build in and it will boot to this busybox based OS so that you can fix the problems in your OS manually (or change kernel boot parameters to run runlevel 1 at next boot). Remember to run sync before powering down since reboot or shutdown commands may not work.

            (from boot - Oops I need runlevel 1 - Raspberry Pi Stack Exchange )