5 Replies Latest reply on Aug 16, 2019 5:03 AM by f.donya

    Circuit Studio - Part created but then not found



      Is anyone else finding that having created a part in CircuitStudio, complied the library with no errors reported that when one goes to place that component in a schematic that even though it is visible in the Library Circuit Studio reports ... "Failed to load <library path.schlib> STG <part name> could not be found"


      If so any clues as to how to stop it doing this?





        • Re: Circuit Studio - Part created but then not found

          Hi Neil


          I am having this problem also.


          I am very new to this software having used Eagle for a number of years. I have followed the information in the help on creating parts but the links between the schematic and the footprints don't seem to work.


          I have a library for through hole capacitors that has 5 or so foot prints in it for various sizes of caps but the software wont included it for some reason.


          I notice the libraries that come supplied (not the vault) are in a compiled format. Don't know if that has something to do with it.


          As far as I know you make a new schematic library and place the pins and draw your shapes for the part.


          Next you make a PCB library that contains the footprint and a step file (optional I believe) for the part so it looks nice in the 3D view.

          I think the pads have the same number assigned as the pins. So pin 1 in the sch file is pin 1 in the PCB file. You then right click on the sch symbol and assign the PCB footprints.


          Sounds easy I think that's it but I am have a lot of problems making it work.



          • Re: Circuit Studio - Part created but then not found

            Don't know, what the reason for this issue is, but a workaround to get rid of this error message is to generate a copy of the component in the library and delete the bad one. Rename the copy and you are done.

            Don't know, if it affects component references of existing projects. I never had the issue on long existing components, only on newly created ones.


            Best Regards,


            • Re: Circuit Studio - Part created but then not found

              Here is the response from the developers:


              The workflow as you described is exactly correct so that the pin numbers correspond between Schematic and PCB. Make sure the libraries are both saved and then place the schematic component onto your schematic. When you're ready, use Project > Update PCB Document, and the ECO process will automatically place your footprint onto the PCB document. This is better than placing the footprint directly onto your PCB because it sets up the UniqueID from the schematic component with the correct PCB footprint.


              The capacitor library should allow 5 different footprints. If this isn't working, please send in the library for us to have a look at. The "STG <part name> could not be found" error is some sort of crash and maybe there is something wrong with one of the libraries that are loaded into CircuitStudio.

              • Re: Circuit Studio - Part created but then not found

                I had the same problem. Eventually, I created a new library and moved all my components' schematic and PCBs to that and compile it. delete the previous library and new library works fine.

                I have no idea why I was getting that error. Apparently, there was not any wrong with the component's schematic and PCB. I tried to add a new component schematic to that library, but I was getting the same error. I changed the location of the source file but still, the error was there. Another problem that I had; when I named my library "MyLib" I was getting error too when I saved it with another name I was not getting any error. In summary, just create a new library and move all the source documents to the new library.