12 Replies Latest reply on Jan 10, 2017 2:42 PM by Frederick Vandenbosch

    Raspberry Pi with EnOcean Pi and EnOcean USB 300


      Good afternoon,


      I was wondering if anyone would kindly help me with an issue.


      I bought an EnOcean USB 300 and an EnOcean Pi, to try and get either to work with a Raspberry Pi. I have been following the official instructions until it came to these commands for the USB 300 and EnOcean Pi respectively:


      hexdump -C < /dev/ttyUSB0

      hexdump -C < /dev/ttyAMA0


      Once I enter these commands, there is no output or error messages. According to the linked document there should be numbers outputted. I have tried with two different Raspberry Pi 3s with fresh and up to date raspbian OS, plus a Raspberry Pi Zero, and every time there is no output or error message when I enter these commands. I have tried searching google and forums, and I could not find an answer. I tried the USB 300 in a windows PC, and it worked, so it is not broken hardware. I have not got as far as installing fhem server either, so that cannot be affecting anything. I have set the Baud to 57600 as well using


      stty -F /dev/ttyUSB0 57600


      Does anyone have any suggestions? I might be missing something simple! Or is the fact that there is no output unimportant?


      Many thanks in advance