29 Replies Latest reply on Sep 5, 2018 9:32 AM by agnessa1

    Raspberry Pi3 Does not boot up - Green light does not lit


      I purchased a Raspberry Pi3 last week, after spending couple of days trying to get it to boot up I gave up and purchase another one. I am having the same issues, it just would not boot up, i.e. the green light does not lit -- which I think means that is Not reading the SD card to load the Operating System. This is what I have done so far:

      Used a 5v/2A power supply, use a 5v/2.4A power supply.

      Used the SD with the preloaded OS that I purchased - no luck

      Purchase another SD card, formatted it and load Noobs sw on it - still no luck

      I removed every thing that is plugged in the PI3 except for the power supply, still no luck.


      Anyone out there who is experiencing the same issue???

      Does your one works out of the box?


      What am i doing wrong???


      What should the voltage/Amp for the power supply be? is it 5v/2.5A?

      Help please.. Gerard

        • Re: Raspberry Pi3 Does not boot up - Green light does not lit

          My Pi 3 did not work straight out of the box. I used the official 2.5amp power supply which lights up the board with no hassles. However, the OS version I used was from an older NOOBS for Pi 2. Thinking that I had a dud board, I ordered another (in kit form) from another dealer. The kit had a Micro SD Card with NOOBS installed, and worked just fine. The NOOBS version was 1.8 and only contained Raspbian Jessie.

          While waiting delivery, I downloaded NOOBS version 1.9 from the Raspberry web site to have another go. I used a Download Manager program (Xtreme Download Manager) to ensure that all of the code was received. (Took an hour to finish). There is a lot of useful guides on the Raspberry Web Site to help with unzipping and loading onto the SD Card. The boot process with NOOBS 1.9 went OK but needed the Internet to download Rasbian and any other programs. I included OSMC and LibreELEC with Raspbian and maybe I should not have. The end result is that Raspbian does not load but the other 2 do. They are Media Centre programs. I will leave as is for the time being as I have the 1.8 Raspbian on the other card. One day I will download NOOBS 1.9 without the other programs to see what happens.

          2 of 2 people found this helpful
            • Re: Raspberry Pi3 Does not boot up - Green light does not lit

              Peter thanks for the info. I am using the Noobs 1.9.2 version without any success. To copy the files on the Sd do you just do copy and paste, i.e all the items in the Noobs folder to the root directory of the SD card? What files do you have in the directory?


              The only thing that I have not done yet is to use a 5v/2.5A power supply which I can't find a place to purchase. Gerard

                • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                  Hello Gerard.

                  Element14 can supply a Power Supply part no 252078701 for $10.46 plus GST and postage. You might also like to access guide notes from www.raspberrypi.org/forums/viewtopic.php?f=28&t=58151. This has heaps of info and links to other items of interest.

                  All you need to know to get NOOBS loaded are these notes. The program I used to format the SD card is SDFormatter, a free download. The notes say to set Options---"Format Type:Full" and "Format Size Adjustment:On".

                  Windows will unzip the NOOBS download into 3 folders and 14 files. In Windows Explorer, these items can be dragged from your unzipped location and dropped to the SD Card. Ensure that only these items are listed in the root of the SD Card and not under any other folder.

                  With the SD Card in, Raspberry should boot up and show you a screen for you to connect to your Internet source so that the Raspbian download can finish. To avoid problem that I had, select Raspbian os only and none of the others. Hopefully you will be up and running.


              • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                Have experimented further. Using a freshly formatted SD Card, NOOBS unzipped folders and files were copied across and then card used to boot the Pi 3 board. After the boot and establishment of the Internet connection Raspbian OS only was selected to install. This went well and finally booted into the Raspbian GUI window. This proves to me that the installation of the two Media Centre programs on my other SD Card interfered with the boot into the Raspbian GUI.

                Gerard, there are two LED lights on the Pi3 board. The right one should light constantly telling that power is there. The left LED flickers when there is processing activity. I am colour blind so do not know the LED colours. If the right side LED is out, you have a power supply problem and you will get no further. If this one lights and there is no flickering on the left one, then you probably have a problem reading the SD Card. Not in the slot properly, bent pins? You probably know this already. Have tried various power supplies in my board, Pi official 2amp and 1amp packs from older Pi versions as well as the 5v 1amp pack from my mobile phone. All boot the Pi to the GUI screen. So Gerard, I am fresh out of any further ideas.


                  • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                    Hi Peter,

                    Thanks again for the valuable help. I have tried everything, with no success. One on my second Pi3 now.. Power Supply 2.5A/5V ( but as you said it should work with a 5v/2A). I think the next step for me is to purchase another SD Card, reformat it and copy the latest version of Noobs across. Which version of Noobs did you use? the 1.9.x version or the 1.8.x version?

                    I have inspect all the slots, pin connections, soldering etc.. all seem to be ok..


                    The left light ( which is meant to be green) on flick on once when power is switched on, the it stays off. If the new SD card does not work then I will have to try a 3rd Pi3.. I am not convinced that it is the Pi3 itself.. From all the blogs, it seem that Pi3 is very stable. I will let you know how I get on.. G

                      • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                        Hello again Gerard

                        I have used both the 1.8.x and 1.9.x NOOBS versions. The 1.8.x version was pre loaded on the SD Card which came in the kit I purchased with the Pi board No.2. The 1.9.x version, I downloaded from the Raspberry Pi org. The NOOBS version I downloaded was the full version, not the lite edition.

                        From what I have read, you are correct in saying that all Pi boards are stable as they are tested at the factory before shipping. There should not be a need to purchase another board. You may like to look at blogs concerning SD Cards. I have seen comments the Pi is a little fussy with cards. I have used SanDisk Ultra and SanDisk Extreme Pro, all HC Class 10.

                        You have not confirmed that the right hand light stays on when power is connected.

                        I certainly hope that you get to the bottom of this challenge.


                    • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                      Hi Folks


                      I just got Raspberry PI 3  Model B from Canakit and the power supply that it came with is 5v/2.5a.   It will not boot with that PS but I have a 5v/1.2 from my jet pack charger.   I've many of the things above and on other sites. 


                      From above what was the SC card size that worked?

                      • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                        One issue is SD card manufacturers sometimes add a boot section so Noobs install I'm guessing is prevented access to the memory it needs to install. In disc management win 10 you can inspect the card and manage it to create the memory partition volume that uses all the SD cards available memory. Also formatting the card could be an issue using correct settings. I'm also having a failed install and I'll implement some of the suggestions eg internet connection mentioned.





                          • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                            I recently bought my first Raspberry Pi 3 Media Centre Kit and, not knowing much about electronics, I followed instructions with double and triple checking before I switched it on.

                            It startup okay and the advice on what to do appeared on my TV set.

                            Then the image started to fade and finally disappeared. The red light remained on but the green light disappeared.

                            I have since tried a few times. Red light comes on but no green light or picture on the TV.

                            I have sent emails to the supplier, Raspberry Pi Australia, but they don't seem to have any clues and haven't offered to do anything about it.

                            It cost me Aus$159 and it seems I've just done my money.

                            I don't feel like spending more unless I can be assured of a result.

                            I'm a bit disappointed that the supplier doesn't seem to have any idea what might be wrong.

                            Cheers (or gloom)


                              • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                                Hi Brian.

                                I'm no expert but do have a basic understanding.

                                Firstly do persevere , faults are rare and Raspberry Pi software and hardware projects can be extremely rewarding.

                                But I get that you aren't feeling that now... So ..

                                The Red light confirms power to the unit and the green confirms a valid Rasbian software detected and booted.

                                So if you have Only the Red light this is indicating that a valid version of Linux cannot be initiated.

                                First off I would use your pc to download a new copy of the NOOBS software package ( use a usb/micro SD converter) . This will totally replace your previous version.  Hopefully this is the issue.

                                The other is a dodgy connection , which for us noobs means a new board.

                                But the light situation with solid red makes me think you have corrupted software . So download or even buy ( about a tenner UK) a new pre-installed NOOBS Raspian SD card, this would be good as all doubt over your procedure is then eliminated (!!)...

                                Good Luck mate,



                                  • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                                    I must add that Raspberry Pi Australia were eventually very helpful and I learned that it was the SD card which was wonky.

                                    I got another card and all worked well, though I'm having trouble understanding some of the acronyms in LibreELEC.

                                    However, I will eventually learn. I am very impressed by the way it was so easy to connect to the Internet.

                                    It's almost like my PC. I'll certainly recommend to my friends that they give it a go.

                                    Brian (Caduceus)

                              • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                                My raspberry pi is stuck here what should i Do?

                                • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                                  I am in the same boat as original poster:

                                  - new Pi 3 from Microcenter

                                  - SD card was booting up Pi 2, same card didn't boot in Pi 3

                                  - So reflashed with fresh download of NOOB and current Raspbian

                                  - Same SD card continues to boot Pi 2 with reflashed current NOOB/Raspbian but fails to light up Green light on new Pi 3 and seems to give no output

                                  - So SD card itself is fine -- does booting it in Pi 2 cause some change in SD card that would fail it in Pi 3?


                                  At what point do I conclude Pi 3 is defective (never booted before)? I dislike the lack of spring push/pop mechanism in Pi 3 but understand it was done to alleviate SD problems and now the SD card is a friction fit in Pi 3 onwards, just not sure if I am not pushing it in properly, it is seated well or not or something else with pi 3


                                  Thanks for any pointers

                                    • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                                      The on-the-street hearsay is that >90% of any returns are user error, and not faulty Pi's. There isn't enough detail to conclude that the Pi is defective.

                                      Some more information would be needed, specifically what power supply and cable are you using? What else is attached? And is there a photo showing the insertion of the micro SD card, if there is any doubt from you that it may not be pushed/seated correctly.

                                        • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                                          Thanks for responding. I will get more details to you esp power supply and photo,  as soon as I can get to the device at home.


                                          Meanwhile, as mentioned, same (recently full formatted new NOOBS/Raspbian) SD card when used with same setup (USB cables, power cable) inserted in identical way but into my RPi 2 works just fine. RPi 3 shows no green light any time.  Only power supply and monitor USB plugged in.  With or without keyboard and mouse same result.

                                            • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                                              Solved.  Went to Microcenter, bought a new identical RPi 3, bought a recommended power supply. Put the same SD card in and all worked. Then swapped just the problematic RPi 3 and only red light. So concluded faulty unit and showed and informed them, they swapped it!  The new R Pi 3 works fine even with my regular 2v phone charger.


                                              So I got the rare bad apple. Should have done this sooner.


                                              But thanks all for the suggestions and to OP for this thread.

                                              1 of 1 people found this helpful
                                            • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                                              I have almost 100 boards in service. Of those 100, I had three out-of-box failures: 1 mechanical-intermittent, 1 rainbow-screen-of-death, and 1 does-not-a-damn-thing. I had my tech reflow all three on the chance that the failures are all due to bad solder. The mechanical-intermittent "recovered" but the other two are still scrap. The Pi is a wonderful product, but 3% failure on boards that have passed factory test is kinda dismal quality.

                                          • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                                            Hi Gerad,

                                            couple of things I would try and see where it leads you.

                                            First: (silly question) the SD card is the right way around and all the way in?


                                            Second: the power supply (2A is plenty): use it to plug into a mobile phone or tablet (or anything with a micro USB) and see see if it gets power.


                                            Third: plug the power supply into your RPI (and nothing else in case some of your peripherals have a problem). Use a multi-meter between the GPIO pins for +5V and GND and check if you see 5V. If you do, also check the +3.3V pin.


                                            Can you let us know what the result is?

                                            • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                                              I was having the same issue today, i found instead of dragging and dropping into the sd card i had installed it in a folder i labeled noobs, which was the problem.. Thank you and I hope this is useful if anyone else has had this issue

                                              • Re: Raspberry Pi3 Does not boot up - Green light does not lit

                                                You should make sure the SD card is properly seated and formatted/installed correctly. And that you didn’t do anything to the board, because last time I tried, I accidentally broke a resistor thing for the CPU and totally trashed the board (it made the green light not work)

                                                No green means that no boot code was executed, so its probably having an issue reading it.

                                                What to do:


                                                Make sure card is seated property.

                                                Make sure your sd card/pi image has “bootcode.bin”, “fixup.dat”, and “start.elf”. And that you can read it.

                                                Make sure the SD card isnt damaged.

                                                Ensure the board isn’t damaged.

                                                Ensure the power supply is sufficient. The Pi 3 takes 5v and draws around 2 amps of current (Estimate is high but 1A isn’t good enough)


                                                Flash patterns:

                                                2 flashes: card couldn’t be read

                                                3 flashes: start.elf not found

                                                4 flashes: start.elf not launched

                                                7 flashes: kernel.img not found

                                                8 flashes: SDRAM not recognised.

                                                SDCard tools for formatting/installing Raspbian:

                                                1 of 1 people found this helpful