5 Replies Latest reply on Nov 9, 2017 12:32 PM by bhfletcher

    FSBL file is mandatory for Zynq/ZynqMp devices



      I'm working through the tutorials for the Minized. In tutorial 04, Experiment 3 (page 9), when I go to Program Flash, there's a statement in Program Flash Memory dialog which states "FSBL file is mandatory for Zynq/ZynqMp devices" and I apparently can't proceed until I resolve the error.

      Any thoughts on what i'm doing wrong?  I've gone back through the steps in the first two sections of the tutorial but I may be repeating the same erorr each time through.

      I'm running XSDK 2017.3 under Ubuntu. The tutorials have gone per script up to this point.


        • Experiment 1 outlines how to

          Experiment 1 outlines how to create the FSBL. Did you do that? You can verify by going into ...\Applications\MiniZed_Basic_System\ZED_FSBL\Debug and see if you have ZED_FSBL.elf.

          Experiment 2 outlines how to prepare the Boot Image. Did you do do dthat? You can verify by going into ...\Applications\MiniZed_Basic_System\Periph_Test\bootimage and see if you have Periph_Test.mcs.

          Are you continuing Experiment 3 using the same project that was used to generate the FSBL and boot images? That is important so that the SDK understands the hardware configuration of the target hardware so that it can successfully target and program the Flash.

          That all said, the tutorial was written for 2017.1. I haven't yet looked to see if there was a major change in procedure for 2017.3 although that is highly unlikely.


          • Thanks for the reply

            I worked through the first two tutorials with everything seeming to go according to script.  I'll double check on the specific files you mentioned and get back to you.

            • Yes, I have those two files

              I just verified the presence of those two files (ZED_FSBL.elf, 347.4 kB, and Periph_Tests.mcs, 6.2 MB). The latter file is named Periph_Tests.mcs, not Periph_Test.mcs as in the turorial, but I think I was consistent about that naming throughout.

              • Solved

                Tried again to do the Program Flash operation and where previously I couldn't select an FSBL file (I believe that line was grayed out - wish I'd taken a screen shot though) as in Figure 12 of the tutorial, now I could choose the ZED_FSBL.elf and then success.

                • Great! Thank you for

                  Great! Thank you for reporting back. Best success to you on your MiniZed projects!