2 Replies Latest reply on Sep 29, 2017 5:41 PM by rsg

    OpenAMP on MicroZed using Xilinx 16.2 tools?


      I want to run a Linux/FreeRTOS OpenAMP application on a MicroZed board, using Vivado 16.2. I've made a great deal of progress, but appear to be missing something. This is my rough plan:

      1.   Install Vivado 16.2 and PetaLinux 16.2
      2.   Install MicroZed BSP for Vivado 16.2 from zedboard.org
      3.   Get familiar with Vivado (it's been 8 years since my last foray into Xilinx!) and MicroZed
      4.   Using UG1144 as a guide, build and boot a PetaLinux Linux image
      5.   Using UG1186 as a guide, build and run the OpenAMP Echo test app
      6.   Start my app development

      I've gotten through the first four steps, but in UG1186 (see https://www.xilinx.com/support/documentation/sw_manuals/xilinx2016_2/ug1186-zynq-openamp-gsg.pdf), I run into a roadblock.  I am trying to follow the procedure in "Chapter 3. Building and Running a Linux Project with Applications", with the goal of running echo_test.  However, when I get to step 6 on page 16, the OpenAMP applications are not shown when I run "petalinux-config -c rootfs"!

      I have found two clues as to what I may be missing.

      1.   The note in step 6 states that "These options are only available in the PetaLinux reference BSP".
      2.   Step 1 on page 14 is this: "petalinux-create -t project -s <PATH_TO_PETALINUX_ZYNQMP_PROJECT_BSP>". I used the "PetaLinux 2016.2 Compressed BSP, z7010" BSP that I got from MicroZed (see http://microzed.org/support/design/1519/10) for the BSP.

      So I am wondering if the MicroZed BSP does not include OpenAMP, or is there another that I should be using? Also, I cannot find any OpenAMP downloads on the Xilinx website, regardless of version; where do I get the OpenAMP framework?

      My guess is that the MicroZed BSP does not include OpenAMP in it.  If this is true, where (link, please!) can I get the framework, and how do I "install" it?

      Thanks in advance!