5 Replies Latest reply on Mar 14, 2019 3:22 PM by ilg

    Using XPM in Ubuntu


      Hello again, My two friends and I decided to use Ubuntu as working environment. So like I did in Windows, I proceeded to install the nodejs and then install xpm, which was successfully. but when I tried to install "xpm install --global @gnu-mcu-eclipse/arm-none-eabi-gcc" in the terminal I got :


      sudo xpm install --global @gnu-mcu-eclipse/arm-none-eabi-gcc --force

      xPack manager - install package(s)



      Processing @gnu-mcu-eclipse/arm-none-eabi-gcc@8.2.1-1.4.1...

      Removing existing package from '/home/kylo/opt/xPacks/@gnu-mcu-eclipse/arm-none-eabi-gcc/8.2.1-1.4.1'...

      Installing globally in '/home/kylo/opt/xPacks/@gnu-mcu-eclipse/arm-none-eabi-gcc/8.2.1-1.4.1'...

      Extracting 'gnu-mcu-eclipse-arm-none-eabi-gcc-8.2.1-1.4-20190214-0604-centos64.tgz'...

      3243 files extracted.



      'xpm install' completed in 12.944 sec.



      I used force because when using the command normally I still get the same issue , and the issue is that the folder is empty, only some text files, and not the bin folder and the rest. for any reason something is preventing  the extracted files to be placed in that directory, am I missing something ??


      thanks in advance


      • Reply
        • Re: Using XPM in Ubuntu

          There is nothing wrong and you do not need sudo, the toolchain is in a folder named .content.

            • Re: Using XPM in Ubuntu

              Hello again Mr. Liviu, My question is because in the tutorial I have this :


              This method uses the portable tool xpm, the xPack Package Manager, and can be used on Windows, macOS and GNU/Linux.


              $ xpm install --global @gnu-mcu-eclipse/arm-none-eabi-gcc 


              This will always install the latest available version, in the central xPacks repository, which is a platform dependent folder in the user home:

              • Windows: %APPDATA%\xPacks (or %userprofile%\AppData\Roaming\xPacks, like C:\Users\ilg\AppData\Roaming\xPacks)
              • macOS: ${HOME}/Library/xPacks
              • GNU/Linux: ${HOME}/opt/xPacks

              This location is also known by Eclipse, so it can automatically identify the installed toolchains.



              So later they show a way to test it :


              $ "${HOME}"/opt/gnu-mcu-eclipse/arm-none-eabi-gcc/7.2.1-1.1-20180401-0515/bin/arm-none-eabi-gcc --version


              Actually I know that version is old compared to the new one, but after the folder which contain the version on its name, the folder only shows some txt files but there is not the folder "bin", even the whole directory only weights 19kb or something.


              Thanks in advance.


                • Re: Using XPM in Ubuntu

                  This is a misunderstanding.


                  The documentation presents two methods to install the toolchain, "The xPack install" and "Manual install".


                  The command you refer to (to test the toolchain) is in the "Manual install" section, and does not apply to "The xPack install", since the folders are different.


                  When you install via xpm, things are fully automated, xpm first downloads the package.json and few other text files, then gets the large archive (that otherwise you have to manually download), and places its content in a folder named .content, that you probably do not see unless you instruct your file explorer to show dot files.


                  If the wording in the documentation page is difficult to understand, please point where the problem is and possibly suggest a better one.

                    • Re: Using XPM in Ubuntu

                      Thanks for your kind reply... This will save me a lot of troubles from now. You excuse me if I missed this point, but would be good (if not already there) any note explaining that the xpm method is very different from manual installing. Also if possible, a way to test when xpm installs, to make sure we are in the correct path. If is that the case, I will proceed with the rest of the instructions until Im ready to run any test on my MCU, which I already have with me. For now, I will be working with ST LINK V2 until I get to work with the J-link. baby steps, you know..