1 Reply Latest reply on Jun 24, 2020 2:09 PM by talvlad29

    PetaLinux u-boot issue with ultra96v2

    talvlad29

      HI,

      I work with ultra96v2 board from AVNET (Part="xczu3eg-sbva484-1-e"). I created HW design (I used vivado 2019.2) based on step by step tutorial (https://highlevel-synthesis.com/2019/11/07/how-to-create-ultra96v2-linux-based-platform-in-xilinx-vitis-2019-2/comment-page-1/#comment-1383) and build PetaLinux package (I used PetaLinux 2019.2). I tried to run it from SD card but it got stuck at boot stage (boot mode was selected to boot from SD). I tried to download the same image via JTAG and received the following response:

      vladimir@vladimir-virtual:~/vitis/ultra96v2_vitis_pkg/ultra96v2-petalinux$
      vladimir@vladimir-virtual:~/vitis/ultra96v2_vitis_pkg/ultra96v2-petalinux/images/linux$ petalinux-boot --jtag --u-boot --fpga --pmufw
      INFO: sourcing build tools
      INFO: Use bitstream: "/home/vladimir/vitis/ultra96v2_vitis_pkg/ultra96v2-petalinux/images/linux/system.bit.
      INFO: Please use --fpga --bitstream <BITSTREAM> to specify a bitstream if you want to use other bitstream.
      INFO: Launching XSDB for file download and boot.
      INFO: This may take a few minutes, depending on the size of your image.
      rlwrap: warning: your $TERM is 'xterm-256color' but rlwrap couldn't find it in the terminfo database. Expect some problems.: Inappropriate ioctl for device
      INFO: Configuring the FPGA...
      INFO: Downloading bitstream: /home/vladimir/vitis/ultra96v2_vitis_pkg/ultra96v2-petalinux/images/linux/system.bit to the target.
      INFO: Downloading ELF file: /home/vladimir/vitis/ultra96v2_vitis_pkg/ultra96v2-petalinux/images/linux/pmufw.elf to the target.
      INFO: Downloading ELF file: /home/vladimir/vitis/ultra96v2_vitis_pkg/ultra96v2-petalinux/images/linux/zynqmp_fsbl.elf to the target.
      INFO: Downloading ELF file: /home/vladimir/vitis/ultra96v2_vitis_pkg/ultra96v2-petalinux/images/linux/u-boot.elf to the target.
      Memory write error at 0x8000000. MMU fault at VA 0x8000000. Translation fault, second level
      invoked from within
      "::tcf::eval -progress {
      apply {{info} {
      switch -- [lindex $info 0] {
      "info" {
      puts -nonewline "\r[lindex $info 1]"
      }
      "warning" {
      puts "\n[lindex $info 1]"
      }
      "data" {
      puts -nonewline "\r[lindex $info 1] of [lindex $info 2] complete"
      }
      "done" {
      puts "\n[lindex $info 1]"
      }
      }
      flush stdout
      ::xsdb::abort_check
      }}} {::tcf::cache_enter tcfchan#0 {tcf_cache_eval {download_cache_client ::tcfclient#0::arg}}}"
      (procedure "::tcf::cache_eval_with_progress" line 2)
      invoked from within
      "::tcf::cache_eval_with_progress $params(chan) [list download_cache_client $argvar] {
      apply {{info} {
      switch -- [lindex $info 0] {
      "info" ..."
      (procedure "dow" line 78)
      invoked from within
      "dow "/home/vladimir/vitis/ultra96v2_vitis_pkg/ultra96v2-petalinux/images/linux/u-boot.elf""
      (file "/tmp/tmp.tBvV3aPdLo" line 28)
      INFO: The XSDB log is as follows
      attempting to launch hw_server

      ****** Xilinx hw_server v2019.2
      **** Build date : Oct 23 2019 at 23:11:29
      ** Copyright 1986-2019 Xilinx, Inc. All Rights Reserved.

      INFO: hw_server application started
      INFO: Use Ctrl-C to exit hw_server application

      INFO: To connect to this hw_server instance use url: TCP:127.0.0.1:3121

      100% 5MB 0.8MB/s 00:06
      Downloading Program -- /home/vladimir/vitis/ultra96v2_vitis_pkg/ultra96v2-petalinux/images/linux/pmufw.elf
      section, .vectors.reset: 0xffdc0000 - 0xffdc0007
      section, .vectors.sw_exception: 0xffdc0008 - 0xffdc000f
      section, .vectors.interrupt: 0xffdc0010 - 0xffdc0017
      section, .vectors.hw_exception: 0xffdc0020 - 0xffdc0027
      section, .text: 0xffdc0050 - 0xffdd11bb
      section, .rodata: 0xffdd11bc - 0xffdd32d3
      section, .data: 0xffdd32d4 - 0xffdd75cb
      section, .sdata2: 0xffdd75cc - 0xffdd75cf
      section, .sdata: 0xffdd75d0 - 0xffdd75cf
      section, .sbss: 0xffdd75d0 - 0xffdd75cf
      section, .bss: 0xffdd75e0 - 0xffddb60f
      section, .srdata: 0xffddb610 - 0xffddbf33
      section, .stack: 0xffddbf34 - 0xffddcf37
      section, .xpbr_serv_ext_tbl: 0xffddf6e0 - 0xffddfadf
      100% 0MB 0.0MB/s 00:02
      Setting PC to Program Start Address 0xffdd03dc
      Successfully downloaded /home/vladimir/vitis/ultra96v2_vitis_pkg/ultra96v2-petalinux/images/linux/pmufw.elf
      Downloading Program -- /home/vladimir/vitis/ultra96v2_vitis_pkg/ultra96v2-petalinux/images/linux/zynqmp_fsbl.elf
      section, .text: 0xfffc0000 - 0xfffce353
      section, .init: 0xfffce380 - 0xfffce3b3
      section, .fini: 0xfffce3c0 - 0xfffce3f3
      section, .note.gnu.build-id: 0xfffce3f4 - 0xfffce417
      section, .rodata: 0xfffce440 - 0xfffce8b7
      section, .sys_cfg_data: 0xfffce8c0 - 0xfffcf117
      section, .mmu_tbl0: 0xfffd0000 - 0xfffd000f
      section, .mmu_tbl1: 0xfffd1000 - 0xfffd2fff
      section, .mmu_tbl2: 0xfffd3000 - 0xfffd6fff
      section, .data: 0xfffd7000 - 0xfffd83b7
      section, .sbss: 0xfffd83b8 - 0xfffd83bf
      section, .bss: 0xfffd83c0 - 0xfffda47f
      section, .heap: 0xfffda480 - 0xfffda87f
      section, .stack: 0xfffda880 - 0xfffdc87f
      section, .dup_data: 0xfffdc880 - 0xfffddc37
      section, .handoff_params: 0xfffe9e00 - 0xfffe9e87
      section, .bitstream_buffer: 0xffff0040 - 0xfffffc3f
      100% 0MB 0.0MB/s 01:07
      Setting PC to Program Start Address 0xfffc0000
      Successfully downloaded /home/vladimir/vitis/ultra96v2_vitis_pkg/ultra96v2-petalinux/images/linux/zynqmp_fsbl.elf
      Downloading Program -- /home/vladimir/vitis/ultra96v2_vitis_pkg/ultra96v2-petalinux/images/linux/u-boot.elf
      section, .data: 0x08000000 - 0x080863a5
      aborting, 1 pending requests...
      Failed to download /home/vladimir/vitis/ultra96v2_vitis_pkg/ultra96v2-petalinux/images/linux/u-boot.elf

      How can I fix this issue?

      Thank you,

      Vladimir