1 Reply Latest reply on Jun 26, 2020 5:59 PM by bhfletcher

    running multiple cores in baremetal env Xilinx SDK.

    micallef25

      Hello, I was curious if anyone has been able to run all 6 cores (4 APU) (2 RPU) cores with the SDK?

       

      I am having trouble right now running the 4 cores. I face a very interesting bug that I think has something to do with the psu_init.tcl when I run my debug configuration.

       

      For my 4 A53 cores I create 4 elf files and modify each linkerscript with a new base address and size.

       

      So...

       

      core0 has base 0 size 0x500000

      core1 has base0x500000 size 0x500000

       

      And so on. for the rest of the cores.

       

      Frustratingly, I can only get all 4 cores to run if I partition them with 50MB of space. I should be able to give each core at the minimum .5GB....

       

      The problem I see is that when I run all 4 elf files core 3 and 4 are ok and will execute. But during the assembly startup during a branch to _startup my program jumps to no mans land and dies.

       

      I checked the object dump of each file and they look correct, done a refresh and clean. It is very strange because at instruction

       

      b _startup // should jump to 0x4230 instead it jumps to 0x234345 or some random spot...

       

      If I choose to run all 4 cores the system will break. If I then modify my debug configuration to run instead just core0 and core1 it will work ok. None of my memories in my linkerscript are overlapping so I was curious if anyone had similar issues or if there is some trick that I am missing when setting up my debug configuration? ( I tried resetting and not restting certain cores no success )

       

      Thanks for listening!

       

      Eric