5 Replies Latest reply on Oct 27, 2021 3:36 AM by elm14

    Vivado 2020 "No ARM Processor Found in Design"


      I've created a simple design in Vivado 2020.2 that consists of a Microblaze, UART, SPI and LEDs. I enabled interrupts but haven't yet utilised the triggers.: all went well and bitstream was generated, which I then exported along with the hardware.

      Once exported I switched across to Vitis IDE and created an Application Project, importing my XSA hardware and selecting the 'Hello World' project. Programming the hardware also seemed to work correctly. However when I run the 'Hello World' example I get an error and I'm unsure what it relates to or how to fix it.

      My target board is a Digilent Arty Z7 although my design is not utilising the Zynq.


      Any suggestions on how to resolve would be very much appreciated, I can post additional info if required. I also have found only one mention of the same error when searching the internet; this was posted a few days ago and the design and error are almost identical to mine...sadly no replies to that yet, although I will watch and see.

        • Re: Vivado 2020 "No ARM Processor Found in Design"

          I just added the Zynq PS to my design. I'm now not getting my actual C print satetment as expect but instead some other printout:

          Maybe its not running my actual application? I'm sure I can find the answer to that though by searching for the text messages that appear on my UART to see what code is running.


          Therefore I guess by initial request for help has changed slightly; does anyone know if it is necessary to add the Zynq to a simple Microblaze only design to get Vivado to build correctly ?

            • Re: Vivado 2020 "No ARM Processor Found in Design"

              The plot thickens (or maybe starts to unwind) as I try a few things out. Firstly I changed my firmware implementation to include a slice of a counter to suitably flash one of the boards LED...this lets me confirm the FPGA is actually configured as I wish. A plain Xilinx/Program Device from Vitis does indeed get that LED flashing away.


              But when I try and run my code, which is also configured to program the FPGA, the LED no longer flashes. Also nothing new appears on the PuTTY terminal. However the Console in Vitis shows my C code's xil_printf message !!!


              Like anything, I'll keep chipping away and hopefully understand better what is happening. When I find out I'll post here for two reasons: (1) to help others with the same problem (2) help me when I get the same issue in a year's time and cannot remember what I did to fix it

            • Re: Vivado 2020 "No ARM Processor Found in Design"

              Keep chipping away, Rod!


              This is so far above my pay grade that I can only watch in amazement!



              • Re: Vivado 2020 "No ARM Processor Found in Design"

                The initial error message suggests that your hardware contains a MicroBlaze processor but that Vitis has been configured to compile code for the Zynq hard processor. It's difficult to diagnose any further without seeing your software setup. If it helps, I created a video walk-through of creating a MicroBlaze core in Vivado 2020.1 as part of this road test: Cmod S7: Breadboardable Spartan-7 FPGA Module - Review Obviously it's for the Cmod S7 rather than the Arty Z7 although the process should be exactly the same.


                The strange behaviour once you added a Zynq wrapper is something else though. I'd have expected your code to run on one of the processors at least!

                1 of 1 people found this helpful
                • Re: Vivado 2020 "No ARM Processor Found in Design"

                  Hi Rod.

                  I have the same problem as yours, but I can't solve it after searching the Internet. Could you please provide more details on how to solve this problem. You can also send me an email to wentao.w.99@gmail.com. Thank you very much.