1 2 Previous Next 24 Replies Latest reply on May 12, 2012 5:15 PM by felixfurtak Go to original post
      • 15. Re: after a wi fi dongle

        Quick update. I managed to get the Edimax EW-7811Un working by following the instructions above.


        The process worked for me on Debian but not Arch images.


        In the process, I discovered that the dongle would *only* work if it was connected directly to the R-Pi usb port and would *not work* through a powered usb hub.


        This is surprising since I was attempting to protect the Pi from excessive power drain, but in fact it was actually the cause of the problem.


        Perhaps this is an incompatability with this particular hub.


        For the record the hub in question is a (lsusb)


        05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB


        Anyway, thanks for the help. I can confirm Edimax EW-7811Un as working (on Debian)

        • 16. Re: after a wi fi dongle

          glad this works as i just brought one for my Pi.

          • 17. Re: after a wi fi dongle

            The WiFi document here: http://www.element14.com/community/docs/DOC-44703 and at least three other people on the raspberrypi forum have made the same observation: a WiFi adaptor works directly on the Pi, but NOT from a powered hub, even with a fully adequate power supply to the hub.



            Based on other reports about USB packet loss http://www.raspberrypi.org/forum/troubleshooting/usb-packet-loss

            and the USB and Network issues reported here: https://github.com/raspberrypi/firmware/issues/9

            I think there is a software problem that is causing many or most WiFi adaptors to fail when connected through a hub.

            • 18. Re: after a wi fi dongle
              Drew Fustini

              Thanks for posting those links.  I definitely was baffled at times by the behavior of using USB hub.  Some adapters worked ok from USB hub and others did not (smsc95xx register r/w errors).  The last I tested I realized all the adapters stopped (darn smsc95xx errors) working when I added a mouse, trying both the powered hub and direct.


              Interesting to know there might be a kernel issue.  I had been suspicious power was an issue.  The only insight I had was DMM on TP1/TP2 which gave me a solid 5.1V everytime I checked.  I'm hoping to get access to a Pi again next week to do some more testing.

              • 19. Re: after a wi fi dongle

                Just to repeat what I posted on the RasPi forum:


                There is hope. Two days ago (April 30) there were several USB subsystem commits marked "added support for TT in the USB driver". See below for what that means. I am not sure, but I think it means in this case, if your hub is running at USB High-Speed for the USB WiFi device, and if you also have a keyboard or mouse (low-speed USB protocol) on the same hub,  then it would not work without TT.

                A USB hub consists of a Hub Repeater section, a Hub Controller section, and a Transaction Translator (TT) section. [...] The Transaction Translator (TT) takes high-speed split transactions and translates them to full-/low-speed transactions when the hub is operating at high-speed and has full-/low-speed devices attached. from http://www.cypress.com/?id=4&#…..;rID=54981

                • 20. Re: after a wi fi dongle
                  Drew Fustini

                  Thanks for digging that up.  Very interesting about low-speed versus high-speed.  I never even thought of that.  I look forward to testing again soon.

                  • 21. Re: after a wi fi dongle

                    Thre are a lot of USB Wifi device supoorted striaght off the Kernel with Debian, but it's a case of they might have cut a few bits out or not coded them for the ARM version.

                    • 22. Re: after a wi fi dongle

                      There are certainly a lot of things missing from the default kernel. iptables is one glaring omission. I hope that later releases will be more full featured, but I guess it's a trade-off between features and memory footprint.

                      • 23. Re: after a wi fi dongle

                        I too have purchased one of these dongles after finding problems with my other dongles, both claim to be supported by the PI Squeeze.


                        one, a Belkin F5D7050  which claims to be a ZD1211B but 'Squeeze' wont talk to it as there are error reports on powering up.

                        Sadly I don't have the experience yet to correct the error report with a cure.


                        the other, a D-Link DWL-G122 that claims to be an Ralink RT73,

                        The D-Link refuses to connect even though it is loading drivers and 'sort of' talking to the OS.

                        I get a list of local nodes with 'IWlist wlan0 scan' but no sweeties when trying to connect to an open network node.


                        The Edimax EW-7811UN has the Linux driver software on their site, but itneeds compiling to the host OS and Hardware.


                        Damned if I know how to do that...



                        BELKIN F5D7050 ( ZD1211B in Debian ) no joy

                        D-Link DWL-G122 ( Ralink RT73 in Debian ) no joy


                        Anyone care to compile the Edimax drivers for us 'next to newbies'.

                        • 24. Re: after a wi fi dongle

                          Mike W, somone has already compiled the Edimax drivers for you. In fact you only need one file, and that's 8192cu.ko.


                          Check out http://www.ctrl-alt-del.cc/2012/05/raspberry-pi-meets-edimax-ew-7811un-wireless-ada.html


                          and http://www.raspberrypi.org/phpBB3/viewtopic.php?f=6&t=4992  for more info


                          Regarding your DLink dongle. If you are at the point of getting a list of stations when you type


                               iwlist wlan0 scan


                          then to all intents and purposes your dongle is working. You just need to figure out how to connect it to your wireless lan. This process will depend on your particular setup (e.g. whether you are runnin WEP, WPA2 or unencrypted, etc), but all the information on how to do this is documented in many places such as Debian forums.





                          1 2 Previous Next