7 Replies Latest reply on Aug 7, 2012 11:38 PM by mlivingstone

    How to get Micronext mnwd152b working?




      When I purchased my Raspberry Pi from Element14, I bought a MicroNext mnwd152b because Element 14 recommended it.


      Now that I have set it all up, when I have the dongle connected to the USB connected on the RPi, as you boot up, it just says it is timing out when Modprobe runs and never seems to work. How do I get this working? I am running a current Raspbian Wheezy.


      To get it running, I connected it via a cat5 cable which works nicely if you start doing networking operations as soon as it boots up. Unfortunately, if you leave it alone for a minute or two, you seem to lose connectivity - if you check ifconfig, eth0 no longer has an IP address assigned and you can no longer ping it from the rest of the network.


      Any suggestions as to how I may diagnose this problem? Other computers on the network continue working fine through the FritzBox 7390 it is connected to.


      Thanks in advance,



        • Re: How to get Micronext mnwd152b working?


            This thread might be helpful.



          >Unfortunately, if you leave it alone for a minute or two, you seem to lose connectivity

          I don't think you're the first to have this problem.

          There is a troubleshooting forum here:


          • Re: How to get Micronext mnwd152b working?
            Drew Fustini

            Hi Mark,


            I believe this adapter would use the RTL8192cu driver.  I had tested a similar adapter the Asus N13.  In my Wi-Fi document, there is a link to the 8192cu driver which was compiled by a colleague in the UK (ajtag).  However, this kernel module needs to be recompiled to work with the kernel in the current Raspbian Wheezy image.  I'll ping him as I don't think he has done this yet.


            In the meantime, Adafruit has released there own version of Raspbian Wheezy to support the products they sell including RTL8192cu-based WiFi:




            Their image might work for your adapter.




              • Re: How to get Micronext mnwd152b working?
                Drew Fustini

                I was able to use the Asus USB-N13 without any problems with Adafruit's image (http://learn.adafruit.com/adafruit-raspberry-pi-educational-linux-distro/occidentalis-v0-dot-1).  It has the 8192cu driver module compiled into the kernel.  I believe the Micronext uses the same driver.

                  • Re: How to get Micronext mnwd152b working?
                    Drew Fustini

                    pi@raspberrypi:~$ cat /proc/config.gz  |gunzip - |grep 8192

                    # CONFIG_RTL8192SE is not set

                    # CONFIG_RTL8192DE is not set



                    pi@raspberrypi:~$ grep 8192cu /lib/modules/3.1.9adafruit+/modules.*


                    pi@raspberrypi:~$ lsusb

                    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

                    Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.

                    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.

                    Bus 001 Device 004: ID 0b05:17ab ASUSTek Computer, Inc. USB-N13 802.11n Network Adapter (rev. B1) [Realtek RTL8192CU]

                    pi@raspberrypi:~$ iwconfig

                    lo        no wireless extensions.



                    eth0      no wireless extensions.



                    wlan1     unassociated  Nickname:"<WIFI@REALTEK>"

                              Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated  


                              Retry:off   RTS thr:off   Fragment thr:off

                              Power Management:off

                              Link Quality:0  Signal level:0  Noise level:0

                              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0

                              Tx excessive retries:0  Invalid misc:0   Missed beacon:0

                    • Re: How to get Micronext mnwd152b working?

                      Hi Drew,


                      I have just created an Adafruit sdcard, so when the kids are off to school in the morning I will give it a try. From what you say it should work fine.





                        • Re: How to get Micronext mnwd152b working?
                          Drew Fustini

                          Great, Mark.  I'll be interested to know how it works out for that adapter.

                            • Re: How to get Micronext mnwd152b working?

                              Hi Drew,


                              I got it up and running with the Adafruit image, but the results - while better than Wheezy - are still not perfect.


                              It  still seems that if left for some period of time, it loses connectivity (both ethernet and wifi) from which it cannot recover other than via reboot. I do notice however that if you do an ifconfig / iwconfig the IP address still shows, but you get timeouts / host resolution failures. I tried with both eth/wlan, and singly but same problem. When one goes, all go down :-(


                              I did an apt-get upgrade but that doesn't seem to make any difference.


                              All of the peripherals connect via a powered hub.


                              I tried monitoring /var/log/messages and it seems to spend an inordinate amount of time trying to put the wifi dongle into power save mode just to then say that the dongle is currently busy. Is there some way of telling the RPi it is on AC and not to powersave anything?


                              Also, every time it receives a wifi AES packet, it logs the fact. I suspect that once RPi gets bedded down, someone is going to have to make some hard decisions as to what gets put in the log - as we do not have an infinite harddisk in this case :-(


                              So I guess the Adafruit is a step forward, but the connectivity over time problems still exist which appears to be common given troubleshooting forum messages.