75 Replies Latest reply on Sep 11, 2012 3:55 AM by wallarug

    Wireless network conectivity

    wallarug

      I bought one of these about 12 mths ago: http://www.jaycar.com.au/productView.asp?ID=YN8306&keywords=high+power+wireless+n&form=KEYWORD

      I downloaded the drivers from the link above then installed them on a windows computer.  How do I use these linux drivers/installers on the raspberry pi to get the wireless adaptor to work?

       

      Will this work with the Raspberry Pi?

        • Re: Wireless network conectivity
          wallarug

          I should add that I am using the latest Debian image.

           

          If it does work, what are the commands to install this?

            • Re: Wireless network conectivity
              GreenYamo

              Fergus,

               

              I would try here first:

               

              http://elinux.org/RPi_VerifiedPeripherals#USB_WiFi_Adapters

               

              There is also a guide for installing if yours is on the working list.

               

              Steve

                • Re: Wireless network conectivity
                  wallarug

                  Digitech is not on the "working list" as of today.  I will play around with the RPi and see if I can get it working with the provided drivers.

                  • Re: Wireless network conectivity
                    wallarug

                    As I am new to linux,

                    Can someone please help me through the installing process.  I don't know how to install a tar.bz2 file type.  I have extracted it to a folder and found the readme file but I don't understand what it is telling me to do.  I have attached it here.

                      • Re: Wireless network conectivity
                        morgaine

                        Fergus, with a bit of luck, you may be able to ignore those build instructions altogether, and just do a network package install of the driver you need.  Take a look at this post by GizmoB73:

                         

                         

                        Although I don't know whether it resolved his own problem, he points out that the rt2870 chipset is handled by the regular "ralink" driver, which you can install directly on your Debian with nothing more than:

                         

                        • apt-get install firmware-ralink

                         

                        Unfortunately I don't have my Pi yet and I'm not running Debian here on any machine, but it's worth a try doing the above install command, then running "depmod -a", and finally running "modprobe" on the right kernel module that the apt-get installed.

                         

                        To find the module name, run "uname -a" to discover your kernel version/build name (it should be the 3rd field of the single line of output, for example 3.2.0-xxx), and then use that name to look in the appropriate wireless modules directory:

                         

                        • ls -l /lib/modules/3.2.0-xxx/kernel/drivers/net/wireless/rt2x00

                         

                        In that directory you should find a number of driver modules (.ko files), and with a bit of luck that will include a rt2870.ko --- if so then try "modprobe rt2870".  If it's not there then you could try one of the others, although that can lead to a crash sometimes.

                         

                        It would be so much easier to give proper advice if I had a Pi, grrrr ... Good luck!

                         

                        Morgaine.

                        • Re: Wireless network conectivity

                          Fergus,

                            I'm not sure where you're getting stuck.  I also can't tell if this

                          driver has ever been built for arm, or for debian, so I'm not sure

                          what the probability of success is.

                           

                            If you still have a tar.bz2 file, you can extract it like:

                           

                                  bzip2  -cd  file.bz2  |  tar xvf -

                          where file.bz2 is the name of the file you have, and be

                          careful with the spaces

                           

                          The readme file appears to be in microsoft word format,

                          which you can read on a PC or using Openoffice on the RPi.

                           

                          the results of unpacking the bz2 file should be a directory

                          with some files ending in .c and .h (these are the c source files),

                          and a file called Makefile.   You will be editing the Makefile,

                          according to step 2 of the readme file.  You can skip step 1,

                          which is just unpacking the files, which I think you've already done.

                           

                          In step 3, you will be editing os/linux/config.mk

                           

                          In step 4, you will type

                             make

                          at the command prompt

                           

                          which will use your modified Makefile to cause the .c and .h

                          files to be compiled using the c compiler.

                           

                          In step 5, you will type

                            cp ...

                          at the command prompt, to copy the .dat file where it goes.

                           

                          Hope this is somewhat helpful. 

                          EDIT: just saw Morgaine's reply.  Try that first.

                    • Re: Wireless network conectivity
                      finkbat

                      If your ralink adaptor uses broadcom chipset you might want to look at linuxwireless.org/en/users/Drivers/b43.

                       

                      I had a similar issue with my linux netbook. For some reason the broadcom chipset requires firmware to be installed in addition to the drivers.

                       

                      It can be found in firmware-b43-installer package . Not sure if its in the RPi repositories as I don't have mine to play with yet... :-(

                      • Re: Wireless network conectivity
                        finkbat

                        If your adaptor uses Broadcom chipset you may need to install a piece of firmware to make it work. I had a similar problem with my Linux netbook that had Ralink wifi. It booted up but said that there was no WiFi as no firmware was loaded! After much searching the solution is at http://linuxwireless.org/en/users/Drivers/b43.

                         

                        The B43 package installs the firmware needed to run the Broadcom chipset. As its not GPL it can't be released with any Linux package, but is able to be extracted from the Windows driver. This package is already to go, just install!

                         

                        I required the firmware-b43-installer package. Not sure if it's in the RasPi repositories as I haven't got mine to play with yet... :-( But the above site it fairly comprehensive!

                         

                        Hope it works.

                          • Re: Wireless network conectivity
                            Mister-P

                            i have had issues with broadcom on various laptops using different distro's of linux, this is the best solution i have found so far. i also cant confirm at the moment if the b43 firmware is in the repositories. i will check tonight and see if it is.

                             

                            i cant actually try this on the R-Pi as i dont have a USB wifi adapter with the broadcom chipset.

                             

                            http://ubuntuforums.org/showpost.php?p=10527475&postcount=5

                             

                            hope this helps.

                              • Re: Wireless network conectivity
                                wallarug

                                Did a bit of research and found out that the RT2770F uses the same drivers as RT2780.  Also, I read the website that was posted by Neill but the RPi did not want to install firmware-b43-installer.

                                But,  From that website I think I discovered how to (attempt to) install the drivers that came with the device.  When I tried:

                                Wireless Card (3).PNG

                                The following error messages came-up:

                                Wireless Card (4).JPG

                                Can anyone shed-some-light on what is wrong?  Why can't I just use the supplied drivers?  Why won't firmware-b43 install?

                                  • Re: Wireless network conectivity
                                    wallarug

                                    Can someone please see what is wrong with the .tar.bz2 file that came with the device (and gave the above failures).  Can someone play around with these files and see if you can find the problem. I can not post the files here but you can download them from: here or here .

                                      • Re: Wireless network conectivity
                                        wallarug

                                        I am reading the Makefile and the readme file that came with the device.  Can someone please explain what I have to do? (based on what the readme file is telling me.)

                                         

                                        Extract from readme file:

                                         

                                        1> $tar -xvzf RT2870_Linux_STA_x.x.x.x.tgz

                                            go to "./RT2870_Linux_STA_x.x.x.x" directory.

                                         

                                        2> In Makefile

                                                   set the "MODE = STA" in Makefile and chose the TARGET to Linux by set "TARGET = LINUX"

                                                   define the linux kernel source include file path LINUX_SRC

                                                   modify to meet your need.

                                         

                                         

                                        3> In os/linux/config.mk

                                                  define the GCC and LD of the target machine

                                                  define the compiler flags CFLAGS

                                                  modify to meet your need.

                                                  ** Build for being controlled by NetworkManager or wpa_supplicant wext functions

                                                     Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y'.

                                                     => #>cd wpa_supplicant-x.x

                                                     => #>./wpa_supplicant -Dwext -ira0 -c wpa_supplicant.conf -d

                                                  ** Build for being controlled by WpaSupplicant with Ralink Driver

                                                     Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n'.

                                                     => #>cd wpa_supplicant-0.5.7

                                                     => #>./wpa_supplicant -Dralink -ira0 -c wpa_supplicant.conf -d

                                         

                                         

                                        4> $make

                                                  # compile driver source code

                                                  # To fix "error: too few arguments to function ¡¥iwe_stream_add_event"

                                                    => $patch -i os/linux/sta_ioctl.c.patch os/linux/sta_ioctl.c

                                         

                                         

                                        5> $cp RT2870STA.dat  /etc/Wireless/RT2870STA/RT2870STA.dat

                                         

                                        6> load driver, go to "os/linux/" directory.

                                            #[kernel 2.4]

                                            #    $/sbin/insmod rt2870sta.o

                                            #    $/sbin/ifconfig ra0 inet YOUR_IP up

                                         

                                            #[kernel 2.6]

                                            #    $/sbin/insmod rt2870sta.ko

                                            #    $/sbin/ifconfig ra0 inet YOUR_IP up

                                         

                                         

                                        7> unload driver   

                                            $/sbin/ifconfig ra0 down

                                                  $/sbin/rmmod rt2870sta

                                         

                                         

                                         

                                        I don't understand the step that says: " define the linux kernel source include file path LINUX_SRC" .

                                         

                                        Can someone help me please?

                                          • Re: Wireless network conectivity
                                            wallarug

                                            Found this: http://forums.whirlpool.net.au/archive/1439103 but I don't know where the: "Linux kernel source code header files are installed "

                                             

                                            Could someone please fill in the blanks from this post.  Which include: steps 2 and 3.

                                             

                                            This would be much appreciated.

                                             

                                            Thanks in advanced.

                                              • Re: Wireless network conectivity
                                                GreenYamo

                                                Hello Fergus,

                                                 

                                                Are you sure that it is a 2770 ? Looking at the smaller chip, it is a 2720 which brings up a lot more hits for me in Google regarding wireless cards.

                                                I'm afraid I am not much of a Linux expert, but what you are posting above looks like you are compiling from source which is well above my head, perhaps someone else could comment on that.

                                                Have a look at the following link, that may be some help: http://wiki.debian.org/rt2870sta

                                                I know this may sound a little defeatist, and i'm happy to be told so, but at some point I would say you need to cut your losses and possibly think about buying a USB adaptor that is known to work with the Pi, rather than spending so much time trying to get your current one working ?

                                                 

                                                Steve

                                                  • Re: Wireless network conectivity
                                                    wallarug

                                                    I think I will take your advice:

                                                    "      but at some point I would say you need to cut your losses and possibly think about buying a USB adaptor that is known to work with the Pi, rather  than spending so much time trying to get your current one working ?"

                                                     

                                                    What do you think of this one: http://www.jaycar.com.au/productView.asp?ID=YN8309

                                                     

                                                    Although it is not branded on the Jaycar website, I think that it is the EW-7811Un which is verified on the wiki [http://elinux.org/RPi_VerifiedPeripherals#USB_WiFi_Adapters ].

                                                     

                                                    Also, I read on the wiki that someone has made a self-installer (so to speak) which should make it easy to impliment.

                                                     

                                                    Any thoughs before I go -out and buy this wireless adapter?

                                                     

                                                    PS: Should some add the other one to the problem adapter section. 

                                                     

                                                    And as a side not, I think the problem may have been the confusion between the two chips (RT2770 + RT2720) somewhere in the software. or that the hub is not providing enough power and therefore this device is pulling power from the RPi.


                                                    Just a though.

                                                    • Re: Wireless network conectivity
                                                      wallarug

                                                      The two chips in this device are: Ralink RT2780F chipset with RT2720L as transceiver.  Does this mean anything driver wise?

                                                       

                                                      (I am still going to get a new adapter though)

                                            • Re: Wireless network conectivity
                                              wallarug

                                              Mr P wrote:

                                               

                                              i have had issues with broadcom on various laptops using different distro's of linux, this is the best solution i have found so far. i also cant confirm at the moment if the b43 firmware is in the repositories. i will check tonight and see if it is.

                                               

                                              i cant actually try this on the R-Pi as i dont have a USB wifi adapter with the broadcom chipset.

                                               

                                              http://ubuntuforums.org/showpost.php?p=10527475&postcount=5

                                               

                                              hope this helps.

                                              As you can see from the above posts, I don't think that it is a broadcom chipset.

                                                • Re: Wireless network conectivity
                                                  wallarug

                                                  How can I confirm the make if it is a generic brand?

                                                    • Re: Wireless network conectivity
                                                      GreenYamo

                                                      Hello Fergus, although not an answer to the question directly above, have you had a look at the Adafruit distro for the Pi ? From what I remember reading, this has drivers built in for some wireless cards andf may be worth giving a go with your current usb adaptor ?

                                                       

                                                      Morgaine has posted in this forum with links to the distro.

                                                       

                                                      Trying to answer your actual question, have a look at the drivers that come with the adaptor (even if you have got it yet, you can normally find a web page that will supply you the drivers, hopefully from the place you are buying it from) for Windows, and they will give a fair idea. BE something like Drivers\windows\realtek or hopefully something equally as useful.

                                                       

                                                      Steve

                                                        • Re: Wireless network conectivity
                                                          wallarug

                                                          I ahev the drivers, I just can't install them becasue I am a Linux n00b.

                                                           

                                                          Could you help with this and this would solve my problem.

                                                           

                                                          Fergus

                                                           

                                                          See: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=45&t=13482&p=143746#p143746 for files that I need help with.

                                                            • Re: Wireless network conectivity
                                                              wallarug

                                                              Fergus Byrne wrote:

                                                               

                                                              I ahev the drivers, I just can't install them becasue I am a Linux n00b.

                                                               

                                                              Could you help with this and this would solve my problem.

                                                               

                                                              Fergus

                                                               

                                                              See: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=45&t=13482&p=143746#p143746 for files that I need help with.

                                                              Here is the instructions from the readme file that I don't understand/can't find the correct agruments to fill-in.  Could you PLEASE fill-in what I can't and then post back here.  please .

                                                               

                                                                        define the linux kernel source include file path LINUX_SRC

                                                                                   modify to meet your need.

                                                               

                                                              3> In os/linux/config.mk

                                                                        define the GCC and LD of the target machine

                                                                        define the compiler flags CFLAGS

                                                                        modify to meet your need.

                                                                        ** Build for being controlled by NetworkManager or wpa_supplicant wext functions

                                                                           Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y'.

                                                                           => #>cd wpa_supplicant-x.x

                                                                           => #>./wpa_supplicant -Dwext -ira0 -c wpa_supplicant.conf -d

                                                                        ** Build for being controlled by WpaSupplicant with Ralink Driver

                                                                           Please set 'HAS_WPA_SUPPLICANT=y' and 'HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n'.

                                                                           => #>cd wpa_supplicant-0.5.7

                                                                           => #>./wpa_supplicant -Dralink -ira0 -c wpa_supplicant.conf -d

                                                               

                                                               

                                                              4> $make

                                                                        # compile driver source code

                                                                        # To fix "error: too few arguments to function ¡¥iwe_stream_add_event"

                                                                          => $patch -i os/linux/sta_ioctl.c.patch os/linux/sta_ioctl.c

                                                               

                                                               

                                                              5> $cp RT2870STA.dat  /etc/Wireless/RT2870STA/RT2870STA.dat

                                                               

                                                              6> load driver, go to "os/linux/" directory.

                                                                  #[kernel 2.4]

                                                                  #    $/sbin/insmod rt2870sta.o

                                                                  #    $/sbin/ifconfig ra0 inet YOUR_IP up

                                                               

                                                                  #[kernel 2.6]

                                                                  #    $/sbin/insmod rt2870sta.ko

                                                                  #    $/sbin/ifconfig ra0 inet YOUR_IP up

                                                               

                                                               

                                                              7> unload driver   

                                                                  $/sbin/ifconfig ra0 down

                                                                        $/sbin/rmmod rt2870sta

                                                                • Re: Wireless network conectivity
                                                                  GreenYamo

                                                                  Hello Fergus, i'm afraid as I said above, i'm very much a Linux noob too, and other than looking like those instructions are for re-compiling the kernal with the drivers included (and even that is probably wrong) I can't help much

                                                                  All I can say is that to get my USB stick working, I didn't have to do any this, just the instructions I posted a way back up this thread. I think there must be an easier way than doing the above.

                                                                    • Re: Wireless network conectivity
                                                                      wallarug

                                                                      Thats ok.  but I found this site which looks interesting, I am posting it here so I can find it later

                                                                      http://linux.die.net/man/8/iwconfig

                                                                       

                                                                      For fixing a file I messed up.

                                                                      http://elinux.org/RPi_Peripherals#Wireless:_TP-Link_TL-WN722N_USB_wireless_adapter_.28Debian_6.29

                                                                      • Re: Wireless network conectivity
                                                                        wallarug

                                                                        I bought the Edimax EW-7811Un but I need help setting it up, Steve, could you please help me with this one.  The RPi wiki says that it is verified but there is no guide to set-up this device for Raspbian.  I found this guide: http://www.ctrl-alt-del.cc/2012/05/raspberry-pi-meets-edimax-ew-7811un-wireless-ada.html but it has not worked for my RPi.  I think it has something to do with me not being able to get the rpi-update thing.  I tried to get this but failed.  Everytime I run rpi-update it returns:

                                                                         

                                                                        /usr/bin/rpi-update: line 1: syntax error near unexpected token `newline'

                                                                        /usr/bin/rpi-update: line 1: `<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Trans                                                                             itional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">'

                                                                         

                                                                         

                                                                        Can this be fixed so that I can update the firmware?

                                                                         

                                                                        Wireless card help would be nice as well .

                                                                        • Re: Wireless network conectivity
                                                                          wallarug

                                                                          With the EDIMAX, it gives me the errors:

                                                                          8192cu: disagrees about version of symbol <name of part>

                                                                          8192cu: Unknown symbol <name of part> (err -22)

                                                                          8192cu: disagrees about version of symbol <name of part>

                                                                          8192cu: Unknown symbol <name of part> (err -22)

                                                                          8192cu: disagrees about version of symbol <name of part>

                                                                          8192cu: Unknown symbol <name of part> (err -22)

                                                                          8192cu: disagrees about version of symbol <name of part>

                                                                          8192cu: Unknown symbol <name of part> (err -22)

                                                                          8192cu: disagrees about version of symbol <name of part>

                                                                          8192cu: Unknown symbol <name of part> (err -22)

                                                                          8192cu: disagrees about version of symbol <name of part>

                                                                          8192cu: Unknown symbol <name of part> (err -22)

                                                                          8192cu: disagrees about version of symbol <name of part>

                                                                          8192cu: Unknown symbol <name of part> (err -22)

                                                                          8192cu: disagrees about version of symbol <name of part>

                                                                          8192cu: Unknown symbol <name of part> (err -22)

                                                                          8192cu: disagrees about version of symbol <name of part>

                                                                          8192cu: Unknown symbol <name of part> (err -22)

                                                                          8192cu: disagrees about version of symbol <name of part>

                                                                          8192cu: Unknown symbol <name of part> (err -22)

                                                                          8192cu: disagrees about version of symbol <name of part>

                                                                          8192cu: Unknown symbol <name of part> (err -22)

                                                                           

                                                                          The "name of the parts" are all different.

                                                                           

                                                                          What can be done to fix this issue?  This might sovle my problem.

                                                                           

                                                                          How do you unpack a .ko file?

                                                                           

                                                                          I didn't unpack mine.  this could be leading to the above issues.








                                                                           

                                                                          Message was edited by: Fergus Byrne

                                                                            • Re: Wireless network conectivity
                                                                              Drew Fustini

                                                                              My guess is that the 8192cu.ko module you have doesn't agree with the version of the kernel your running.  a .ko file is a kernel module file and shouldn't have to unpacked.  the utility "modinfo" will print out information about the module.  could you run that and paste the output?  also, could you paste what "uname -a" outputs?  it might be that the kernel versions don't agree.

                                                                                • Re: Wireless network conectivity
                                                                                  wallarug

                                                                                  Drew Fustini wrote:

                                                                                   

                                                                                  My guess is that the 8192cu.ko module you have doesn't agree with the version of the kernel your running.  a .ko file is a kernel module file and shouldn't have to unpacked.  the utility "modinfo" will print out information about the module.  could you run that and paste the output?  also, could you paste what "uname -a" outputs?  it might be that the kernel versions don't agree.

                                                                                  Here's the output from uname -a:

                                                                                  Linux raspberrypi 3.1.9+ #168 PREEMPT Sat Jul 14 18:56:31 BST 2012 armv6l GNU/Linux

                                                                                   

                                                                                  I also fixed the problem of the :

                                                                                  8192cu: disagrees about version of symbol <name of part>

                                                                                  8192cu: Unknown symbol <name of part> (err -22)

                                                                                  8192cu: disagrees about version of symbol <name of part>

                                                                                  8192cu: Unknown symbol <name of part> (err -22)

                                                                                  8192cu: disagrees about version of symbol <name of part>

                                                                                  8192cu: Unknown symbol <name of part> (err -22)

                                                                                  8192cu: disagrees about version of symbol <name of part>

                                                                                  8192cu: Unknown symbol <name of part> (err -22)

                                                                                   

                                                                                  ...by deleting the driver (8192cu.ko file).

                                                                                   

                                                                                  Which leads me to suspect that the RPi s/ware didn't like it.

                                                                                   

                                                                                  I can now also tell you that the output of lsusb is:

                                                                                  Bus 001 Device 007: ID 7392:7811 Edimax Technology Co.,Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

                                                                                   

                                                                                  I hope this helps you solve my problem.  I also found someone who had the same problem and am reading what they did now: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=26&t=6256&hilit=edimax&start=575

                                                                                   

                                                                                  Thanks

                                                                                    • Re: Wireless network conectivity
                                                                                      wallarug

                                                                                      THIS IS A MUST ADD TO THE WIKI! (it is already there but is not advertised very well)

                                                                                       

                                                                                      http://www.raspberrypi.org/phpBB3/viewtopic.php?f=26&t=6256&hilit=edimax&start=600 

                                                                                       

                                                                                      http://dl.dropbox.com/u/80256631/install-rtl8188cus.txt

                                                                                       

                                                                                      and

                                                                                       

                                                                                      http://dl.dropbox.com/u/80256631/install-rtl8188cus-latest.sh

                                                                                       

                                                                                      These solved all my problems in less than 15minutes.  Keep in mind that it only works for some adapters, which are listed on the 1st link.

                                                                                      The script also installs all the latest updates for the RPi (rpi-update) as well as setting up your wireless.

                                                                                       

                                                                                      Great job,  MrEngman

                                                                                       

                                                                                      I still wonder how to install my other device though.  So if anyone finds this out, please let me know (it is not really that important now).

                                                                                       

                                                                                      Fergus.

                                                                                      • Re: Wireless network conectivity

                                                                                        8192cu: disagrees about version of symbol <name of part>

                                                                                        8192cu: Unknown symbol <name of part> (err -22)

                                                                                         

                                                                                        ...by deleting the driver (8192cu.ko file).

                                                                                         

                                                                                        Which leads me to suspect that the RPi s/ware didn't like it.

                                                                                        What those messages tell you is that the module you compiled was built against a different kernel than the one you're running. Sometimes this can be as simple as having the exact same kernel source, but just one option has been changed in the .config

                                                                                         

                                                                                        To build external modules you need the correct kernel source tree and the .config from the running kernel. You can usually obtain this from the /proc/config.gz file.

                                                                                         

                                                                                        It's difficult to cover every possible problem in just a few lines, but here's a basic outline of how it should be done - no idea if this would work for you though

                                                                                         

                                                                                        cd /home/pi  - or wherever

                                                                                        git clone https://github.com/raspberrypi/linux.git - this should leave you with a 'linux' directory eventually, it will take some time

                                                                                        cd linux

                                                                                        cp /proc/config.gz .   - copy config of running kernel

                                                                                        gunzip config.gz       - unpack config

                                                                                        mv config .config      - move it to (dot)config that leading . is necessary !

                                                                                        make oldconfig         - this configures the kernel source with the config of your running kernel

                                                                                         

                                                                                        if make oldconfig asks lots of confusing questions you don't know how to answer, try make silentoldconfig instead

                                                                                         

                                                                                        at this point you can go and build your driver, but you must make sure it uses the kernel source tree you've just configured. You likely need to change two symlinks under /lib/modules/* for this to work properly like this:

                                                                                         

                                                                                        rm /lib/modules/`uname -r`/build

                                                                                        rm /lib/modules/`uname -r`/source

                                                                                        ln -s /home/pi/linux /lib/modules/`uname -r`/build

                                                                                        ln -s /home/pi/linux /lib/modules/`uname -r`/source

                                                                                         

                                                                                        now build and install your external driver module.

                                                                                         

                                                                                        It's sometimes the case that you'll end up with two conflicting versions of a driver, you can search for them like this

                                                                                         

                                                                                        find /lib/modules/`uname -r`/ -name 8192cu.ko

                                                                                         

                                                                                        if that finds more than one, delete all of them and then re-run the drivers install.

                                                                                         

                                                                                        When you're done, run depmod -a hopefully the driver install did it for you, but sometimes they don't.

                                                                                         

                                                                                        You should then be able to run modprobe 8192cu to load the module. dmesg will show you any errors.

                                                                                         

                                                                                        I hope some of the above helps, but no guarantees - too many assumptions in there for guarantees

                                                                                          • Re: Wireless network conectivity
                                                                                            wallarug

                                                                                            selsinork wrote:

                                                                                             

                                                                                            8192cu: disagrees about version of symbol <name of part>

                                                                                            8192cu: Unknown symbol <name of part> (err -22)

                                                                                             

                                                                                            ...by deleting the driver (8192cu.ko file).

                                                                                             

                                                                                            Which leads me to suspect that the RPi s/ware didn't like it.

                                                                                            What those messages tell you is that the module you compiled was built against a different kernel than the one you're running. Sometimes this can be as simple as having the exact same kernel source, but just one option has been changed in the .config

                                                                                             

                                                                                            To build external modules you need the correct kernel source tree and the .config from the running kernel. You can usually obtain this from the /proc/config.gz file.

                                                                                             

                                                                                            It's difficult to cover every possible problem in just a few lines, but here's a basic outline of how it should be done - no idea if this would work for you though

                                                                                             

                                                                                            cd /home/pi  - or wherever

                                                                                            git clone https://github.com/raspberrypi/linux.git - this should leave you with a 'linux' directory eventually, it will take some time

                                                                                            cd linux

                                                                                            cp /proc/config.gz .   - copy config of running kernel

                                                                                            gunzip config.gz       - unpack config

                                                                                            mv config .config      - move it to (dot)config that leading . is necessary !

                                                                                            make oldconfig         - this configures the kernel source with the config of your running kernel

                                                                                             

                                                                                            if make oldconfig asks lots of confusing questions you don't know how to answer, try make silentoldconfig instead

                                                                                             

                                                                                            at this point you can go and build your driver, but you must make sure it uses the kernel source tree you've just configured. You likely need to change two symlinks under /lib/modules/* for this to work properly like this:

                                                                                             

                                                                                            rm /lib/modules/`uname -r`/build

                                                                                            rm /lib/modules/`uname -r`/source

                                                                                            ln -s /home/pi/linux /lib/modules/`uname -r`/build

                                                                                            ln -s /home/pi/linux /lib/modules/`uname -r`/source

                                                                                             

                                                                                            now build and install your external driver module.

                                                                                             

                                                                                            It's sometimes the case that you'll end up with two conflicting versions of a driver, you can search for them like this

                                                                                             

                                                                                            find /lib/modules/`uname -r`/ -name 8192cu.ko

                                                                                             

                                                                                            if that finds more than one, delete all of them and then re-run the drivers install.

                                                                                             

                                                                                            When you're done, run depmod -a hopefully the driver install did it for you, but sometimes they don't.

                                                                                             

                                                                                            You should then be able to run modprobe 8192cu to load the module. dmesg will show you any errors.

                                                                                             

                                                                                            I hope some of the above helps, but no guarantees - too many assumptions in there for guarantees

                                                                                             

                                                                                            I am a linux n00b,  I read something and think that was what the problem could be. Anyway, the problems are all solved for me anyway.

                                                                                             

                                                                                            thanks for the help.

                                                                                             

                                                                                            Message was edited by: Fergus Byrne

                                                                                            • Re: Wireless network conectivity
                                                                                              wallarug

                                                                                              YEPPY!!

                                                                                               

                                                                                              I worked it out after 6 months of trouble.

                                                                                               

                                                                                              I found these instructions: http://elinux.org/RPi_Ralink_WLAN_devices

                                                                                              ...Which I then used to install the card as my second Wireless interface.

                                                                                               

                                                                                              Install the wpasupplicant and the ralink firmware:

                                                                                              1) sudo apt-get install wpasupplicant

                                                                                              2) sudo apt-get install firmware-ralink

                                                                                              Restrict access to /etc/interfaces so only root can read it (in this method, this file will contain your network password):

                                                                                              3) sudo chmod 0600 /etc/network/interfaces

                                                                                              Edit you /etc/network/interfaces:

                                                                                              4) sudo nano /etc/network/interfaces

                                                                                              5) The file already contains the configuration for eth0 (your Ethernet port) and looks something like this:

                                                                                              auto eth0 iface eth0 inet dhcp  

                                                                                              add the following lines below, enter you network name (ssid) and password:

                                                                                              iface wlan0 inet dhcp wpa-ssid <your network ssid here>  wpa-psk <your network password>  

                                                                                              6) save the file.

                                                                                              The network interface will connect every time the RPi boots up. To connect it now manually, run:

                                                                                              7) sudo ifup wlan0

                                                                                               

                                                                                              I hope someone can now add this to the wiki as a working adapter.

                                                                                               

                                                                                              Ralink Technology, Corp. RT2870 Wireless Adapter

                                                                                              ID: 148f:2870

                                                                                               

                                                                                              Must be used with a powered hub and works out-of-the-box with Raspbian (August 16th 2012 --> From Raspberrypi.org Download page)

                                                                                               

                                                                                              The only real instructions required are:

                                                                                              1. Image card and go through normal set-up

                                                                                              2. Plug in card and confirm that it is what it says it is using "lsusb" command

                                                                                              3. Type in "sudo nano /etc/network/interfaces"

                                                                                              4. Add the following lines:

                                                                                              auto lo

                                                                                               

                                                                                              iface lo inet loopback

                                                                                              iface eth0 inet dhcp

                                                                                               

                                                                                              allow-hotplug wlan0

                                                                                               

                                                                                              auto wlan0

                                                                                               

                                                                                              iface wlan0 dhcp

                                                                                              wpa-ssid <insert name of your ssid here using inverted commas " ">

                                                                                              wpa-psk < insert password of access point here using inverted commas " ">

                                                                                              5. Use the command "sudo ifup wlan0"

                                                                                              6. Let the device connect

                                                                                              7. You should be connected.

                                                                                               

                                                                                               

                                                                                              Thanks for all the help.

                                                                                               

                                                                                              This problem is now SOLVED.

                                                                                               

                                                                                              Fergus.