21 Replies Latest reply on Dec 27, 2012 12:18 PM by waltersm

    Got my Raspberry Pi, but...


      Got my Raspberry Pi...


      Plugged in the card I got from Element14...plugged in power adapter I got from Element14...Raspberry Pi showed solid red light on. Is it supposed to?


      Then...I plugged into my HDMI to my TV. TV was looking for something and never found it. Tried different settings. Nothing worked. Screen on TV never changed.


      Suggestions welcome. Thanks for any help you can provide.

        • Re: Got my Raspberry Pi, but...
          John Beetem



          I suggest starting with the RasPi Troubleshooting Wiki.  The most common problem is low voltage measured from TP1 to TP2: it should be at least 4.75V for reliable operation.  This can be caused by an iffy power supply, or more often by an iffy Micro USB power cable.


          Solid red LED means the power supply is active -- that's good.  You should also see some flashes on the OK LED which means that RasPi is trying to load the operating systems from the SD card.  If you don't see flashes on the OK LED, check the SD card slot's contacts with a magnifier to make sure none are bent, and make sure the SD card is inserted all the way.  Check the Troubleshooting Wiki for other suggestions.

            • Re: Got my Raspberry Pi, but...

              John...Red light stays on. No other flashing lights. SD card seems fine. Get can't find signal from TV.


              David...I plugged in monitor/TV, keyboard and mouse before connectiong power. Get can't find signal from TV.



                • Re: Got my Raspberry Pi, but...

                  After reading the troubleshooting information, I've come to realize that using a Raspberry Pi is not as easy as it sounded when I heard about it as a device for kids. It sounds more like a toy for kids who have engineers in the family. Measuring voltage and testing connecting cords, etc. is way beyond a mere mortal like me.

                    • Re: Got my Raspberry Pi, but...

                      Joel, you've taken a  very good first step towards discovering that it's not as hard as it seems by coming to this technical/engineering site.   It does require some minimal investment in a digital multimeter, but an adequate one can be bought for well under a tenner.


                      Admittedly I'm biased, but I strongly believe that nobody, and I really do mean nobody, should be without a multimeter.  Even if you do nothing more than test the charge state of batteries, it will pay for itself in no time because it makes a person more informed and less ambling in the dark.  That is easily worth its weight in gold.


                      And armed with a multimeter, you'll find no shortage of people willing to help on this site, and elsewhere.



                        • Re: Got my Raspberry Pi, but...

                          >>Admittedly I'm biased, but I strongly believe that nobody, and I really do mean nobody, should be without a multimeter.<<


                          OK, tomorrow I'll go to my local Radio Shack and get a multimeter.


                          Looking foward to the wonderful world of multimetering. I hope.

                            • Re: Got my Raspberry Pi, but...

                              Wow, I've made a sale!    Pity I get no commission.


                              Be sure it's a digital one.  Analogue multimeters are still around (barely), but generally have little utility compared to even the cheapest of digital instruments today.


                              Addendum:  Related issues and similar advice given in this thread .

                                • Re: Got my Raspberry Pi, but...
                                  Colin Barnard

                                  I feel I have to disagree slightly with your comment Morgaine,  I find there are still good uses for an analogue multimeter especially where indicative readings are what are needed rather than absolute ones, such as RC discharge or rough capacitor values or sudden voltage/current changes.


                                  Admittedly as you say for Pi purposes and general electronics, a digital meter is the way to go, I just think you've written off analogue meters a bit too quickly, even if privately you still use them.


                                  Of course just to muddy the waters, I prefer to use an oscilloscope for hunting down logic  and AC problems, but I'm not suggesting people need to run off and buy a sillyscope (tm John Beetem), just to play with their Pi.



                                    • Re: Got my Raspberry Pi, but...

                                      Hehe.  Well I have a ton of old analogue instruments here as well, so I do slightly sympathize with your comment ... but not a lot.


                                      Analogue indicators can sometimes be more useful than digital readout as you say, but then, all my digital multimeters feature analogue bar indicators as well, even the cheapest one.  I expect that's  normal nowadays.  I do wish I could alter the damping factor on the bars though, as I don't find a single compromise setting sufficient in all cases.


                                      And yes, I agree with your comment about oscilloscopes entirely.  If they were available for under a tenner, I'd be recommending that Joel buy a sillyscope (tm John Beetem) instead of or in addition to the multimeter.

                        • Re: Got my Raspberry Pi, but...

                          You need to plug in all your monitor/TV, keyboard, mouse, etc. BEFORE connecting power (otherwise it will not detect any monitor).  It might take awhile to boot.


                          I don't have my Raspberry Pi yet, but longtime Linux user and I have read the wiki and downloaded the current SD card image to take a peek at it.  The SD card may not have the most recent software.  There are other discussions about that, for example http://www.element14.com/community/message/62360#62360/l/new-raspberry-pi-w-512mb--doa

                          • Re: Got my Raspberry Pi, but...

                            Dear Joel

                            dont give up

                            raspi is realy as simply as computer can be


                            same issue i found on my first rpi start

                            in case when my tv is not connected and switched on in time of startup

                            yellow RCA conector is used for video output.

                            can u utilize/test this (analog tv) video signal?


                            in case that i dont connect rpi to net, only one red led light is also on.


                            also try to verify content of sd card in another pc

                            in official image you can find file issue.txt

                            in latest includes "Raspberry Pi reference 2012-10-28 (armhf)"

                              • Re: Got my Raspberry Pi, but...

                                You know the basics already.

                                At poweron, red should go on (indicating 3V3 is present and nothing more)

                                green ok should start flashing when the os is loaded.

                                If green shows no activity, problem can be supply, sd card or Pi itself.


                                power can be checked by measuring the TP1 - TP2 voltage.

                                It can be the power adapter or the cable between the adapter and the Pi who are responsable for the voltage being 2 low.

                                The Pi has some polyfuses which also can be responsable for lower voltage readings.


                                sdcard itself can be checked on a pc. You should be able to see the small fat32 boot partition and it's boot files. it's only 50 - 70MB in size.

                                The larger linux root file partition is ext4 and can only be checked on a linux or mac system. (You have tools under windows to open ext4 partitions as well.)


                                If you have another sdcard lying around, it might be worth to give that a try.

                                Sometimes the sd card socket contacts give bad contact. A visual inspection of those can be usefull in such case.


                                Don't connect any usb devices during your initial tests. Only start with those after you have seen the green light that indicates the sd card partitions are recognised.

                                  • Re: Got my Raspberry Pi, but...

                                    Got my digital multimeter first thing this morning.


                                    Only solid red light shows up when Pi is plugged in.


                                    TP1-TP2 is 5.2...so that sounds right.


                                    Information on the card (as is shown on my Mac) is as follows:

                                    Screen Shot 2012-11-24 at 10.32.55 AM.png

                                    What can/should I do next?

                                      • Re: Got my Raspberry Pi, but...

                                        Despite the card looking OK on the Mac, my money is on a corrupt SD card, this has happened a few times to my knowledge at least.

                                        Any chance you can borrow an SD card and image it yourself from one of the images on the Raspi site ?

                                        Solid red light seems to indicate that the Pi can't find a valid boot image. Could also mean the SD card isn't fully inserted.

                                        Like I say, seem to be a number of corrupt SD cards, what do the postal services do to them ?



                                        • Re: Got my Raspberry Pi, but...
                                          John Beetem

                                          Joel Heffner wrote:


                                          Got my digital multimeter first thing this morning.


                                          Only solid red light shows up when Pi is plugged in.


                                          TP1-TP2 is 5.2...so that sounds right.


                                          Information on the card (as is shown on my Mac) is as follows...


                                          What can/should I do next?

                                          As Steve says, you could download a new SD card image, preferably to a different SD card.  This has the advantage that you'll be getting a newer version of the OS, which will most likely perform better.  OTOH, it's a long process and the whole point of buying a pre-loaded SD card is to avoid this.


                                          If you know someone nearby who has a RasPi you could try swapping SD cards and see which RasPis work with which cards.


                                          Otherwise, at this point I'm thinking your best bet is to send it back for a replacement.  You need to get an RMA (Return Materials Authorization) from the vendor's web site.  Since TP1-TP2 looks good and the SD contacts look good and the SD directory looks good, here are the most likely problems IMO:


                                          1.  The contents of an SD card file is corrupted.    Try is copying the files from the SD card to your Mac and see if you get any bad file errors.


                                          2.  An iffy solder joint has failed.  They do a quick go/no go RasPi test at the factory, but at this price range you're not going to get burn-in testing, so thermal cycling and/or transportation may have caused an iffy solder joint to fail.


                                          3.  An iffy PC board trace has failed.  A hair-line crack can survive initial testing, but fail after thermal cycling.


                                          RMAs help the manufacturer and designers to learn what's going wrong.  From the small number of problems people are reporting relative to the number of RasPis out there (I think well over 500K) I would guess that the yield is already pretty high, but that doesn't help if you're one of the unlucky ones either with the RasPi itself or the SD card.

                                          • Re: Got my Raspberry Pi, but...
                                            Drew Fustini

                                            Hi - do you if you have a 512MB Pi?  If so, then the issue is that this pre-programmed card is too old based on your screenshot (June 17 kernel and firmware).


                                            Your profile shows USA so I assume you purchased from Newark element14.  I'd recommend you contact customer service and ask for a replacement:




                                            The newer pre-formatted cards have July 15th kernel/firmware which is recent enough to boot the 512MB Pi.  Once you receive the replacement card, you can update it to the most recent firmware to enable the extra memory with these instructions: http://www.element14.com/community/groups/raspberry-pi/blog/2012/11/14/update-process-to-enable-to-full-512mb-ram




                                      • Re: Got my Raspberry Pi, but...

                                        Dear Fellow Raspberry Pi Users! Yes, FELLOW users.


                                        I ordered a new card and it took a while to get it...however, the 2nd card works!


                                        Thanks to all who helped. I appreciate it.


                                        Now...all I have to do is figure out how to do the stuff I want to do with it.

                                        • Re: Got my Raspberry Pi, but...

                                          I have exactly the same problem and also got an Element 14 preloaded card. I'll have to go through the pain of trying a new card and new download, I just hope it's not a broken pi. It was my Christmas pressie