14 Replies Latest reply on Apr 23, 2017 3:58 PM by rigpa

    Software for PiFace


      I have just bought a PiFace board but after two days of trying I cannot obtain any software to run it. I have tried https:// github.com and it returns "no such file or directory. I've tried PiFace Digital, "Getting Started with PiFace Digital in less than ten minutes", on the page starting "you can always enable the SPi driver .................. The software appears to have downloaded and installed but the PiFace Emulator doesn't work. (I used the command piface/scripts/piface_emulator) and it returned "no such file or directory".

      Can someone spot where I'm going wrong please?

          • Re: Software for PiFace

            Dear Tom,

            I have updated Raspbian and installed pifacedigitalio following your

            advice. Unfortunately blink.py failed with the report "no such file or


            It seems that all along I've been having that report so I still need help

            I'm afraid.

            My home/pi directory at present contains the folders:




            RPi.GPIO .0.5.3a





            Python Games








            pure13.0.2.55 8en_gb.exe

            1 of 1 people found this helpful
              • Re: Software for PiFace

                Can you try the following commands and show me the output, please?


                    $ aptitude show python3-pifacedigitalio

                    $ ls -l /usr/share/doc/ | grep piface

                  • Re: Software for PiFace

                    Dear Tom,

                    Here is the listing for you:


                    pi@raspberrypi ~ $ aptitude show python3-pifacedigitalio

                    Package: python3-pifacedigitalio

                    State: installed

                    Automatically installed: no

                    Version: 2.1.0-1

                    Priority: optional

                    Section: python

                    Maintainer: Thomas Preston <thomas.preston@openlx.org.uk>

                    Architecture: all

                    Uncompressed Size: 528 k

                    Depends: python3 (>= 3.2.3-3~), python3-pifacecommon (>= 3.0.0),

                             python3-pifacecommon (< 4.0.0)

                    Description: The PiFace Digital I/O module.

                    Python 3 module for interacting with PiFace Digital. Documentation:



                    pi@raspberrypi ~ $ is -l /usr/share/doc/ | grep piface

                    bash: is: command not found

                    pi@raspberrypi ~ $ ls -l/usr/share/doc/ | grep piface

                    ls: invalid option -- '/'

                    Try `ls --help' for more information.

                    pi@raspberrypi ~ $




                    I was confused by the typeface using your second line. Sorry.



                    • Re: Software for PiFace

                      Dear Tom,

                      I've done all the updating and upgrading of Raspian as per examples on

                      https://github.com/piface/pifacedigitalio. The outcome of the Blink test

                      was :


                      pi@raspberrypi ~ $  python3



                      Traceback (most recent call last):


                        File "/usr/lib/python3/dist-packages/pifacecommon/spi.py", line 40, in



                          self.fd = posix.open(spi_device, posix.O_RDWR)


                      OSError: No such file or directory: '/dev/spidev0.0'



                      During handling of the above exception, another exception occurred:



                      Traceback (most recent call last):


                        File "/usr/share/doc/python3-pifacedigitalio/examples/blink.py", line 9,



                          pifacedigital = pifacedigitalio.PiFaceDigital()


                        File "/usr/lib/python3/dist-packages/pifacedigitalio/core.py", line 45,

                      in __init__


                          super(PiFaceDigital, self).__init__(hardware_addr, bus, chip_select)


                        File "/usr/lib/python3/dist-packages/pifacecommon/mcp23s17.py", line 91,

                      in __init__


                          super(MCP23S17, self).__init__(bus, chip_select)


                        File "/usr/lib/python3/dist-packages/pifacecommon/spi.py", line 32, in





                        File "/usr/lib/python3/dist-packages/pifacecommon/spi.py", line 44, in



                          % (spi_device, SPI_HELP_LINK)


                      pifacecommon.spi.SPIInitError: I can't see /dev/spidev0.0. Have you enabled

                      the SPI module? (




                      pi@raspberrypi ~ $



                      I hope this is useful to you. I saw no activity on the PiFace board. Is it

                      my error perhaps? Can you offer any other ideas please?


                      Chris Hart

                        • Re: Software for PiFace

                          One thing immediately jumps out at me

                          pifacecommon.spi.SPIInitError: I can't see /dev/spidev0.0. Have you enabled

                          the SPI module?


                          Have you? I would suggest following the link and see where that takes you.


                          The error seems to be that the driver for the SPI is not loaded, therefore the OS doesn't know about /dev/spidev0.0


                          On Unix (and by extension Linux) systems most of the IO is handled as if the device were a file, so when a device driver is loaded the OS will create a "file" in the /dev/ directory corresponding to the device. In this case the SPI device.


                          If that file is not found, it probably means that the driver for the file isn't loaded, or you don't have permission to access it.


                          I haven't had the opportunity to play with the PiFace yet, but I would suspect that your error has something to do with the module not being enabled.


                          I briefly visited this page

                          Installation — PiFace Common 4.0.0 documentation 

                          which is the same as the link above and it seems to have the information you need.


                          Good Luck,


                        • Re: Software for PiFace

                          Dear Tom,

                          I have got the PiFace to respond by having gone into Config Advanced and

                          setting SPI to "Yes" following advice at:


                          I'm looking forward to learning how to set up and run some interesting


                          Kind regards,

                          Chris. Hart.

                    • Re: Software for PiFace

                      You should be able to obtain the examples and documentation from the Github source https://github.com/piface/pifacedigitalio

                        • Re: Software for PiFace

                          Thanks for suggestion. I have followed this through to the letter and ended up with a puzzling result with the blink.py routine failing once again with a directory problem:


                          pi@raspberrypi ~ $  python3 /usr/share/doc/python3-pifacedigitalio/examples/blink.py
                          Traceback (most recent call last):
                          File "/usr/lib/python3/dist-packages/pifacecommon/spi.py", line 40, in open_fd
                          self.fd = posix.open(spi_device, posix.O_RDWR)
                          OSError: [Errno 2] No such file or directory: '/dev/spidev0.0'


                        • Re: Software for PiFace

                          pifacedigital-emulator works straight off the prompt for me

                          • Re: Software for PiFace

                            This discussion is over a month old now, but there is now a new official PiFace website with some good documentation on it.



                            • Re: Software for PiFace

                              There is some actualization about how to fix this problem?

                              I am having exactly the same issue. I bouth a piface and and i have tried to install the software several time and I always achieve:

                              SPIInitError: I can't see /dev/spidev0.0. Have you enabled the SPI module? (htt\ p://piface.github.io/pifacecommon/installation.html#enable-the-spi-module)


                              I have followed all the instructions named in this conversations but it doestn work.


                              Can you all guys please help me?



                              • Re: Software for PiFace

                                I'm having the same issue. I've tried enabling the SPI module with raspi-config. After enabling, it still returns the same result as shown above.


                                Also trying the emulator gives the following result.


                                $ pifacedigital-emulator

                                Error initialising PiFace Digital:  I can't see /dev/spidev0.0. Have you enabled the SPI module? (http://piface.github.io/pifacecommon/installation.html#enable-the-spi-module)

                                Running without hardware PiFace Digital.

                                pifacedigital-emulator: cannot connect to X server


                                Could anyone come to our aid?

                                • Re: Software for PiFace

                                  This somehow solved it for me : (found this on GitHub) https://github.com/piface/pifacecommon/issues/7

                                  ... Don't know what caused the SPI module to be missing in the first place, and don't know what exactly fixed it, but oh well, it works now.

                                  I have solved it by installing spidev0 and spidev0.1 files with this proccedure:
                                  I don't know why, but the original distribution of raspbian doesnt include it, you can even set SPI true in the raspi-config screen, but it doesnt work if the spidev0 and pidev0.1 files are not installed. Maybe it coul be nice if the instalation of pifacedigital-emulator could verify if and if it is missing, then auto installing.
                                  Another little issue I found in the spidev0 instalation proccedure, is that you have to install/upgrade firmware files, then other devices depending on the version istalled(like wifi dongle in my case) can be misconfiguerd.

                                  1 of 1 people found this helpful