26TH JULY

Freescale CodeWarrior IDE

Putting the battery subject aside, It was time to check the CodeWarrior Installation.

 

I plugged in the XL_STAR to my PC.The USB device drivers installed without a hitch.

 

I then ran up the FreeScale CodeWarrior but encountered a read only error pop up about Read Only access to the preferences file.

Since I have Windows 7 restarted it using "run as administrator" to enable read/write access to the preferences file and it worked.

No dramas!

Did I miss a note in the documentation about this?

[29/07/2011] - Since then , I granted the User's group Modify rights to the CodeWarrior IDE 5.9 Prefs file in CodeWarrior bin folder

[29/07/2011] - I also deleted all IDE.EXE*.dump files in the same folder.

[29/07/2011] - I see how it goes.

[31/07/2011] - No problems as yet.

[04/07/2011] - None of the above configurations or problems encountered when installing and running on Vista.

 

I ran the Updater and updated the 3 patches it found on the Internet.

 

I then restarted CodeWarrior, reloaded the XL_STAR demo program, remade the file and executed the debug mode.

It worked as expected allowing me to single step through the sample code.

 

I'm now armed and ready to develop.