From the Overview in Visual Studio, you can get the "Device Status", from there you can get the application status of the attached device.

It's also possible to launch the Azure Sphere developer prompt from here and run the "azsphere dev show-attached" command. When I ran that it showed that my operating system was out of date which makes sense given the SDK update earlier in the week.

OTA updates

If you run the show ota commands you can see what version and details you are running.

 

azsphere device show-ota-config

azsphere device show-ota-status

So I ran the device recovery command as suggested and my new OS was flashed onto the device in a couple of minutes.

My application appears to have been lost in this process. So I ran show-ota-status again and this time got a message that the security service is targeting with a depreciated version with a URL to visit -  aka.ms/AzureSphereUpgradeGuidance which asked me to sign in and then led to a 403 forbidden message but now leads to the home page...

The flashing process also lost my wifi settings so I put those back in. When I then asked for the status I got the correct answer. I suspect the issue here was that it was caching the setings?

It will be interesting to see how this process differs when the device is in field mode.