set up a new workstation in my living room dinning table. I am getting frustrated with Mint-Cinnamon So I loaded Ubuntu  but I did not there shell so Installed Cinnamon on top of it.

And that just was never meant to be. So after a few months, I to try Debian 9.1 with Cinnamon (distro).

Installer Grief
  1. You can not install from the Live-CD (DVD) Shell/GUI
  2. You can not run fsck as it's not there!!
  3. If you don't have a DHCP network you have problems. (It can't download the libraries.)
  4. And you can't set the network during the install.
  5. Also, you can't sudo, or mount (no password)

After two installs, its installer and Live-CD are both junk.

Re-Install
  1. Set up my ip address, mask, and my DNS server.
  2. grabbed the nfs-common package.
  3. updated the computer
  4. NOW THE GRIEF
  5. adduser username sudo. (as root) & reboot twice
  6. Add in most of my toys.
  7. Then run sudo systemctl unmask nfs-common

I put up Sonar as my screen-saver which  over night, locked up. Now mind you I had NFS4 working like a charm

So I had to power down the system ie "10 seconds on the power switch" which did a number on my drive.

After internal fsck cleared the drive and I was logged back in both of my sudo, and showmount would not work and gave lots of fun errors. So after beating myself up, and going up blind alleys. I reloaded Debian, one more time. and ran the update. Still the same problem. I felt stupid, like a dog chasing his tail.

So I dug in and looked some more, and more.  So I reloaded nfs-common, after purging the old one. and still the problem remained.  This was my error:

"Failed to start nfs-idmapd.service: Unit nfs-server.service not found."

I now seemed to be getting somewhere,  I did not have nfs-server installed  just the client package nfs-common so I tried to  reload nfs-common, but then I got an error:

"Failed to restart nfs-common.service: Unit nfs-common.service is masked" Duh, apparently during the updates it Masked the service (file) Permissions!, Permissions!

So I ran sudo systemctl unmask nfs-common. It now works like it should, That was 3 days down the drain. Good lesson.

 

fins.

C. Harrison 

 

PS: texadactyl thank you for the mention.