Well, I am working to get the Indicator done today or tomorrow, the slight tremors in my hands make Wire-Wrap a real pain. I will not get to a point where this will be buttoned-up, as there will be a lot of jumpers! I also have to trim down the interface board with my Dremel sander as it's not square to the mounted display board and the interconnect mounted on my interface vector board, which I thought was square, to begin with as Vector board has .1 by .1 hole spacing. Duh? Also when the display board is mounted in place and the interface is plugged together you have to pry them apart, with a small screwdriver.

My wiring plan is per my blog NexGenFuel Indicator Redux v2.  The TI PCF8575 can not be broken into two distinct ports. That is for instance to use port-A for switches(input) and then use port-B for LEDs (output). So my choice was to use the MCP23017 it is a 5-volt device,  it allows me to use the I/O expanders ports as two 8-bit ports or one 16-bit port. port-A bits 0 to 4 for the devices' address bus, yellow wires, and port-B bits 0 to 7 for the device data bus, orange wires. The picture on the left does not show either the I2C's SDA, yellow jumper, or SDC, orange jumper, and the MCP23017's I2C address lines, black wires, which I will have grounded which will give my base address of hex.40

I will also use a separate power supply for the displays as each display will use 300ma or a little more. So that means I need 600ma + the Arduino Mega  Source-Sink is about 800ma. So I will have to power the displays from an outside source. Even though there will be two power supplies I will have ground on the display board connected to the interface board, and to the Arduino Megas ground. The Arduino will also power the display interface board, along with the switches, and their logic.

I have hooked the interface board to the Arduino power and SDA/SDC pins and proceeded to run the  I2C discovery program. FAIL! Let's put it this way everybody who knows me, knows how much I love the Arduino IDE. I wish it would just DIE! Most of today I had problems getting to the tty ports! This took most of this Sunday the 15th. I had to add myself to the /etc/sudoers file which is only readable, so I ran chmod +w sudorers. Added my self to the file with the same permissions a ROOT, save the file rebooted my PC  the only way I got it to work was to use this command sudo /home/harrison/arduino-1.8.5/arduino. That worked so I ran the I2C scanner which said: No I2C available.

So I am stoved in. Time for bed. And the world will turn and bring a new day!

~~Cris H