7 Replies Latest reply on Feb 28, 2012 1:39 PM by

    bug regarding text logo in library and flood-fill

    frank26080115

      I have demonstrated the bug in this video, please watch it in 1280x720 and full screen

       

      http://www.youtube.com/watch?v=odne9gdBqfY

       

        • Re: bug regarding text logo in library and flood-fill

          Frank Zhao wrote:

          I have demonstrated the bug in this video, please watch it in

          1280x720 and full screen

           

          http://www.youtube.com/watch?v=odne9gdBqfY

           

           

          I agree there is  a defect that  needs correcting as the behaviour should be

          the same for the Top and Bottom layers.

           

          I wish to point out an error with your package design.

          You drew a rectangle around your text using a zero width wire, placing it on

          the tRestrict layer.

          That had no effect as the area under the zero width wire has no area. The

          ratsnests you performed revelaed this.

           

          Had you wanted the copper text within a  rectangle clear of copper you

          should have formed the rectangle with the RECTANGLE tool

           

          HTH

          Warren

           

          --

          Viewed / responded via the newsgroup at

          news.cadsoft.de

           

           

           

            • Re: bug regarding text logo in library and flood-fill
              frank26080115

              Hi Warren

               

              The reason the tRestrict layer appears to have not taken effect is because the flood fill polygon had isolate set to 0, also orphan was enabled. I prefer to use tRestrict wires to completely enclose an area instead of rectangles or polygons because I don't want the area to appear shaded. If this is not a recommended practice, then let me know.

               

              Regardless of that, I made my point. I hope this gets fixed.

               

              Have a look at the actual logo

               

              http://i.imgur.com/SivO9.png

                • Re: bug regarding text logo in library and flood-fill

                  Frank Zhao wrote:

                  Hi Warren

                   

                  The reason the tRestrict layer appears to have not taken effect is

                  because the flood fill polygon had isolate set to 0, also orphan was

                  enabled. I prefer to use tRestrict wires to completely enclose an

                  area instead of rectangles or polygons because I don't want the area

                  to appear shaded. If this is not a recommended practice, then let me

                  know.

                   

                  Regardless of that, I made my point. I hope this gets fixed.

                   

                  Have a look at the actual logo

                   

                  http://i.imgur.com/SivO9.png

                   

                  The logo image looks unconventional to me.

                   

                  The top flood fill has an edge shape that mimics a clearance from the text

                  on the bottom layer. It may be what you intended

                  So what object is the top flood fill keeping away from?

                   

                  Warren

                   

                  --

                  Viewed / responded via the newsgroup at

                  news.cadsoft.de