46 Replies Latest reply on Dec 19, 2013 11:31 AM by morgaine

    FRDM-KL25Z OpenSDA - rollback


      Leapt before looking and upgraded hardware to 1.05 version from Quickstart Package. This NO LONGER WORKS WITH UBUNTU 12.04. The shipped version 1.01 was working fine.


      Anyone have an older version (anything pre 1.05) of the OpenSDA file, that I could try?

        • Re: FRDM-KL25Z OpenSDA - rollback

          I do have version V1.02 (DEBUG-APP_Pemicro_v102.SDA). Would that help?



          • Re: FRDM-KL25Z OpenSDA - rollback

            Can you define worked? I was able to get the default USB mass storage device to appear under Ubuntu, but not the Bootloader, were you able to get both? I tried dragging one of the sample binaries to the default device and when I rebooted it appeared to do nothing. I had to boot windows in a virtual box to restore the blinky-slider demo.


            I won't be near my board for a few hours, but I will gladly check when I get home, perhaps we can compare notes, I would much prefer to work in ubuntu so if I can get it working there that would be better.




              • Re: FRDM-KL25Z OpenSDA - rollback



                I got as far as you did.


                Got the board (with 1.01 installed). Saw that the CDC Mass Storage came up on my Ubuntu 12.04 development environment.

                Thought great! That was easy.


                Ok. Next step will be to upgrade the OpenSDA application, as recommended by their Quickstart documents.


                Then, I found the bootloader didn't work. So borrowed a Windows to see if that would work.

                It did, of course, so I upgraded the OpenSDA application to the 1.05 version, as recommended.


                Back on my development environment, OpenSDA application didn't mount any more.

                I don't have the old version of the OpenSDA 1.01, so I couldn't roll back.

                I raised a case on Freescale customer service about 10 days ago (that no one's even looked at yet).


                So I thought I'd try here on the forum to see if the experience was common with others.


                Anyway, if Freescale are not prepared to work this out, so that they have an open development environment (Eclipse on Linux), then I've got very little interest in investing time into their system. There are nice alternatives.


                I've got some Teensy 3.0 boards on the way, with Cortex-M4.



                Regards, Phillip

              • Re: FRDM-KL25Z OpenSDA - rollback

                Thanks to Erich, I've got some pre-production version of the OpenSDA application, and I have tested them with Ubuntu 12.04 AMD64.

                I've got their v28 Linux drivers installed too, as this was the question asked by Freescale support.


                Following testing, I can report that while the earlier versions do get recognised and allow the OpenSDA "drive" to be read by the OS, it seems that they cannot be written to as a "drive" by the OS. Changing the pre-compiled examples provided in Quickstart package doesn't seem to change any result (red blinky, not red. green blinky, not green.) although the new file appears to have been written into the directory.


                This is now in my too-hard basket, and I'll check back to see how they're going with a new Linux AMD64 version sometime soon.

                • Re: FRDM-KL25Z OpenSDA - rollback

                  Hi, Philip,


                  I've attached the 1.01 version of the MSD Flash Programmer.



                  • Re: FRDM-KL25Z OpenSDA - rollback

                    Same problem here - pretty useless having a "freedom" development board when you can't develop for it from a free OS..

                    • Re: FRDM-KL25Z OpenSDA - rollback

                      Where can the updates be found, Please?


                      Thank you.

                        • Re: FRDM-KL25Z OpenSDA - rollback

                          I'm also in search of linux support.

                            • Re: FRDM-KL25Z OpenSDA - rollback

                              Yeah, I'm still waiting too, would be great if I could actually use my 2 "freedom" dev boards..

                                • Re: FRDM-KL25Z OpenSDA - rollback

                                  Hi, All,


                                  The OpenSDA MSD Flash Programmer application has been updated and now supports Linux!


                                  Available here: http://www.pemicro.com/opensda/


                                  Unfortunately, you will still have to use a Windows machine to put the board into bootloader mode and drag in the new MSD App.  The Bootloader suffered the same issue as the MSD App.  For now, the only update option is to use your existing Bootloader.


                                  MSD Flash Programmer Release Notes:

                                  MSD Version 1.07


                                    - Improved initial communications to the target MCU to address cases where

                                      the reset line is disabled or the low power boot mode is used. This may

                                      previously have resulted in inability to reprogram the target MCU.


                                  MSD Version 1.06


                                    - Support added for Linux Operating System (Tested on Ubuntu)


                                  MSD Version 1.05

                                    - Reset and Run after programming was fixed for secure devices

                                    - If an illegal file was dropped to it, the LEDs wouldn't blink an error, device would stop working.

                                    - Protected against programming the FSEC in a way which permanently secures the device




                            • Re: FRDM-KL25Z OpenSDA - rollback

                              From the FWIW department, I have CodeWarrior 10.3 running in Win XP on VirtualBox in Ubuntu 12.04.


                              After a week of troubleshooting and getting everything configured correctly, the Freedom board works as expected, including Bootloading both the debug and MSD programs from the Windows virtual machine.


                              The issue I am having, however, is the 8-12 second delay during "Step Over" commands in debug mode. This means it takes nearly a minute to step through a 5 line program. (This makes programming nearly painful, and excruciating if ones program is more complicated than 3 IO commands.)


                              I don't know where the problem lies; whether it be in the way I have the MCU timing set, or the version of the debug program in the Bootloader, or the way I have the VirtualBox configured with either Win XP or my Ubuntu system, or because my computer is simply too slow (3 GHz & 4 G RAM.)


                              (Also FWIW, I don't know if CodeWarrior can run in Windows in VirtualBox on Ubuntu with anything less than 4 G RAM. Two G is needed for the Win virtual machine and CW and the rest is used by VirtualBox and Ubuntu.)


                              If there is any interest, I can list what I think I did to make it all work together. (Honestly I am not entirely sure, but except for the delay, I don't "think" I am having any issues.)


                              Or, if figuring this out is common knowledge, can someone direct me to how I might solve the delay issue, please?


                              Thank you.

                              • Re: FRDM-KL25Z OpenSDA - rollback

                                Recently 1.07 OpenSDA has been released. I (and others) have tested this and as of Ubuntu 12.04 LTS AMD64, with provided v28 Linux drivers, precompiled binaries (.srec) can be written to the board. Great.


                                The fact that the Bootloader doesn't support Linux can only be resolved by the factory, according to Freescale support, so there remains no option but to use Windows machines to swap from loading to debugging OpenSDA applications. Not great. Actually bad. But enough to close this issue.

                                  • Re: FRDM-KL25Z OpenSDA - rollback

                                    No, they could tell us what order of accesses to the virtual FAT filesystem is expected and seen with on windows, or what the exact bug was that was fixed.


                                    This is a perfect example of why using a mass storage device + filesystem interface to something that is not a filesystem on a mass storage device is a very, very bad idea.




                                    1) What was the exact change made to the MSD firmware to support that one particular version of ubuntu? (note: I expect it is brittle enough that there is no garuntee it will work in future revisions of any thing that affects the order blocks are accessed in)

                                    2) Why isn't the source code for the OpenSDA applications publicly avaliable?

                                    3) What is the debug OpenSDA application's protocol?

                                    4) Don't use a fs (filesystem) on msd (mass storage device) interface _ever_ again. Plain msd where I simply write the raw fw onto what appears to be a block device is perfectly fine. Trying to pretend you have a filesystem is asking for trouble.

                                  • Re: FRDM-KL25Z OpenSDA - rollback



                                    I am having what seems to be a similar problem. I am running Windows XP. I installed the PE drivers and updated the drivers for the OpenSDA - CDC serial port, as the quick start guide explains. I can connect the board both as the flash progammer and as the bootloader, but I can't seem to load files in either of them. The explorer window shows the new *.srec or *.sda files but nothing changes on the board.


                                    I see this post is about this happening on Linux but did it happen to anybody running Windows? Was a solution found?



                                    • Re: FRDM-KL25Z OpenSDA - rollback

                                      All these posts are 1/2 year old.  We just bought 2 "freedom" boards to be used in a (hopefully) larger education initiative.


                                      Nobody here uses anything but Ubuntu (13.04 and 12.04, 64bit) - there is NO windows available and it it not feasible to require customers to have windows to get the "freedom" (yeah right) board flashed.


                                      Has there been ANY solution to getting everything running from pure Linux (without windows)?

                                      also - is there any source available to get it flashed/handled from RaspberryPi (or other devices)?


                                      If not:


                                      1. Please remove "freedom" from the name

                                      2. Please give us a refund


                                      If yes:


                                      Thank you very much for fixing it - please provide a link!


                                      (I think I will repost this on the freescale community board)

                                      • Re: FRDM-KL25Z OpenSDA - rollback

                                        Has anyone gotten a FRDM-K20D50M to work on linux?


                                        My linux box doesn't seem to recognize it at all.


                                        At least with the KL25z it would recognize it as a usb disk drive.




                                        • Re: FRDM-KL25Z OpenSDA - rollback

                                          Dear Freescale FRDM users


                                          I have read your latest posts describing your problems on Linux and Mac OS X to change the OpenSDA modes of your Freescale Freedom boards.

                                          Our team is currently working actively to resolve this issue.

                                          I will keep you informed as soon as I will receive updates.


                                          Concerning the compilers available on Linux or Mac compatible with our FRDM boards :


                                          - Code_Red Red Suite : Version 5 is available for Windows, Linux and Mac OS X hosts

                                             Free 64k development when used with Freescale FRDM boards, not subject to the 60-day evaluation period



                                          - MBed : compatible with Windows, Linux and Mac OS X hosts

                                             According to user comment, your board must have updated to the latest firmware 1.08 (might require a Windows computer)

                                             Free online compiler



                                          - Rowley Crossworks : Version 2.3.1 is available for Windows, Mac OS X and Linux (x86/x64)

                                             30-day evaluation version then it costs 150usd for a Personal and 300usd for an Educational licence



                                          - GNU GCC toolchain from ARM : Version 4.7 is available for Windows, Mac OS X and Linux

                                              Free GNU toolchain with a GCC source branch for Embedded ARM Processors maintained by ARM



                                          Hoping those information will be helpful

                                            • Re: FRDM-KL25Z OpenSDA - rollback

                                              Dear Phillip,


                                              thank you for the options - however, it's not the development environments that are the problem - it's getting a board fresh from the factory working under linux.  After upgrading the bootloader and OpenSDA firmware, the board seems to mount fine under ubuntu 12.04 and 13.04 (at least).


                                              As it's probably not a feasible solution for you to recall all boards and get them flashed, I suggest that you make a one-off dedicated application (console only) to bootstrap the board under linux, using the knowledge you have of how the faulty software behaves (the one that is in the boards in stock with farnell and others).


                                              Please make the source available so we don't have to wait for you to build the app for different platforms.  There shouldn't be anything secret in it - as it would only compensate for the bugs present in older firmware.


                                              This way, we (all the linux users) have a way to move forward without Windows.





                                              PS - personally, I prefer the bare metal solution from here:  https://github.com/payne92/bare-metal-arm 

                                            • Re: FRDM-KL25Z OpenSDA - rollback

                                              I met some failures trying to update the OpenSDA of an old FRDM-KL25Z prototyping board (could drag and drop the MSD.SDA file but when I repluged the board it reappeared as BOOTLOADER drive) ...

                                              ... and MSD mode worked with a previous SDA file, may be you could test this trick to solve your issue under Linux ?

                                              File MSD_FRDM-KL25Z_v006B.SDA has been attached to this message

                                              Please keep us updated about your evaluations.