23 Replies Latest reply on Apr 26, 2018 1:19 AM by davinder

    Ubuntu 14.04

    e_b_123

      How can I install an the actual Ubuntu 14.04 or at least how can i fix the reboot problem at ubuntu 12.04.

      Has anybody a finished image available for download, in order to use with the riotboard.?

        • Re: Ubuntu 14.04

          Perhaps post details of your reboot problem and see if someone can help?

           

          The only images that are currently available (here) are the Android and 12.04.  You may be able to install the 12.04 and then upgrade it all the way to 14.04, but I don't know if that would be successful or not.

          If the problem you're having is related to the kernel then it's unlikely an upgrade like this would help anyway as you'll need a specific kernel for this board and there likely isn't one other than the original one in the 12.04 image at this point.

          • Re: Ubuntu 14.04
            radiatortwo

            Only alternative right now is compiling the Kernel yourself.

            There is a branch of the original Kernel in which the reboot error is corrected.

             

            I described here how to compile the Kernel.

            Re: Linux : Where is UART's

             

            You then just have to replace the Kernel image file when flashing Ubuntu.

              • Re: Ubuntu 14.04
                e_b_123

                Hallo Mr. Römer sadly copy and paste didn't work at all.

                I always receive following error

                linaro@linaro-ubuntu-desktop:~/linux-imx$ sudo make ARCH=arm CROS_COMPILE=arm-linux-gnueabihf- uImage

                make: arm-fsl-linux-gnueabi-gcc: Command not found

                scripts/kconfig/conf --silentoldconfig Kconfig

                make: arm-fsl-linux-gnueabi-gcc: Command not found

                  CHK     include/linux/version.h

                  CHK     include/generated/utsrelease.h

                make[1]: `include/generated/mach-types.h' is up to date.

                  CC      kernel/bounds.s

                /bin/sh: 1: arm-fsl-linux-gnueabi-gcc: not found

                make[1]: *** [kernel/bounds.s] Error 127

                make: *** [prepare0] Error 2

                linaro@linaro-ubuntu-desktop:~/linux-imx$

                 

                 

                I tried to do i tby manual and replaced u-boot and linux to embest_imx_3.0.35_4.1.0. and also downloaded the compiler from toochain.

                Make u-boot worked fine, but creating kernel image delivered still the same error.

                I tried on ubuntu 11. now on 12.11 but still the same problem.

                  • Re: Ubuntu 14.04
                    radiatortwo

                    I have a typo in the text it´s not "CROS_COMPILE=..." it´s "CROSS_COMPILE=...".

                    Sorry for that.

                    I´ll correct it in that post.

                      • Re: Ubuntu 14.04
                        e_b_123

                        Yes I've seen.

                        But this didn't solve.

                        May you could dd your RIoTboard, so I'd be able to place it on mine? or to replace the existing Linux and burn with the mergetool.

                        I am gonna to use it in commercial way. Have already running 10 Pi's successfully with gsm and RS485 transmission since a year (a little workaround with GPIO, reboot..) and they still work.

                        But want to get more stable, for example without sd card. But actually it's sad to provide an old version on the official website.,

                        which can't once reboot or shutdown.

                        So please hurry up:). RioTBoardTeam.

                         

                        P.S in the Usermanual is described make mx6solo_riot_config,

                        but the boards name has been changed. I just not remember how. Pls.correct.

                          • Re: Ubuntu 14.04
                            radiatortwo

                            If you can wait some more:
                            Selsinork is going to post a description on how to compile the newest mainline kernel.

                            What I described to compile is a rather old Kernel 3.0.35.

                            He already posted the description of compiling and using the mainline u-boot yesterday.

                             

                            I will then also compile and test the new Kernel. I could also provide some space for an image on my server.

                            I can´t provide an image myself. Just because it would take mo too damn long to upload it...

                            I have a really slow connection.

                            If someone wants to upload it I could give a ftp account for that.

                             

                            What I can do is to provide the Kernel Image file itself. I made no changes in the kernel code and I only tested it with a minimal debian rootfs so far.

                            But it should work with an Ubuntu rootfs I think.

                             

                            I can upload it as soon as I´m back from work, because it´s on my notebook and I don´t have it with me right now. This will take a few hours from now.

                              • Re: Re: Ubuntu 14.04
                                radiatortwo

                                Here is the Kernel Image in which the reboot should be fixed.
                                Just replace your old image with this one.

                                 

                                Like I said.

                                Only tested with Debian rootfs.

                                  • Re: Ubuntu 14.04
                                    e_b_123

                                    Hallo Herr Römlich,

                                    i replaced the file in the boot directory?

                                    uname -a shows

                                    Linux linaro-ubuntu-desktop 3.0.35-02871-ga35ffe3 #1 SMP PREEMPT Wed Oct 30 15:27:47 CST 2013 armv7l armv7l armv7l GNU/Linux

                                     

                                    is this now the updated version?

                                    Reboot still don't work.

                                      • Re: Re: Ubuntu 14.04

                                        It appears that Ottos working version is Linux-3.0.35-03023-ga0660f4

                                         

                                        Unfortunately, the file in the boot directory is never used.

                                        Assuming you're using the MFG_Tool, you'd need to replace the uimage in the correct subdirectory and reflash completely. (I don't have a windows machine, so really can't help with MFG_Tool)

                                         

                                        The reason it doesn't use the file in the boot directory can be found in the embedded script in u-boot which does this:

                                         

                                        bootdelay=3
                                        baudrate=115200
                                        ipaddr=192.168.1.103
                                        serverip=192.168.1.101
                                        netmask=255.255.255.0
                                        loadaddr=0x10800000
                                        rd_loadaddr=(0x10800000 + 0x300000)
                                        netdev=eth0
                                        ethprime=FEC0
                                        uboot=u-boot.bin
                                        kernel=uImage
                                        nfsroot=/opt/eldk/arm
                                        bootargs=console=ttymxc1,115200 nosmp video=mxcfb0:dev=hdmi,1280x720M@60,bpp=32 video=mxcfb1:off
                                        bootargs_nfs=setenv bootargs ${bootargs} root=/dev/nfs ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp
                                        bootcmd_net=run bootargs_nfs; tftpboot ${loadaddr} ${kernel}; bootm
                                        bootargs_mmc=setenv bootargs ${bootargs} root=/dev/mmcblk0p1 rootwait
                                        bootcmd_mmc=run bootargs_mmc; mmc dev 3; mmc read ${loadaddr} 0x800 0x2000; bootm
                                        bootcmd=run bootcmd_mmc

                                        the bit in bold is what loads the kernel and what it's doing is reading raw data directly from the mmc card starting at  1,048,576 bytes into the card, and a length of 4,194,304 bytes.

                                         

                                        Theoretically you could use dd to write the new uimage to the card in the correct location with something like:

                                        dd if=/boot/uImage of=/dev/mmcblk0 bs=1M seek=1

                                        However, I've never done that and can't guarantee it'll work, so you should be prepared to have to reflash using the MFG_Tool

                                         

                                        Note that there's an implicit problem with the u-boot setup that's being used - if you recompile a kernel and it ends up being bigger than 4MB then it won't be able to boot since u-boot will only partially load the kernel image.  I'm sure it's obvious why the way this is currently being done is a bad idea.  The worst part is that there's no need to do this.

                                          • Re: Ubuntu 14.04
                                            e_b_123

                                            well done. dd worked fine.

                                            Now reboot works.

                                            why no need to this? "The worst part is that there's no need to do this."

                                            Thank you.

                                              • Re: Ubuntu 14.04

                                                basically because u-boot can be setup in such a way that it will read the uImage from the file in /boot which eliminates an extra step and removes any confusion people have with the file being there.  From a technical point of view, reading the file from the filesystem also means the kernel can grow outside the current hard limit of 4MB without requiring any changes.

                                                 

                                                There are several typical u-boot usage patterns that are not necessary today, probably they still happen due to historic reasons.  I think it's good to drop those things that are not needed, it removes confusion and means nobody has to answer the 'why am I doing this unnecessary step?' type of question

                                                 

                                                Anyway, glad the dd command worked!

                                                • Re: Ubuntu 14.04
                                                  GregC

                                                  Eugen

                                                  As suggested by Otto, can you please share your stable Linux Ubuntu 12.04 image with the community ?

                                                  I have limited Linux experience and a slow computer but I would like test it on my RiOT board

                                                  Thanks in advance
                                                  Greg

                                                    • Re: Ubuntu 14.04
                                                      radiatortwo

                                                      You can use the official Linux download and just replace the kernel image in the files folder with mine.

                                                      Then flash it normally with mfgtools.

                                                       

                                                      You then have the same image as Eugen.

                                                      I don't think we need a whole system image for this.

                                                        • Re: Ubuntu 14.04

                                                          I agree, however mfgtool is a difficulty for a lot of people. Especially with the file in the current download needing renamed before it will work!

                                                           

                                                          In a lot of ways, I think it could be preferable to have simple img files that can be written to SD card, or a BBB style 'flasher' SD card image. Most people can handle win32diskimager by now as it's a common thing to use for most boards. RIoT being different by using mfgtool just adds an obstacle that could easily be removed..

                                                            • Re: Ubuntu 14.04
                                                              radiatortwo

                                                              Jup that´s right. But the only problem is you can´t flash an image directly on the internal eMMC. You´d have to manually copy the image from the sdcard onto the internal flash.

                                                              And I think a lot of people like me want to use the riotboard without extra sdcards.

                                                               

                                                              By the way. I tried putting the board into bootloader mode (the mode when MFGTool writes it´s data onto the board.) and then copy the image onto the flash drive you get then. But no luck. It just crashes.

                                                              • Re: Ubuntu 14.04
                                                                tushar panda

                                                                mfgtool is a difficulty for a lot of people

                                                                almost every MFG newbie hits the .txt to .xml roadblock, will notify vendor on this .

                                                                RIoT being different by using mfgtool just adds an obstacle that could easily be removed

                                                                thats a standard set by freescale , RIoT being a i.MX bundle just carries it,  however flashing images in linux is not at all a constraint for linux users.

                                                                  • Re: Ubuntu 14.04

                                                                    tushar panda wrote:

                                                                    almost every MFG newbie hits the .txt to .xml roadblock, will notify vendor on this .

                                                                    I saw you specifically added instructions for that to http://www.element14.com/community/docs/DOC-68063/l/riotboard-updating-os-images-in-windows-environment

                                                                    So we can point people to that now

                                                                     

                                                                    thats a standard set by freescale , RIoT being a i.MX bundle just carries it,  however flashing images in linux is not at all a constraint for linux users.

                                                                    Having several other i.MX6 based boards, I've never come across MFGTool before..  Have used the Linux imx_usb (https://github.com/boundarydevices/imx_usb_loader) variant to update u-boot in spi on both Sabre-Lite and MarS, but that's much more straightforward.

                                                                    Other SoC vendors have similar ideas - FEL mode on AllWinner devices for example, where it's a pain as well. Olimex IIRC were at one point charging an extra 10 euros for boards with NAND/Android specifically due to the difficulty of using it (think production line where you're testing lots of boards but can only do one board per Windows PC and it needs manual touch time as the windows util can't easily be automated).

                                                                     

                                                                    The BBB took the opposite route of using a bootable SD card that when booted automatically formats the eMMC and unpacks a tar.gz file onto it..  This is much the same as what mfgtool does, just less complex from the perspective of the users

                                                                     

                                                                    The method described in that blog post is good for linux users, but it's fairly clear from the people asking questions here that most of them are using windows.  The BBB method wins simply because it's useable, and almost identical in operation, whether you're using Mac/Windows/Linux.

                                                                • Re: Ubuntu 14.04
                                                                  tushar panda

                                                                  i guess greg is asking for ubuntu 12.04 which Eugen got working

                                            • Re: Ubuntu 14.04
                                              tushar panda

                                              how can i fix the reboot problem at ubuntu 12.04.

                                              can you share the boot logs or snapshot of the reboot issue you are facing.

                                               

                                              Has anybody a finished image available for download, in order to use with the riotboard.?

                                              there is a linaro ubuntu 11.10 image available, you can also build it from source

                                               

                                              after flashing (Linux) you can update it to get the supported armel packages.

                                              • Re: Ubuntu 14.04
                                                davinder

                                                Can anyone upload or give link to ubuntu 14.04 or latest image for Riotboard ?