12 Replies Latest reply on Sep 23, 2014 7:32 AM by funinalaska

    Arduino pro mini issues

    funinalaska

      OK, I have been using Arduino Uno, Mega and micro for a while now.

      All have USB on the board.

      I had ordered some Pro Mini boards a while ago and am just now finally getting to fool around with them.

      I got a FTDI232 board to program them with but I am having no luck.

      I have followed along with many tutorials online that use these boards with this adapter.

      I always get:

      avrdude: stk500_getsync(): not in sync: resp=0x00

      I have tried a couple different Pro Minis thinking maybe one I had was bad.

      I also did do the test with putting a jumper over RX and TX and seeing if I get mirroring in Serial monitor and I do.

      I have checked the settings in the com port on my system settings and it seems to be set as the tutorial say.

      Anyone have any thoughts what could be my issue?

        • Re: Arduino pro mini issues
          jw0752

          Hi Andrew - I had exactly the same problem and the same error message. I accidently had selected "Mini"ntead of "Pro Mini" when I selected the board in the Tool menu of the Arduino IDE. Check that out and try it again.

          John

          • Re: Arduino pro mini issues
            jw0752

            Hi Andrew - I checked my notes and here are a couple ideas. First of all, many of the Mini Pros come loaded with "blink" If you hook up power and the LED blinks you will know that the factory was able to load a program and the unit is working. Here is a link to the connections between the Mini Pro and the FTDI board. Check out the comment section for insights.

            https://www.sparkfun.com/products/9716

            When I hooked mine up I put a  0.1 uF cap in the line from DTR to the Reset on the Pro Mini. This worked for me on my setup.

            Once again good luck.

            John

            1 of 1 people found this helpful
            • Re: Arduino pro mini issues
              albertk836

              I had the same problem. I bought several pro mini(s) and a usb adapter, not knowing they are not all alike. The USB adapter I got does not have the reset electronics as part of it. To program the pro mini I must press an hold the reset button on the mini and  then send the file to the mini. As soon as I see the message about sending data to the board, release the reset button.

               

              GIve that a try

              • Re: Arduino pro mini issues
                bobcroft

                Hi Andrew,

                                    I have several Pro Minis and they program without a problem.  One thing I cam across was that the pins on the clone versions are the opposite way round to the 'official' board.  I use a variety of programmers but perhaps the easiest is the Visiport 2 available from Tindie in the USA.  I got one sent to the UK with no problems.  It has some really neat features like dual voltage programming and selectable reset lines.  The Visiport 2 does NOT connect to a clone version of the Pro Mini in the same way that is shown on the Visiport website as you have to turn it around to suit the reversed pin layout, however it is a good programming device.  I have no connection to Visiport.

                I also use a CP2102 USB to serial converter but you need to ensure you use the correct driver.  I never use the reset button when programming.  The CP2102 module I have has most of the RS232 signals broken out so you can select which line to connect to the Pro Mini reset pin.

                Please post a reply if you want me to list the pins I use on each device.

                I hope that helps.

                • Re: Arduino pro mini issues
                  mcb1

                  Andrew

                  It looks like you have checked quite a few things.

                  What voltage are your Mini's since there are 5v and 3v3 versions.

                   

                  The link John has linked to has some VERY good comments, regarding incorrect silkscreen (wrong voltage) and broken tracks.  

                   

                  You should be able to connect your FTDI directly to another Arduino, and program that, which would tend to prove the board you brought has the bootloader installed.

                   

                  Mark

                  • Re: Arduino pro mini issues
                    funinalaska

                    OK, I have tried a bunch of things.

                    I have tried checking all the connections.

                    I have tried holding the reset button till the sketch is finished uploading.

                    The only things I have not tried are adding the cap and resistor on the reset pin.

                     

                    I did do one more thing to troubleshoot.

                    I hooked it up to my Uno.

                    I only hooked up:

                    TX->RX

                    RX->TX

                    5V->5V

                    GND->GND

                    It worked,

                    I was able to upload a sketch to my Uno by pressing the reset button as soon as it said uploading.

                     

                    This tells me my FTDI works just fine...

                    This is telling me either I got Pro Minis without bootloader or I have a batch of bad boards.

                    I am hoping not the latter.

                     

                    I am inserting images of my Pro Mini and my FTDI (sorry they are crappy they were taken with my phone and it sucks at Macro)

                     

                    How do I tell if the Pro Minis have the bootloader burned on them?

                    How do I burn it if they do not?

                     

                     

                    image01.jpeg

                    The FTDI labels are difficult to see so in the orientation in the pic from to to bottom

                    DTR

                    RX

                    TX

                    VCC

                    CTS

                    GND

                    image02.jpeg

                    and yes, my Pro Mini is only printed on the back, which is really annoying once you have headers soldered on to it.

                    image03.jpeg

                    • Re: Arduino pro mini issues
                      funinalaska

                      Ok, so for an update. Once I burned the bootloader on theis board as described here:

                      http://forum.arduino.cc/index.php?topic=217246.0

                      now my pro mini accepts upload with no problem simply by connecting the FTDI to it so DTR pins line up.

                      Now I have 5 more boards to play with