8 Replies Latest reply on Jan 4, 2017 7:53 AM by monkeyman_stones

    GIZMO 2 no sound (Linux)

    darkcloud

      I get no sound on Linux Ubuntu 14.04 when plugging in a small speaker from the standard audio jack. But some noise is heard.

      Also, when using a program using OpenAL for audio I get this error:

      PrzxfRS.jpg

      Thats all the info I can give. No error messages from the OS. Just no sound. Please tell me what else I can provide as info.

       

       

       

      T

        • Re: GIZMO 2 no sound (Linux)
          balearicdynamics

          Welcome to the club!

           

          I am coming crazy by days on Gizmo2 to install OS and other stuff. Frankly I have not yet explored in depth the audio out but if you have a HDMI out put I suggest to try to see if the HDMI Audio out works. In this case maybe that it is a wrong output channel settings. The other thing I suggest if you haven not yet done it, is to install VLC as it gives many information on how the audio software is responding to the hardware of the board and you can make a lot of tests setting different parameters.

           

          In few time I will be back on a running Ubuntu version of the Ubuntu operating system and can make some test together with you.

           

          Enrico

            • Re: GIZMO 2 no sound (Linux)
              darkcloud

              I have the Gizmo connected to my TV via HDMI at the moment.

              I will try what you suggested.

              What do you mean by "output channel settings"? Where is that? I'm not very familiar with Linux.

                • Re: GIZMO 2 no sound (Linux)
                  balearicdynamics

                  Supposing you are using Ubuntu or Debian (until now these was the two better Linux I saw working on the Gizmo2) your audio will work with Alsa, where the audio out channel will work on several channels, the integrated audio output with the HDMI cable or the on-board audio processor sending and received audio signals through the jacks. With VLC you can configure the audio parameters as well as Alsa directly from the system configuration (all graphic user interfaces so I suppose these are better for you than the command line), selecting where the audio out should be directed.

                   

                  Enrico

                    • Re: GIZMO 2 no sound (Linux)
                      darkcloud

                      I know you can choose the audio and video output to use for VLC specifically, doesnt seem like it changes anything for other programs.

                        • Re: GIZMO 2 no sound (Linux)
                          balearicdynamics

                          Sorry but let me ask you a question. What version of raspbian Linux did you installed? The standard version or the one with the Realtime Kernel specific for the audio card ?

                           

                          Enrico

                            • Re: GIZMO 2 no sound (Linux)
                              darkcloud

                              Raspbian? It's a standard Ubuntu 14.04 Desktop on Gizmo.

                                • Re: GIZMO 2 no sound (Linux)
                                  balearicdynamics

                                  Sorry I wrote raspbian

                                   

                                  I have not yet done tests in dept with audio only, but I saw that to get the better performances some users adopt the real-time kernel version of Ubuntu. AFAIK, there is not an RT version of the 14.04. This was only just a question about the operating system. And everywhere it is mentioned Ubuntu 14.04 LT as the best solution for the Gizmo2. When I installed it, during the installation process the OS asks for some non-open components related to the audio processor that should be installed. It is asked just because are not strictly open source so they note it. Excluding this detail I can't imagine what went wrong with your machine.In this moment I am using a version of debian but I have also a boot SSD disk with Ubuntu 14.04. If you can wait a while I can make specific tests then I will forward the working configuration (or report the same issue )

                                   

                                  Enrico

                      • Re: GIZMO 2 no sound (Linux)
                        monkeyman_stones

                        You need to change your alsa-base.conf file in /etc/modprobe.d/ to the device number (1, 2, 3, etc) your HDMI is/uses. You can find them from the terminal with command aplay -l which will define what number each sound device is. You can then change alsa-base.conf to target that device.  You can also go GUI and enter "alsamixergui" from the terminal, then click "File" (top left of window), then "Change Device" then select the HDMI option presented.  In /etc/modprobe.d/alsa-base.conf change everything (near the bottom of the page) from "options snd-(device type or name) index=-n" (where "n" is a number other than your HDMI) to the device id # of your HDMI (HDMI is often 0 or 3).

                        Here is an exceptional resource and while it was created for/by Arch Linux, but it works for nearly all distros:  https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture

                        In addition, here is another excellent Arch Linux page defining the common codecs which are for all distro's (which you will need to install to have all sound file types play properly or at all): https://wiki.archlinux.org/index.php/codecs