0 Replies Latest reply on Apr 21, 2017 9:12 AM by jfz

    Wolfson Audio Card can't record from linein with darkice and playback on speaker with squeezelite

    jfz

      Hello,

       

      I'm having an issue with my Wolfson Audio card using this Ragnar's image on my Rpi https://www.element14.com/community/message/106822/l/re-wolfson-modified-noobs-raspbian-zipped-img-cannot-unzip-new-down…

      using darkice localy on the Pi using this post https://www.element14.com/community/external-link.jspa?url=http%3A%2F%2Fwww.t3node.com%2Fblog%2Flive-streaming-mp3-audio… 

      And icecast on my ubuntu server.

      Casting work great thanks to all this people !

      By the way I still have an issue wanting using the same Pi to play the stream on the Wolfson speakers.

      I have squeezelite on the Pi and the LMS on my ubuntu server. Both communicating well with each other.

       

      when I use on my Pi

      mplayer http://myipserver:8000/mylive
      

      while he's streaming, it works great too on the speakers.

       

      Equal when I m using squeezelite with some music on the LMS and without streaming with darkice.

       

      But when I play the stream from squeezelite, only annoying noises are going out the speakers.

      The reason I prefer to use squeezelite is to be able to sync the playing stream with my others squeezelite players (Rpi too)

       

      I m using Ragnar's darkice.cfg too

      lauching squeezelite like this :

      sudo /usr/bin/squeezelite-armv6hf -o sysdefault:CARD=sndrpiwsp
      

       

      here are the command someone could ask me to understand what is happening :

      aplay -l
      **** Liste des Périphériques Matériels PLAYBACK ****
      carte 0: sndrpiwsp [snd_rpi_wsp], périphérique 0: WM5102 AiFi wm5102-aif1-0 []
        Sous-périphériques: 1/1
        Sous-périphérique #0: subdevice #0
      carte 1: ALSA [bcm2835 ALSA], périphérique 0: bcm2835 ALSA [bcm2835 ALSA]
        Sous-périphériques: 7/8
        Sous-périphérique #0: subdevice #0
        Sous-périphérique #1: subdevice #1
        Sous-périphérique #2: subdevice #2
        Sous-périphérique #3: subdevice #3
        Sous-périphérique #4: subdevice #4
        Sous-périphérique #5: subdevice #5
        Sous-périphérique #6: subdevice #6
        Sous-périphérique #7: subdevice #7
      

       

      arecord -l
      **** Liste des Périphériques Matériels CAPTURE ****
      carte 0: sndrpiwsp [snd_rpi_wsp], périphérique 0: WM5102 AiFi wm5102-aif1-0 []
        Sous-périphériques: 1/1
        Sous-périphérique #0: subdevice #0
      

       

      I'm using basic scripts :

      Playback_to_Speakers.sh

      Record_from_lineIn.sh

       

      Notice that launching squeezelite with -o sysdefault:CARD=ALSA works too but sound goes on headset output

       

      Is anyone have an idea about what is happening ?

       

      Thanks