19 Replies Latest reply on Jul 20, 2017 5:25 AM by Christopher Stanton

    Pi Desktop very disappointing

    masterplumber

      I had high hopes for this but it doesn't appear to be very good.  The build quality seems fine and it looks good - just a shame it doesn't actually work.  Or doesn't actually work yet.

       

      The instructions aren't up to much either.

       

      I have a perfectly working Raspberry Pi 3 that boots up into Raspbian (latest version 2017-04-10).  I downloaded the image this morning and flashed it to a Class 10 16GB card using etcher.  Everything works fine.

       

      I then built the desktop using the enclosed instructions and finally snapping the lid onto the case.  Pressed the button and I got a nice blue light - nothing else.

       

      Had to disassemble the thing to see what the problem was.

       

      Dismantled everything and booted up the Pi without the Pi Desktop Board.  All worked fine.  Switched off.  Attached the board (didn't put it in the case this time - lesson learned) along with the usual mouse, kb, monitor.  Pressed the button.  Blue light and nothing.   Noticed that the light on the Pi was solid red - no sign of the usual flickering green light on the Pi indicating activity.

       

      Held in the button on the desktop board until the blue light went off (5 seconds).  Removed the power supply (it's the R Pi official one) and the SD card.  Reinserted the card.  Reinserted the power supply.  Pressed the button.  Voila.  Blue light AND booted into Pixel.  Pressed the button to power down.  Worked fine.  Pressed the button to power up.  Worked fine.  Rebooted into Pixel.

       

      So switched everything off.  Dismantled everything (I bet you know where this is going...) and started from scratch.  Fitted everything into the case but didn't fit the lid on.  Pressed the button.  Blue light came on.  Nada.  Back with the solid red light.

       

      Took everything apart again to check and exactly the same thing happened.  Tried again with a fresh install of Raspbian on a different SD card - exactly the same problem.  

       

      Completely unusable in its current state.  The thing will work sometimes without the case but it requires a power down and the SD card to be reinserted.  Won't work in the case and there's no way to get the card out to try reinserting it without dismantling the whole thing.

       

      Looking through a couple of posts on here I see that others are complaining of the same thing ie thing wont boot and light on Pi staying red.  So have I got a duff board or has this thing not been tested properly or is it just a waste of time and money.  Not impressed.

        • Re: Pi Desktop very disappointing
          shabaz

          Hi Roberto,

           

          There is some workflow issue possibly. Are you powering off without a controlled shutdown?

          You mention "the thing will work sometimes without the case". I think to troubleshoot successfully, get to the stage where the Pi 3 will work consistently _always_, without the case. No point inserting it into the case if you can't get to that point.

           

          If your Pi isn't working consistently as a standalone Pi 3, then you need to resolve this. Please confirm how you power down the device. You may well be doing it correctly, but some people don't, hence the reason for the question to confirm.

          2 of 2 people found this helpful
            • Re: Pi Desktop very disappointing
              masterplumber

              Hi Shabaz

               

              Thanks for the advice.  I have carried out more testing today as follows:

               

              All of this is with the Pi Desktop hat connected but with no case ie just the hat connected to the GPIO pins and the USB connector plugged into the PI and hat respectively.

               

              Connect everything up and press the button.  Pi boots up ok and logs in automatically.  Good

              Press button for 2 seconds.  Powers down on and all lights go off.

              Press button again and Pi boots up ok and logs in automatically.

              Press button for 2 seconds.  Powers down and all lights go off

               

              Repeated these steps a few times just to make sure.

               

              At this point I'm thinking it's working.

               

              Now power down using the button.  All lights are off.   Remove power supply and reinsert.

              Press button.  Blue light comes on, red light comes on on Pi.  No green light.  Pi doesn't boot.

              Press and hold button for 5 seconds.  All lights go off.

              Press button.  Blue light comes on, red light comes on on Pi.  No green light.  Pi doesn't boot.

               

              Repeated these steps a few times just to make sure.

               

              Pi won't boot.

               

              Removed SD card and reinserted.  Power supply is still attached.

               

              Press button.  Pi boots up and logs in automatically.  Power cycle a couple of times using button to power up and down.  All seems ok.

               

              Power down and remove power supply.  Reinsert power supply and press button.  We're back to square one.  Pi won't boot.

               

              Power down again and remove/reinsert SD card.

               

              Press button.  Pi boots ok.

               

              I then repeated the above steps with a different power supply.  Same result.

               

              So what I see is that I can get everything working but whenever I remove the power supply it won't boot unless I also remove and reinsert the SD card.  If the PI and Hat are in the case then that's not possible without dismantling it and to get it back into the case afterwards I need to remove the power supply so it won't work after that anyway.

               

              So I can recreate the 'problem' fairly easily.

               

              Whenever the power supply is removed from the system, it won't reboot unless the SD card is reinserted.  Which kind of defeats the purpose.

               

              Any further suggestion would be welcome.

               

              Edit to add - without the Pi Desktop hat the Pi works fine.  Boots up without any problems using a variety of different SD cards and power supplies so the issue lies with the hat.

                • Re: Pi Desktop very disappointing
                  shabaz

                  Hi Roberto,

                   

                  Removing a microSD card from a powered-off board and re-inserting it will make no difference. There could be a possibility that the socket or microSD card is physically making poor contact, but there are other tests of course for that (e.g. leave the Pi running for a long time; if there was a poor contact issue, then the Pi would eventually cease running correctly).

                   

                  I don't know how the Pi Desktop is supposed to work, but it really sounds a bad idea to press a button to power off unless it invokes a controlled shutdown. A computer needs a controlled shutdown of its operating system usually. That is done using the keyboard/mouse, navigating to the powerdown menu for example. It sounds like you're corrupting the microSD card contents, and eventually on startup Linux repairs it enough to reboot.

                   

                  In summary, it is likely that if you perform a controlled shutdown of the operating system, all will be well.

                  2 of 2 people found this helpful
                    • Re: Pi Desktop very disappointing
                      masterplumber

                      Hi Shabaz

                       

                      The button on the Pi Desktop is supposed to do that very thing ie a controlled shutdown.  This is handled by routines within the pidesktop deb file that is downloaded as part of the installation process (I say this on the back of a post from another contributor who has looked into the code within that deb file).

                       

                      I have also tried the same using the shutdown command from the menu (both GUI and CLI) and it seems to be the same.  However, I will test properly later tonight and see if it makes a difference.

                       

                      Thanks for your assistance though

                        • Re: Pi Desktop very disappointing
                          masterplumber

                          Some more observations following additional testing.

                           

                          Firstly, an explanation of what the pi desktop is/does/is supposed to do to prevent any potential red herrings entering the discussion.  The pi desktop is an add-on board for the Pi.  It contains a battery-backed real time clock and a power button along with a case in which to house everything.  Once the add-on board has been installed, the original Pi power supply port is not available.  You must use the power supply port on the add-on board.  Plugging in the power supply using the port on the add-on board does not automatically boot the Pi.  Instead you must press a small button located on the add-on board (or via the large button on the case if you have installed everything into the case).  You can also use this same button to power down or to do a hard reset.

                           

                          For completeness, the add-on board also contains an mSATA connection supporting up to 1Tb.  This is delivered over USB and a connector is supplied to connect from a Pi traditional USB port to an add-on board micro USB port.  This works fine (I've tested it with a 64Gb mSATA card).  There is also an option to boot from the mSATA along with booting from an external USB flash drive.  I haven't even considered any of that yet as I can't get the basic machine to work

                           

                          My testing has shown that, for me, the only way to get the Pi to boot reliably with the add-on board attached is to insert the SD card while the power is attached.

                           

                          I have tested this by

                           

                          - simply removing the power while the system is up

                          - holding the power button down for 5 seconds (a hard reset)

                          - using shutdown from the CLI

                          - using shutdown from the Pi GUI menu

                          - removing the power supply after using the button on the add-on board to do a controlled shutdown

                           

                          In each instance, the only way to get the Pi to reboot successfully is to remove and reinsert the SD card while the power is attached.

                           

                          Once the Pi is up and running, it is possible to close it down and boot it up using the button on the add-on board.  This works fine - I simply have not found it possible to get the Pi up and running with everything in the case.  When the Pi and add-on board are in the case, the SD card slot is inaccessible so it is impossible to remove and reinsert it which - as my testing  has demonstrated - may get it to work.

                           

                          My conclusion is that either I have a defective board or the programming for the add-on board has not been tested properly ie the state of the relevant pins is not able to be ascertained reliably.  All in all, a pretty poor purchase and there seems to be no technical support to raise these issues

                            • Re: Pi Desktop very disappointing
                              uscdadnyc

                              Thx to RB and Shabaz, for this discussion on the Pi-desktop. Are there any Pics of the Assembled Product (w/ RPi inside)? Showing how much Clearance there is b/f putting the Top on. There was/is another e14Thread that had this Q, much like I am asking now. I was thinking of putting an Up-board SBC (Single Board Computer w/ Atom uProcessor) into the Pi-desktop. Instead of the Rpi. Is there enough Clearance to add a (if it exists) a USB3.0-interface (only) SSD? Of course I would use my Dremel Tool to cut access to the USB3.0 micro-B, then feed the 3.0 cable  back into the Pi-desktop Case. Right now I have both a RPiZW (Zero-Wireless) and an Up-board inside a Pi-TopCEED. Of course operating One Computer at a time though. The Pi-desktop looks pretty good . Appearance-wise. I wanted something to match the Decor of my Intel NUC5i7RYH Unit.

                              USCDADNYC (NY NY USA)

                    • Re: Pi Desktop very disappointing
                      Christopher Stanton

                      Hi masterplumber , sorry to hear you're having a few hiccups with this.

                       

                      What power supply are you using? What is its volt and amp rating?

                        • Re: Pi Desktop very disappointing
                          masterplumber

                          I now have a working system.

                           

                          It seems that the problem was the SD card.  Or rather the SD cards.  I have been using Sandisk 16Gb Class 10 microsd cards and they have been absolutely fine.  They boot up the Pi without any issues whatsoever.   However, they don't seem to work when the Pi Desktop is added to the mix (I tried more than one Sandisk card so it wasn't a one-off)

                           

                          Having exhausted all of my testing as above the only thing left was to try a different brand of SD card and this seems to have worked although I am perplexed as to why.

                           

                          Using a Samsung Class 10 16Gb I was able to get the Pi to boot up inside the case and also power down and up again using the Pi Desktop button.  It even works when the power supply is removed and reinserted.

                           

                          If I revert back to the Sandisk cards however, the problems with booting etc recur.

                           

                          If I get some time I may carry out some more extensive testing - just in case I have missed something along the line - but for now the situation is resolved.  Pi Desktop + Samsung card works.  Pi Desktop + Sandisk card doesn't work.

                           

                          Note that I can boot up the Pi on its own using either the Sandisk or the Samsung.  But it's only the Samsung that will work with the Pi Desktop

                           

                          Thanks to all for their advice and assistance

                        • Re: Pi Desktop very disappointing
                          dannyv1

                          Hi Guys,

                          This may or may not be a help: When using SD cards on my Arduinos I had similar working / not working problems until I used 'Adafruit's' "SDFormater" app and did a QUICK FORMAT
                          (NOT an Overwrite format). I double checked that it had to be a Quick format (for some reason).

                           

                          Since doing that, I have never had a problem with any card.

                           

                          Cheers!

                           

                          Danny

                          3 of 3 people found this helpful
                          • Re: Pi Desktop very disappointing
                            orthosie

                            If the real-time-clock battery is removable, try removing it and then rerun your experiment.

                             

                            From your description, you disconnected the power supply and then reconnecteded it but the system would not boot unless you removed the SSD card and reinserted it. Although you have removed the main power supply, the RTC battery is still present. If through some faulty design or software the RTC's power is not properly managed, it may be the source of the problem.

                             

                            A quick test would further narrow down the variables.

                             

                            Best regards

                            Orthosie

                            2 of 2 people found this helpful