6 Replies Latest reply on Sep 1, 2020 7:05 PM by compeoree

    SVN error


      I am using 2 svn repositories, one with Assembla.


      I amble to check out projects, but the files indicated that they are being refreshed and any time you click on 1 it throws a Version control error " Notifications are allowed on main thread only".


      I am on CS 1.4.1 build 99.


      Any Ideas, besides deleting the svn directory.

        • Re: SVN error

          Not used remote repositories only file based ones but never seen this error. Could the folder structure be corrupt, you could install TortoiseSVN and see what it makes of the local folder and remote repository.

          • Re: SVN error

            I'm wondering if anyone ever found a solution to this. I am seeing the same error in 1.5.1 build 13 running on Windows 10. I can view my repository through Tortoise SVN (I even tried VisualSVN with the same result), so the repositories are not corrupt. But if I enable SVN in the CircuitStudio system preferences, I get this error popping up every time I click on a file. Same result whether I use the internal SVN or external svn.exe.




            • Re: SVN error

              And I'm ungladly joining the line of people with this error message.


              Another thing that's happening right here, is that the internal CS SVN throws only error messages when I try to checkout a project. Tortoise SVN at least is able to check out correctly. But then the above mentioned error message keeps appearing "Notifications are allowed on main thread only".


              Did somebody manage to get this running?