0 Replies Latest reply on Oct 13, 2017 10:39 AM by antonmd

    Troubleshooting Official 7" Display

    antonmd

      Hello everyone!

       

      I purchased an official 7" display for an Rpi2 several months ago, and have used it with many projects, having no problems whatsoever.

       

      Then it suddenly stopped powering on. I had the Rpi2 and display in an enclosure that I had been using for over a week with the same reliability I had come to expect.

      With no warning or error messages of any kind, using Raspbian, like I had been doing, the pi worked, found by my network, allowed me to SSH when I tried, only, the display would not power on, there was no backlight, no icon indicators, absolutely nothing.

       

      Frustrated, I went to my local electronics store and purchased an Rpi3 and new official 7" touchscreen display. I brought these items home, plugged them in together the exact same way I always have, and on the Rpi3, same issue - no power, no visible attempt at trying.

       

      I went through all of the usual protocol - sudo update, upgrade, dist-upgrade, reboot - and still, no power.

       

      After two days of reading every blog, forum, and book I could find that referenced displays and troubleshooting, I found the documentation to be very limited.

       

      I thought, maybe, I picked one that just so happened to be non-functional out of the box, and I exchanged it at the store I got it from.

       

      Last night I followed the exact same procedure, and now I have a 3rd display that just won't work at all.

       

      I have burned new images on brand new, class 10, 16 and 32gb micro sd cards and properly formatted them following the precise instructions on raspberrypi.org. I tried using new installations of  Noobs, Raspbian, and Ubuntu Mate, and in no instance did the Rpi2 or Rpi3 auto-detect the display being attached like it used to do all of the time with no problems whatsoever.

       

      I absolutely am out of ideas. Out of 3 displays and 2 Rpi boards, using official power supplies, using only official operating systems, suddenly., this official touchscreen - a vital part of the projects I work on - just doesn't work in any way. Has anyone else had problems like this? Is there a change in the config file that prevents these displays from being used by default? 

       

      In the past it was plug-and-play with now extra configuration required, now I'm really stumped.