15 Replies Latest reply on Jan 8, 2018 12:44 PM by csiemer

    Did you guys even beta test this?

    naca6409

      I've been trying to get used to Circuit Studio after being trained on Altium, and I'm going to say straight off: This software is *extremely* disappointing.  No "Find Similar"?  Sure, remove the flex circuit functionality, but keep the basic productivity features!

       

      Anyways, my reason for creating an account and posting was this train-wreck:

       

      I'm using the software on a Surface Book 2.  Fresh install, both OS and CircuitStudio.  I haven't screwed with any display settings or anything.  It's as stock as things can get.


      However, for some reason, the "Cartesian Grid Editor" aka "Snap Grid" dialog in the PCBLib editor is not rendering correctly, making it impossible for me to adjust the values.

        • Re: Did you guys even beta test this?
          e14softwareuk

          Can you grab the bottom of the window with the mouse and resize the dialog?

          • Re: Did you guys even beta test this?
            csiemer

            What resolution are you currently running at? 

             

            Minimum resolution for CircuitStudio is currently 1280x1024 at 100% scaling

             

            So, if you are at 1024 or around there, and scaling is set higher than 100% within Windows, some dialogs can get a chop effect like you are seeing here.  If you are at or below 1024, and also at a higher scaling it could end up looking like your screenshot.

             

            If your maximum vertical resolution cannot reach 1024, you will have to run at 100% scaling for CircuitStudio, and some dialogs might still be difficult to see.  But in these cases, please let us know the resolution and scaling you are running at and if it is a dialog we can improve, we can submit a ticket for review.

             

            This table is pretty handy for mapping scaling to resolution for CircuitStudio, I hope it helps, but keep in mind that even at Maximum scaling for a resolution, on widescreen ratios I have still seen some minor dialog chopping so although it might say 250%, if you see a dialog chopped, try dropping to 200% and see if it improves.

            Scaling is changed within Windows 10 by accessing your Display Settings in the Scale and Layout section.

            Monitor Vertical Resolution (pixels)Maximum DPI Scaling Supported
            1024 to 1200100%
            1600125%
            1800200%
            2K and above250%
              • Re: Did you guys even beta test this?
                naca6409

                As I mentioned before, this is stock Windows 10 on a Surface Book 2.  I haven't changed any settings, but my current display settings are within the ranges your table specifies.  I also tried a second display (2560x1440 @ 100% scale) with no change.




                  • Re: Did you guys even beta test this?
                    csiemer

                    Hmm, should definitely look close to how I see mine, your settings are not too different than how I run.

                     

                    If you are not comfortable changing the registry, but are comfortable having a look, can you please go to the Registry key Peter referenced above and take a screenshot of the values?

                    HKEY_CURRENT_USER\Software\Altium\CircuitStudio {guid}\DesignExplorer\Forms\TGridEditorForm

                     

                    As a reference, here is how mine look for this particular form.

                     

                    I am curious if your values are somehow different, maybe an issue during install or something.  At minimum we can get a ticket submitted to make this dialog resizable, but my troubleshooting brain is curious as to the cause of this so hopefully we can get to the root of it

                      • Re: Did you guys even beta test this?
                        naca6409

                        Good idea.  I tried adjusting the height parameter to match yours and the behavior of the dialog was the same when I next invoked it.

                         

                         

                        Previously, the value was set to 240.

                          • Re: Did you guys even beta test this?
                            csiemer

                            Ok, one more thing to check settings wise.

                             

                            For the shortcut you use to open CircuitStudio, access the properties of this shortcut and then go to the Compatibility tab.  There is a section here for High DPI scaling.  Please take a screenshot of this so I can see how it is set.

                            Here are the regular settings I use for reference

                            I tried various options here to reproduce what you are seeing, but could not do it.  However, in changing these settings the dialog is modified.  So, it might be worth checking a few of the settings here to see if they either correct the issue, or at least kick that dialog into a readable/usable size.  To see changes with this, you will need to close and re-launch CircuitStudio from the updated shortcut properties.

                             

                            Also, just to be sure, check to see that you have all critical Windows updates installed.

                              • Re: Did you guys even beta test this?
                                naca6409

                                Here were my settings.  I tried mirroring yours and did not get any change in behavior.

                                My updates are current. 

                                  • Re: Did you guys even beta test this?
                                    csiemer

                                    I've been reading a bit about the Surface and Scaling issues, and they seem to be in a bit of a special category, especially when additional displays are plugged in.

                                     

                                    The workarounds I am seeing, seem to be quite involved, but we can give them a try.  Before we consider diving into attempting the workaround, try the following and let me know if it changes anything for you.

                                     

                                    Disconnect any additional displays, so only the Surface display is active, don't just disable them, but disconnect, no dock etc.

                                     

                                    Restart Windows with no additional displays attached

                                     

                                    Set display scaling to 100% -  at a high resolution icons and text will be real small, don't worry, the intent is not to leave it in this mode, just to see if this alters behavior. If 100% is not an option, please let me know.

                                     

                                    Restart Windows or Sign out and Sign in again so the scaling settings take effect everywhere.

                                     

                                    Launch CS and let me know if you notice a change in that dialog.

                                • Re: Did you guys even beta test this?
                                  e14softwareuk

                                  This grid dialog is used by the the PCB and PCBLIB editors, do you get the same dialog issue from both editors?