7 Replies Latest reply on Mar 26, 2018 9:00 AM by phased

    Move Part / Device to Other Layer (Bottom)

    phased

      Hello,

       

      I have been working on a PCB design which is intended to use an edge card connector. I first created a package / symbol / device which represented this connector as having copper (fingers) on both the top and bottom layers. However, when attempting to export the routing files to a manufacturing house, I got a failure message with errors such as: Your project doesn't contain a bottom copper file and Your project doesn't contain a bottom solder mask.

      So this made me realize that, even though I created the package to have copper on both Top and Bottom layers, the board layout kept both sets of copper on the Top layer.

       

      After this, I attempted to create a device which had only one set of fingers so I could put device on the Top layer and another on the Bottom layer. However, apparently Eagle will not allow me to put a device on the Bottom layer.

       

      Can anyone tell me if there is something special I need to do to accomplish this or if I am going about the process of adding edge connector fingers to a board incorrectly and how I may do it differently?

       

      Thank you very much in advance!

       

      Troy.

        • Re: Move Part / Device to Other Layer (Bottom)
          Autodesk Guest

          Am 22.03.2018 um 17:30 schrieb Troy Whipple:

          Hello,

           

          I have been working on a PCB design which is intended to use an edge card connector. I first created a package / symbol / device which represented this connector as having copper (fingers) on both the top and bottom layers. However, when attempting to export the routing files to a manufacturing house, I got a failure message with errors such as: Your project doesn't contain a bottom copper file and Your project doesn't contain a bottom solder mask.

          So this made me realize that, even though I created the package to have copper on both Top and Bottom layers, the board layout kept both sets of copper on the Top layer.

           

          After this, I attempted to create a device which had only one set of fingers so I could put device on the Top layer and another on the Bottom layer. However, apparently Eagle will not allow me to put a device on the Bottom layer.

           

          Can anyone tell me if there is something special I need to do to accomplish this or if I am going about the process of adding edge connector fingers to a board incorrectly and how I may do it differently?

           

          Thank you very much in advance!

           

          Troy.

           

          --

          To view any images and attachments in this post, visit:

          https://www.element14.com/community/message/237262

           

           

          Hi,

          use the "Mirror" command to put a device from

          top-layer to bottom-layer(or back)

          This will switch the layers of the device

          1,21,23,25,27,29,31,33,35,37,39,41 to

          2,22,24,26,28,30,32,34,36,38,40,42

           

          HTH

          Werner

           

          1 of 1 people found this helpful
          • Re: Move Part / Device to Other Layer (Bottom)
            Autodesk Guest

            Am 22.03.2018 um 17:30 schrieb Troy Whipple:

            Hello,

             

            I have been working on a PCB design which is intended to use an edge card connector. I first created a package / symbol / device which represented this connector as having copper (fingers) on both the top and bottom layers. However, when attempting to export the routing files to a manufacturing house, I got a failure message with errors such as: Your project doesn't contain a bottom copper file and Your project doesn't contain a bottom solder mask.

            So this made me realize that, even though I created the package to have copper on both Top and Bottom layers, the board layout kept both sets of copper on the Top layer.

             

            After this, I attempted to create a device which had only one set of fingers so I could put device on the Top layer and another on the Bottom layer. However, apparently Eagle will not allow me to put a device on the Bottom layer.

             

            Can anyone tell me if there is something special I need to do to accomplish this or if I am going about the process of adding edge connector fingers to a board incorrectly and how I may do it differently?

             

            Thank you very much in advance!

             

            Troy.

             

            --

            To view any images and attachments in this post, visit:

            https://www.element14.com/community/message/237262

             

             

            Hi,

            use the "Mirror" command to put a device from

            top-layer to bottom-layer(or back)

            This will switch the layers of the device

            1,21,23,25,27,29,31,33,35,37,39,41 to

            2,22,24,26,28,30,32,34,36,38,40,42

             

            HTH

            Werner

             

            • Re: Move Part / Device to Other Layer (Bottom)
              Autodesk Guest

              Am 22.03.2018 um 17:30 schrieb Troy Whipple:

              Hello,

               

              I have been working on a PCB design which is intended to use an edge card connector. I first created a package / symbol / device which represented this connector as having copper (fingers) on both the top and bottom layers. However, when attempting to export the routing files to a manufacturing house, I got a failure message with errors such as: Your project doesn't contain a bottom copper file and Your project doesn't contain a bottom solder mask.

              So this made me realize that, even though I created the package to have copper on both Top and Bottom layers, the board layout kept both sets of copper on the Top layer.

               

              After this, I attempted to create a device which had only one set of fingers so I could put device on the Top layer and another on the Bottom layer. However, apparently Eagle will not allow me to put a device on the Bottom layer.

               

              Can anyone tell me if there is something special I need to do to accomplish this or if I am going about the process of adding edge connector fingers to a board incorrectly and how I may do it differently?

               

              Thank you very much in advance!

               

              Troy.

               

              --

              To view any images and attachments in this post, visit:

              https://www.element14.com/community/message/237262

               

               

              Hi,

              use the "Mirror" command to put a device from

              top-layer to bottom-layer(or back)

              This will switch the layers of the device

              1,21,23,25,27,29,31,33,35,37,39,41 to

              2,22,24,26,28,30,32,34,36,38,40,42

               

              HTH

              Werner

               

                • Re: Move Part / Device to Other Layer (Bottom)
                  phased

                  Hello Werner,

                   

                  Thanks for your reply! Unfortunately, when I attempt to use the mirror function on this, Eagle does not recognize the device as an object it can mirror. Eagle does recognize the device when I use the move function so I find this strange.

                  Of course, I have attempted to move the device to another layer but that does not work. I am open to any suggestions.

                    • Re: Move Part / Device to Other Layer (Bottom)
                      Autodesk Guest

                      Am 23.03.2018 um 13:52 schrieb Troy Whipple:

                      Hello Werner,

                       

                      Thanks for your reply! Unfortunately, when I attempt to use the mirror function on this, Eagle does not recognize the device as an object it can mirror. Eagle does recognize the device when I use the move function so I find this strange.

                      Of course, I have attempted to move the device to another layer but that does not work. I am open to any suggestions.

                       

                      Hello Troy,

                      some Questions:

                      Eagle Versiom?

                      Can you try a "mirror" on an other device on the Board?

                      Its only for testing to look is the issue in eagle or the device.

                       

                      Werner

                       

                       

                        • Re: Move Part / Device to Other Layer (Bottom)
                          phased

                          Hi Werner,

                           

                          Thanks for the follow up. My version of Eagle is 8.3.2. And, yes I can do a mirror on another device on the board. I should mention that when I tried to do the mirror on the device that it did not recognize before, I got an alert saying the free version of Eagle can't perform the requested action. Some objects extend outside the allowed board area. Just for reference, my device is only about .9 inch wide by about .2 inches long and my board is about 1 inch wide by 3 inches long.

                           

                          Any help is appreciated.

                           

                          Thanks,

                           

                          Troy.

                        • Re: Move Part / Device to Other Layer (Bottom)
                          Autodesk Guest

                          Am 23.03.2018 um 13:52 schrieb Troy Whipple:

                          Hello Werner,

                           

                          Thanks for your reply! Unfortunately, when I attempt to use the mirror function on this, Eagle does not recognize the device as an object it can mirror. Eagle does recognize the device when I use the move function so I find this strange.

                          Of course, I have attempted to move the device to another layer but that does not work. I am open to any suggestions.

                           

                          Hello Troy,

                          some Questions:

                          Eagle Versiom?

                          Can you try a "mirror" on an other device on the Board?

                          Its only for testing to look is the issue in eagle or the device.

                           

                          Werner

                           

                           

                      • Re: Move Part / Device to Other Layer (Bottom)
                        Autodesk Guest

                        Troy Whipple wrote:

                        However, when attempting to export the routing files to a

                        manufacturing house, I got a failure message with errors such as: Your

                        project doesn't contain a bottom copper file and Your project doesn't

                        contain a bottom solder mask.

                         

                        You have set up your board to have a top and a bottom layer in DRC?

                        --

                         

                        Lorenz

                         

                        • Re: Move Part / Device to Other Layer (Bottom)
                          Autodesk Guest

                          Troy Whipple wrote:

                          However, when attempting to export the routing files to a

                          manufacturing house, I got a failure message with errors such as: Your

                          project doesn't contain a bottom copper file and Your project doesn't

                          contain a bottom solder mask.

                           

                          You have set up your board to have a top and a bottom layer in DRC?

                          --

                           

                          Lorenz

                           

                          • Re: Move Part / Device to Other Layer (Bottom)
                            Autodesk Guest

                            Troy Whipple wrote:

                            However, when attempting to export the routing files to a

                            manufacturing house, I got a failure message with errors such as: Your

                            project doesn't contain a bottom copper file and Your project doesn't

                            contain a bottom solder mask.

                             

                            You have set up your board to have a top and a bottom layer in DRC?

                            --

                             

                            Lorenz