8 Replies Latest reply on Jun 13, 2018 10:31 AM by mars01

    Great polygon pour performance bug in Circuit Studio Version 1.5.1 and 1.4.1

    joedoe1979

      I create a great 6 layer board (500mm x 80mm) in Circuit Studio 1.3.0. If I click with the mouse at the "Show Polygon" box under "PCB Filter" then I must wait only 1 second. After 1 second all GNG Polygons are invisible. If I do the same unter Circuit Studio 1.41 and 1.51 it need some Minutes at the same computer. If I repour all 6 layer polygons the Circuit Studio Version 1.41 and 1.5.1 need some Minutes but the Circuit Studio Version 1.3.0 need only 1 second. This is a greate performance bug. Can you solve this bug with the next update please,

        • Re: Great polygon pour performance bug in Circuit Studio Version 1.5.1 and 1.4.1
          e14softwareuk

          Hi Michael. This is a known issue that occurs in a small number of designs, see this thread https://www.element14.com/community/message/237092/l/circuitstudio-gets-extremly-slow-with-polygon#237092. Suggestions are to try a different fill method and arc approximation, if that is not sufficient then split the one polygon into two or more. Using these techniques it is possible to get something that was taking 15 minutes or more down to 1 or 2 seconds.

            • Re: Great polygon pour performance bug in Circuit Studio Version 1.5.1 and 1.4.1
              joedoe1979

              This is not a really good solution. Because you know the bug in the version 1.4.1 but you dont fix this bug in version 1.5.1. The circuit studio version 1.3.0 need for the same polygon repour process only 1 second during the new 1.5.1 version need 5 minutes at a high performance desktop computer. So in a early version the performance was excellent but now it is a nightmare. If I only klick at the polygon in my layout I must wait some minutes. Before 10 years PCB software like eagle can create polygon GND planes extremly fast but in 2018 it needs 10 minutes. Please fix the bug as soon as possible.

                • Re: Great polygon pour performance bug in Circuit Studio Version 1.5.1 and 1.4.1
                  mars01

                  Michael, don't worry, the 1.5.1 version solved no bug. 

                  It's not only this issue you just got hit with, there are other that were ... ignored.

                  One year of "hard work" from Altium programmers team on Circuit Studio and it brought us the same bugs and some slight polish on the features.

                  After all the polls, all the bug reports.

                   

                  I think that having Element14 to take the blame is Heaven for Altium they actually can get away with doing (almost) nothing. Like I said in another post, the work done for the Circuit Studio update 1.5.1 is a one day, 2 day job for an experienced programmer, most of the time spent in (re)familiarizing with old code base.

                    • Re: Great polygon pour performance bug in Circuit Studio Version 1.5.1 and 1.4.1
                      joedoe1979

                      I think the Circuit Studio Software is the best PCB Software in the market. I love the software. I make hight speed boards like USB 3.0 with 5GHz signals but this polygon bug is extreemly painfully. I hope the next version get some more shortcuts or better user defined shortcuts.

                        • Re: Great polygon pour performance bug in Circuit Studio Version 1.5.1 and 1.4.1
                          e14softwareuk

                          If you are needing custom shortcuts then search these forums - it is possible to define your own by 'hacking' a file.

                          • Re: Great polygon pour performance bug in Circuit Studio Version 1.5.1 and 1.4.1
                            mars01

                            I think that at this level of PCB's that you are doing it's no longer the merit of the tool but the merit of the one doing the design. I don't say that CircuitStudio is good for nothing, I say that it gets no attention from the development team and that's the reason of still having this bug.

                            If bugs are identified, bugs must be solved. Not doing this is equivalent with breaking the trust we invested when buying this tool.

                             

                            Peter is giving you a sound advice with the shortcuts.

                            Although not seeing the pours (only the outlines) can make it difficult to judge a route in a dense PCB.

                            Modifying this file can give you additional shortcuts:

                            C:\Program Files (x86)\Altium\CS\System\AdvPcb.rcs

                             

                            You can open it with a TXT Editor (my preference goes to Notepad++) and modify Shortcut1='' variables:

                            Line 655: PL PLPCB:PourAllPolygons                        Command='PCB:ChangeObject'                                        Caption='Set All To Poured'                      Image=''                     Shortcut1=''                            Shortcut2=''                           Params='ContextObject=Polygon|Action=PourAllPolygons'                                                    Description='Set Poured State On All Polygons'                           End
                            Line 660: PL PLPCB:UnpourAllPolygons                      Command='PCB:ChangeObject'                                        Caption='Set All To Unpoured'                    Image=''                     Shortcut1=''                            Shortcut2=''                           Params='ContextObject=Polygon|Action=UnpourAllPolygons'                                                  Description='Set Unpour State On All Polygons'                           End
                            1 of 1 people found this helpful
                              • Re: Great polygon pour performance bug in Circuit Studio Version 1.5.1 and 1.4.1
                                joedoe1979

                                Thanks for the shortcut tip. So I create a new shortcut for "move selection by" in the file. This helps me a lot. So I can create my own shortcuts.

                                 

                                PL PLPCB:OffsetSelection                    Command='PCB:OffsetSelection'                                 Caption='Move Selection by X, Y...'          Image='OFFSETSEL.BMP'Shortcut1='Shift+Ctrl+M'                        Shortcut2='' End
                                  • Re: Great polygon pour performance bug in Circuit Studio Version 1.5.1 and 1.4.1
                                    mars01

                                    Michael, I have no idea if creating from scratch new entries will yield something, I guess it's try and see ...

                                    I don't even think that all the possibilities listed in the file are available, because if the functions behind those shortcuts are not there then you get nothing, shortcut or no shortcut.

                                    There are a lot of places in CircuitStudio where it can be seen that it was made by chopping an old version of Altium Designer.

                                    In the end, for myself I managed to add a lot of shortcuts that I am used to, some from Altium Designer and some from the time when I used to use Eagle.