0 Replies Latest reply on Jul 6, 2018 12:25 PM by jaza_tom

    How do I make the interactive router avoid obstacles?

    jaza_tom

      Because the autorouter is useless (see other posts on this point), I am left with no other option than to attempt to route my board manually.

       

      Sadly, it appears that the interactive router in CircuitStudio doesn't work either.

       

      I can't get the interactive router to avoid obstacles.  It keeps defaulting to "Ignore obstacles"... this seems like a bug.  Even after I tab into the interactive router settings to deselect "Ignore Obstacles" checkbox, it apparently immediately decides that it should re-check that box silently without warning me.

       

      I'm using CS V1.5.1 build 13

       

      See the video for proof:

       

       

       

       

      EDIT:
      I was able to resolve this problem by selecting a different interactive routing mode from the Current mode dropdown menu in the interactive routing preferences dialogue that is shown in the video.  Apprently, deselecting "ignore obstacles" is not enough.