0 Replies Latest reply on Jul 11, 2018 4:53 AM by hkraspi2

    PiFace Digital2 no longer works with  wiringpi 2.46 under current Raspbian 2018-06-27

    hkraspi2

      Hi erveryone,

       

      May be you can give a hint to me what can be the cause for no longer working PiFace Digital2 with new Raspbian OS 2018-06-27

       

      HW: raspberrypi 3 (not plus)

      cat /etc/rpi-issue

        Raspberry Pi reference 2017-09-07

        Generated using pi-gen, https://github.com/RPi-Distro/pi-gen, 496e41575eeb9fa13f394ffb407b7bc1d00b21c2, stage5

      grep -e dtparam=i2 -e dtparam=spi /boot/config.txt

        #dtparam=i2c_arm=on

        #dtparam=i2s=on

        dtparam=spi=on

      ls -l /etc/modprobe.d/raspi-blacklist.conf # blackist is empty

        -rw-r--r-- 1 root root 0 Sep 20  2017 /etc/modprobe.d/raspi-blacklist.conf

      PiFace Digital2 worked fine using gpio -p ...commands using bash

       

      root@pi7:~# apt-get update

      root@pi7:~# apt-get upgrade

      root@pi7:~# apt-get dist-upgrade

      >>> PiFace Digital2 stopped working

       

      Test (that worked before update):

       

      root@pi7:~# i=200;gpio -p mode $i input # using bash returned message below

       

      pinMode: You have not called one of the wiringPiSetup

        functions, so I'm aborting your program before it crashes anyway.

       

       

      Old working bash commands for PiFace no longer work with wiringpi 2.46 when accessing PiFace Digital:

       

        gpio -p mode 200 output  # fails with new wiringpi, worked with old version

        gpio -p mode 200 input   # fails with new wiringpi, worked with old version

       

        gpio mode 0 output       # works fine with old and new wiringpi

        gpio mode 0 input        # works fine with old and new wiringpi

       

       

      Hope there is a way to get out of this (bash) trap?

       

      PS: I prefer bash, worked fine for me until update, no need for another programming language so far.

       

      Thanks a lot in advance for your help