2 Replies Latest reply on Oct 15, 2018 12:51 PM by korn

    Raspberry Pi 3 no HDMI output



      After a long time I tried to turn on my RPi 3, but there is no HDMI output. I could not try the S-Video output as I don't have any device to put on.

      I changed only the RPi3 to an RPi2, and everything is perfect, so I think there is something wrong with the RPi3. Any idea how can I fix it?


        • Re: Raspberry Pi 3 no HDMI output

          Hello Robert,


          Have you tried booting your RPi3 with a clean Raspbian Install? I’d do that first for the following reason:


          Not sure how you are testing but if you are simply swaping your SD card from one Pi to the other, the configuration may not work between different versions of the Pi as the components hardware is slightly different and usually the video is the first one to fail.


          If a clean install doesn’t work, another thing you could try is a different HDMI device. If this doesn't work try finding the optimum resolution of your display and set that manually in the OS configuration.



          • Re: Raspberry Pi 3 no HDMI output

            are you're sure the pi is booting. green light flashing, network port active etc...?


            sometimes a hard power off corrupts the card.


            if its raspbian or similar there should be a dos partition on the card called "BOOT" which will mount on a pc or mac..


            edit the config.txt file and check your video settings.


            theres some good tips in there like enabling safe mode, hotplug and boost etc which all helped me at one time or another


            for one momnitor I had to force DMT mode because even though it had an HDMI connector the PI treaded it like DVI and wouldn't send audio.


            heres something close to what it should have it gives you an idea of what to expect


            # uncomment if you get no picture on HDMI for a default "safe" mode




            # uncomment this if your display has a black border of unused pixels visible

            # and your display can output without overscan




            # uncomment the following to adjust overscan. Use positive numbers if console

            # goes off screen, and negative if there is too much border







            # uncomment to force a console size. By default it will be display's size minus

            # overscan.





            # uncomment if hdmi display is not detected and composite is being output




            # uncomment to force a specific HDMI mode (here we are forcing 800x480!)




            hdmi_cvt=1024 600 60 3 0 0 0




            # uncomment to force a HDMI mode rather than DVI. This can make audio work in

            # DMT (computer monitor) modes




            # uncomment to increase signal to HDMI, if you have interference, blanking, or

            # no display




            # uncomment for composite PAL




            #uncomment to overclock the arm. 700 MHz is the default.




            # for more options see http://elinux.org/RPi_config.txt