4 Replies Latest reply on Mar 20, 2017 10:48 PM by fuwenl

    Can not generate a proper u-boot for mini-itx

    fuwenl

      Hi All,

      I followed the tutorial (Ubuntu_on_Zynq_Mini-ITX_Tutorial_04) to install Ubuntu on my mini-itx 7100.

      However, when I tried to generated u-boot, I got a serial of problems described above. 

      1. Follow the extra instructions and get warnings:

      arch/../configs/zynq_mitx_defconfig:2:warning: unexpected data
      arch/../configs/zynq_mitx_defconfig:3:warning: unexpected data
      arch/../configs/zynq_mitx_defconfig:4:warning: unexpected data

      the zynq_mitx_defconfig:

      CONFIG_SPL=y
      +S:CONFIG_ARM=y
      +S:CONFIG_ZYNQ=y
      +S:CONFIG_TARGET_ZYNQ_MITX=y
      CONFIG_OF_CONTROL=n
      CONFIG_DEFAULT_DEVICE_TREE="zynq-mini-itx"

      the u-boot-xlnx is download from GitHub and the branch is xilinx-v2014.4

      I think that the defconfig file may be incorrect so I checked zynq_zed_defconfig find that they are quite different. Therefore,

      2. I copy all contents of  zynq_zed_defconfig into zynq_mitx_defconfig and rm "+S:" of the original lines. I can generate u-boot this time but can not boot my mini-itx 7100 (program done led keeps flashing).

      I also tried to follow other verisons of tutorials but get nothing. The  zynq_mitx_defconfig of tutorial 2013.3, tutorial 2014.4, tutorial 2015.3 are all different.

      Any help is appreciated

        • Tutorial
          elliemellie

          Not sure if it will help, but I will try anyway. Last time I was installing Ubuntu on Zyng mini itx I followed Ubuntu_on_Zynq_Tutorial_03. There were a few issues here and there but I withstood them with some googling,

           

          Cheers
          Ellie

            • Hi Ellie,
              fuwenl

              Hi Ellie,

              I tried the verision you suggest and get the following issue:

              make -C arch/arm/cpu/armv7/zynq/ u-boot.lds
              make[1]: Entering directory `/root/2013/u-boot-xlnx-xilinx-v2013.4/arch/arm/cpu/armv7/zynq'
              make[1]: *** No rule to make target `u-boot.lds'.  Stop.
              make[1]: Leaving directory `/root/2013/u-boot-xlnx-xilinx-v2013.4/arch/arm/cpu/armv7/zynq'
              make: *** [arch/arm/cpu/armv7/zynq/u-boot.lds] Error 2
               

              It seems the u-boot.lds file is not generated. Did you have that issue?

              Thank you very much for you reply.

            • RE: Can not generate a proper u-boot for mini-itx
              zedhed

              Hi fuwenl,

              Have you tried building for the ZedBoard using "make zynq_zed_config"?

              That one should definitely work, so if it does not, then there is likely an issue with the build environment.

              Regards,

              -Kevin