2 Replies Latest reply on Feb 20, 2018 7:10 PM by brc6

    Re-customize IP preset not showing up




      We have acquired a Mini-ITX 7z100 board and are trying to set it up. We managed to install the board definition files for Vivado and create a new project for that board. However, after adding the Zynq7 PS to the block design, when we open the "Re-customize IP" dialog, there is no preset in the list for our board. The only presets that show up are for ZC702, ZC706 and ZedBoard (which are installed by default with Vivado). The "preset.xml" file is present in "C:\Xilinx\Vivado\2017.4\data\boards\board_files\mini_itx_7z100\1.0", but it seems to be ignored by Vivado.


      Is it expected? If so, how are we suppose to customize the IP to match the board then?


      There is a similar topic from 2014 posted in the PicoZed board, but with no solution to this specific problem:




        • Hello BR,

          Hello BR,

          You installed the "Zynq Mini-ITX Board Definition Files Vivado 2015.3 or later" correct?

          Did you follow the instruction tutorial located in that download to ensure everything was installed correctly?

          It appears you installed it in the correct path.

          Did you specify you wanted to use the board definition file during the creation of your project?


            • Solved



              Yes, we've installed the version you quoted and it was correctly installed as the board appears in the new project wizard. We have even created a new project for that board, so the files are installed correctly.


              Our problem was that no board specific preset is showing up in the "Re-customize IP" dialog for the Zynq. After reading the board definition file document more thoroughly, it appears this is not a problem as the "Run Block Automation" command will actually find and apply the correct preset (even though it does not show up in the list!?). We've used other boards in the past, and there was always a preset for those boards in the "Re-customize IP" dialog after installing the correct files, so we were a bit confused this is not the case with this new board.


              So, problem is solved now. Thank you.